Sean VanDruff
1 Copper

VMware View Connection Failure with upgrade to PockCloud Pro

VMware View Connection Failure with upgrade to PockCloud Pro

I updated my PocketCloud to PRO this morning on an iPhone and an iPAD, after the update, I cannot connect to a View desktop. We have a View 4.5 connection server and both XP and Windows 7 desktop. I can't connect to either virtual desktop now. This worked this morning when using PocketCloud version 2.0 (paid version). What might have changed?

The interesting thing is that it seems to connect to the connection server when trying to set up a new computer connection. It lets me see the View domain and choose one of the VMware desktop choices, but once we try to connect it fails.

When trying to connect I get the following error: VMWare View Connection Failed! Please check your connection settings and try again.

The connection server has a self signed SSL certificate.
Both the iPhone and iPad are running iOS version 4.2.1.

0 Kudos
18 Replies
Highlighted
MikePA-2015
1 Copper

RE: VMware View Connection Failure with upgrade to PockCloud Pro

Try replacing the host name with the IP address.

0 Kudos
Sean VanDruff
1 Copper

RE: VMware View Connection Failure with upgrade to PockCloud Pro

We are using an IP address in the View Server field.

Thanks,

Sean

0 Kudos
MikePA-2015
1 Copper

RE: VMware View Connection Failure with upgrade to PockCloud Pro

Quote Originally Posted by Sean VanDruff View Post

We are using an IP address in the View Server field.Thanks, Sean 
Bummer.

After I installed 2.1.217, when I tap on the VMWare View connection, the same error message you are seeing IMMEDIATELY pops up. It's like it's not even trying anything. I changed the name of our View server to its IP address which solved the problem.

EDIT: Something is very broken with the new release and WYSE staff are conspicuously absent

0 Kudos
Sean VanDruff
1 Copper

RE: VMware View Connection Failure with upgrade to PockCloud Pro

After much frustration we were able to revert back to PocketCloud 2.0 and connectivity the Connection server and View desktops is working again. I would like to understand what is wrong with the latest version and when it will get fixed.

Luckily some of my team still had the older version of PocketCloud and we were able to copy over to my iPhone and iPad.

0 Kudos
Suchitha
3 Cadmium

RE: VMware View Connection Failure with upgrade to PockCloud Pro

Hi Sean, Can you please give some information on your view server settings?

ssl on or off? 
Tunneling on or off?
Is RSA enabled on the server?

Thanks! 

 

 


Wyse PocketCloud Team

0 Kudos
dantech
1 Copper

RE: VMware View Connection Failure with upgrade to PockCloud Pro

Same issue since upgrade to 2.1.217

Hi,

We get a very similar issue since upgrade to 2.1.217. When loading an existing connection and/or setting up a new connection (just after selecting desktop). Both are as soon as the app attempts to connect to the view server the app bombs out (after about 1-2 seconds). No error messages are seen.

This has been seen on iPhone 3GS running iOS 3.1.3.

The view systems tested on are running view 4.0 and view 4.5, with the following config:
- Use SSL (Port 443).
- No tunnelling.
- No RSA any other external auth (just using username and password).

Diagnostics so far:
- The same issue happens with 3G, GPRS or WiFi connectivity.
- Same issue when on same network (via WiFi) as the view server and public (both view WiFi, 3G and GPRS).
- No difference on View servers with publicly verifiable certs and locally generated (view 4 system with public cert, view 4.5 with local cert).
- RDP to Terminal server still works without issues.

Both worked fine on Sunday (before update to 2.1.217), and neither work now.

Has anyone found a work-around, or is another update from Wyse iminent?

Is there a way of reverting to the previous version as I don't have a backup of the previous files?

Regards,

Dan

0 Kudos
Suchitha
3 Cadmium

RE: VMware View Connection Failure with upgrade to PockCloud Pro

I just tried it on my ipad,ios:4.2.1 , was able to connect to a ssl view server desktop. Is it possible to give us a test account on your view desktop so we can test from here.
Thanks! 

 

 


Wyse PocketCloud Team

0 Kudos
timdyke
2 Bronze

RE: VMware View Connection Failure with upgrade to PockCloud Pro

How did you revert back

0 Kudos
timdyke
2 Bronze

RE: VMware View Connection Failure with upgrade to PockCloud Pro

I did a capture and I noticed that there is a change in the TSL protocol. The old version 2.1.200 used TLS version 1.0, and the new version uses TLS version 1.2.
We are using a verisign assigned cert, but we are accessing the server via IP address, so the cert does fail. normally we just accept and install the cert and everything works.
Perhaps this is our issue.

How can one roll back once the iTunes on my laptop has been updated with the new version of the APP.

0 Kudos