Highlighted
8 Krypton

View 4.6 Connection Problem w/PocketCloud Pro

View 4.6 Connection Problem w/PocketCloud Pro

I have installed Pocket Cloud Pro on my iPad2, which is WiFi only. I connect to my company network using the Cisco IPSEC VPN connection native to the iPad. I can configure an RDP session to my VDI workstation and connect using RDP just fine. I then try to configure a View session but cannot even finish configuring the connection. I have entered the nickname, server name, user name and password. When I press the VMware Domain tab it connects and shows my domain so I can select that OK. Then, when I press the VMware Desktop tab I get the dreaded PocketCloudPro error:

"VMWare View Connection Failed! Please check your connection settings and try again."

At this point I go back to My Computers in Pocket Cloud and try to start that View session and get another error:

"Please press "Edit" on your VMware View connection and choose a Desktop before going forward."

I then press OK and am back in the My Computers menu.

It looks like I have some sort of setup error so I checked everything I can think of. Here's more relavent info:

SSL is on or off (both fail)
My connection server is setup using FQDN or IP address (both fail)
Installed Net Utility app and CAN ping my connection server by both IP and FQDN. Response time is typically 10-15 ms
DNS entries are correct, including PTR record
I CAN browse to connection server in Safari using IP and FQDN
VMware View 4.6
iPad 2 OS 4.3.3.3
Pocket Cloud 2.1.217
VMware View app (can't find version #)

Here's the big kicker. I have also installed the VMware View app and it connects to my View workstation with no problems. I see my available pool instantly and when I press that I load the desktop right away.

So...Pocket Cloud sees the connection server because it loads the domain configured on my connection server...but fails to see the desktops. It appears I am completely configured correctly since the VMware View client works using the same settings.

Is there a fix for this?

0 Kudos
11 Replies
8 Krypton

RE: View 4.6 Connection Problem w/PocketCloud Pro

Gunnertac, where did you install the vmware view app ? Was it on another desktop ?

 


Wyse PocketCloud Team

Tags (2)
0 Kudos
8 Krypton

RE: View 4.6 Connection Problem w/PocketCloud Pro

Quote Originally Posted by Suchitha View Post
Gunnertac, where did you install the vmware view app ? Was it on another desktop ?

 

No...the vmware view app is on the same iPad that the PocketCloud app is loaded. I made sure the vmware view app was killed in memory before using the PocketCloud app to be sure there wasn't any conflict.

Tags (2)
0 Kudos
8 Krypton

RE: View 4.6 Connection Problem w/PocketCloud Pro

Hi gunnertac,

Regarding vmware view app, and pocketcloud app,
1)Are you using the same view server and same desktop to connect?
2)Are you using the same username?

Can you please login to your view server admin tool.
Click on Inventory-pools
choose your desktop
click on entitlement
Do you see your username listed?

Thank you!

 

 


Wyse PocketCloud Team

Tags (2)
0 Kudos
8 Krypton

RE: View 4.6 Connection Problem w/PocketCloud Pro

Hi Gunnertac,

One more quick thing you can try before you look into my questions.
Please edit your connection, choose your domain once more. Now select your desktop. Does it show up?

Thank you!

 


Wyse PocketCloud Team

Tags (2)
0 Kudos
8 Krypton

RE: View 4.6 Connection Problem w/PocketCloud Pro

Quote Originally Posted by Suchitha View Post
Hi gunnertac,

Regarding vmware view app, and pocketcloud app,
1)Are you using the same view server and same desktop to connect? Yes (We have only one view server)
2)Are you using the same username? Yes (I am admin and have tried with several different usernames and desktops)

Can you please login to your view server admin tool.
Click on Inventory-pools
choose your desktop
click on entitlement
Do you see your username listed? Yes

Thank you!

 

Answers to your questions are above in the quote.

I am using a manual pool with each desktop assigned manually to each user. I have a test environment with 3 view desktops and 3 users. Each user has their own desktop. All 3 users show in Entitlements to the pool. Also, I can see in Desktops that user is assigned to a specific desktop.

Tags (2)
0 Kudos
8 Krypton

RE: View 4.6 Connection Problem w/PocketCloud Pro

Quote Originally Posted by Suchitha View Post
Hi Gunnertac,

One more quick thing you can try before you look into my questions. 
Please edit your connection, choose your domain once more. Now select your desktop. Does it show up?

Thank you!

 

In view configuration screen I press VMware domain. It goes to a screen that shows only 1 domain...my correct domain. I can do nothing other than press Save or Cancel so I press Save. It goes back to the connection settings screen. I then press VMware Desktop and that's when the error pops up. I just did all this and the error it still there. I have deleted my connection and retried with different users and get the exact same results at this part of the process. Using the exact same settings in the VMware View app works. 

0 Kudos
8 Krypton

RE: View 4.6 Connection Problem w/PocketCloud Pro

Hi Gunnertac,

Just create a connection with domain name and no desktop.
Now edit the connection, Once again Add the domain and try pulling the desktop.
Does that help?
Please make sure you put the external ip address of the view server.
we had some issue in the past with the dns name.

Thanks!
suchitha

 

 


Wyse PocketCloud Team

0 Kudos
8 Krypton

RE: View 4.6 Connection Problem w/PocketCloud Pro

No success. I created a new entry and entered the minimum...nickname, view server by IP, user name and password and pressed vmware domain. I see my domain (unchecked) and press it to select, then Save. At that point I went back to My Computers without trying to select a desktop. I then edit the connection and try to add desktop and get the connection failed error.

0 Kudos
8 Krypton

RE: View 4.6 Connection Problem w/PocketCloud Pro

Hi gunnertac, when you edit connection once again please choose the domain. Looks like you just picked the desktop

 

 


Wyse PocketCloud Team

0 Kudos