Highlighted
kenknight
1 Nickel

RE: url schema for iOS not working

Well it has nothing to do with the content-disposition. I used the php script to return exactly what you have as a sample and it launches pocketcloud and that is the end of it. No message or any other indicator.

The return packets from the php script are as follows;

=========================================

HTTP/1.1 200 OK
Cache-Control: no-cache, must-revalidate
Pragma: no-cache
Content-Type: application/x-rdp
Server: Microsoft-IIS/7.0
Content-disposition: inline; filename=3690986a861c449c977394b80230724c.rdp
X-Powered-By: ASP.NET
Date: Wed, 26 Oct 2011 01:51:04 GMT
Content-Length: 152

username:s:xxxxxxxxxxxxxxxx
pocketcloud password:s:xxxxxxxxxx
full address:s:xxxxxxxxxxx
server port:i:xxxxxxx
domain:s:xxxxxxxxx

=========================================

The url I'm attempting to launch pocketcloud with is as follows;

pocketcloud://mydomain.com/myapplication/tablet_rdp.awp?s=asdf98asdf0s9df9sdf9sdfs0d0

Cheers!
Ken

0 Kudos
kenknight
1 Nickel

RE: url schema for iOS not working

WooHoo! Got it working!

The problem is apparently PocketCloud is expecting an RDP filename in the url and doesn't allow the '?s=asdfoasdf' parameter I was trying to pass to my server. The work around was to utilize IIS 7's URL rewrite functionality. I added a map that uses the regular express of '^rdp_session/([_0-9a-z-]+).rdp' and maps it over to '/myapplication/tablet_login.awp?s={R:1}'. 

With the above rule;

http://mydomain.com/rdp_session/233412312312asff.rdp

becomes

http://mydomain.com/myapplication/ta...3412312312asff

in the background.

Gotta love URL rewriting!

Cheers!
Ken

0 Kudos