Wyse Software General

Last reply by 08-24-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Dell wyse thin client 5060 usb imaging tool v3.0

Capture.PNGCapture1.PNGi am trying to use the dell wyse usb imaging tool version 3.0 which if im not mistaken is the newest version. when i plug my usb device into the machine i am able to see the usb in device manager, file explorer and disk managment. i have formatted it multiple time to nfts, the drive shows available when i hit the usb drives button on the bottom of the imaging tool on the left hand side, but when i select the drop down box to select the drive it not showing a usb drive. i have wiped the disk off the usb drive, created new partitions, deleted them , created new volumes, changed disk assignment letters, still not showing in the drop down for me to select on the imaging tool.


Replies (20)
2 Bronze
2 Bronze

Hi, I am having the same issue with the imaging tool detecting the usb device. I've tried multiple usb pens from an array of vendors and in different sizes formatted exfat, fat32 etc but the imaging tool is not showing any of them as available drives.

merlin version 3.8.3

wyse terminal 5070

Dell Wyse USB Imaging Tool


Any update on this? I am having the same issue as Cerdinal with same versions. Same results on both Wyse 5060 and 5070. Using a Kingston Data Travller 3.0 64GB, which is supposedly a Dell verified USB for compatibility.

It's weird that when I plug in 2 USB's, the first page will change to recognize and pluralize Drives, yet it will not populate them to let me select it. Already tried everything I've found on the internet about this.


From the Imaging Tool User Guide: Note: If you are installing USB Imaging tool version 3.1.0 on a thin client device, ensure that you disable the File-Based Write Filter (FBWF) on the device. From Dell Tech Support: The USB drive must be setup for a pull operation using the Imaging Tool on a desktop. It will only become available as a selection on the Thin Client once it is preconfigured for the device. If the Imaging Tool cannot be used on the Thin Client to configure the USB for a pull operation, then perhaps SPECIFY that in the manual, instead of leading on about requirements for installing the software on the thin client, and listing it as compatible. Typical Dell.

From what I have found out this only works on Windows 10 Enterprise or Windows 7 ultimate/Enterprise? Haven't been able to confirm this but seems weird. If anyone has any ideas as to how that works I wouldn't mind knowing. Thanks.

2 Bronze
2 Bronze

You really have to change the USB's drive letter to A: or B:.
It is the only modification that made it work for me. 
Good luck!


I can confirm, it works. I changed drive letter from F: (in my case) to B: and I was able to flash ThinOS to pen drive. I used imaging tool 3.1.0 on Windows 10 Home on my laptop.

2 Bronze
2 Bronze

Thanks a lot! Changed the drive letter to A: and it worked! Thank you!!!


Drive letter change worked for me as well..  Switched to A and worked perfectly

2 Bronze
2 Bronze

Ran into the same issue. Couldn't get it to work with any of my flash drives (tested both USB 2.0 or 3.0), even changing the drive letter to A or B.

Ended up installing the wyse usb imaging tool (3.4.0) along with .NET framework 3.5.0 in a Windows 10 virtual machine (in VMware Workstation), and it finally detected.

2 Bronze
2 Bronze

Changing drive letter to A or B did not work for me either. In fact, doing so seems to have removed it form the "USB Drives" in the tool itself (the drive shows up in Windows just fine though). 

This is ridiculous. I can't even get it to show up on my laptop, much less the thin client. 

Latest Solutions
Top Contributor