Highlighted
2 Bronze

WMS 1.4 OpenSSL certificats issues

Hi

In Portal Administration / Setup

I did'int manage to import an OpenSSL certificate.

First I tried with Key/Certificate Pair.

I have obtained my cert from DigiCert.

So I converted crt to pem because only PEM format is accepted (https://www.dell.com/support/manuals/fr/fr/frdhs1/wyse-wms/wms_1.4_ag/gestion-de-la-configuration-du...)

When I tried to upload  cert, key and intermediate cert : Could not save at this time. Please check your certificates and try again.

 

So I converted them to pfx. And when I tried to upload : Failed to import certificate: Invalid certificate chain: the trustAnchors parameter must be non-empty. Select "Skip verify and Save" to skip validation. This is not recommended.

I found nothing in logs...

Any help would greatly appreciated 😉

0 Kudos
1 Reply
Highlighted
1 Copper

Re: WMS 1.4 OpenSSL certificats issues

I converted from PFX to CERT + KEY file.

openssl pkcs12 -in cert.pfx -out cert.pem -nodes
openssl pkcs12 -in cert.pfx -nocerts -out key.pem

Edit: Added the CA Bundle not only intermediate, all solved

Double check to be sure: openssl s_client -connect site.something:443

only funny, is Verification error: self signed certificate in certificate chain which is of course not true, unless the old self signed certificate is saved somewhere. 

Check ends with "Verify return code: 19 (self signed certificate in certificate chain)"

 

0 Kudos