Cannot USB re-direct over RDP with remotefx

I have a wyse thin client, running 8.5 And a WMS server setup that it is connected to. Everything seems to be working fine except I cannot for the life of me get usb drives to re-direct. This is just a test setup on a hyper-v server, so I'm not working with a broker for RDP right now. I have tested just using my laptop to redirect the usb and it works just fine.

On the thin client, when I plug in a usb drive I can see the events pop up, saying "mass storage connected" VUSB redirect-able device etc. All looks normal.


On the WMS I'm a bit confused. There are 3 areas I am seeing for usb re-direct, and I have tried every combination I can think of to try and make something do something. The first is under "Global Session Settings". From google someone suggested to disable all of it, because ThinOS will try and use TCX or something and if you're trying to use RDP it will fail. I have tried enabling everything, and disabling it all, still no usb.


Second is under "Microsoft RDP Settings" I have USB Redirection Technology set to RDP.


Lastly, Direct RDP Connections, since I'm skipping a broker for now. I have an option to "Map USB drive/s" that I have tried enabled and disabled, still no USB.

DNS is not the issue either, I just went over to make sure there was not anything with that, all machines are on the same server and can see each other. 

I see no errors anywhere, nothing, zip. Again I can verify with my win10 laptop connecting to this win10 VM I am able to usb redirect a flash drive without issues. Just can't do it in ThinOS. What the **bleep** am I missing here?


Edit: I'm testing with just a flash drive, and a usb to serial adapter just to see what happens.

0 Kudos