Highlighted
mr.sarge
1 Copper

D10D + Citrix PS4.0?

Question D10D + Citrix PS4.0?

Hi,

any chance to get working a D10D client with Citrix PS4.0? We plan to upgrade to the latest XenDesktop version next year, until then I have to found a way to get new clients working with PS4.0

We use a lot of Wyse Clients (S10, C10LE, R10L) and they are still working without problems. When I try to connect with a D10D client (ThinOS 8.0_214) I receive only a black screen with mouse cursor visible.

The ini-configurations looks like this:

WNOS.INI
#Enable sign-on process
signon=1

#Default signo-on user = PC-Name
Defaultuser=$TN

#Bitmap filename displayed in the sing-on window
FormURL=logo.jpg

#Display all 38 characters in a desktop icon name
LongApplicationName=yes

#Controls how the system starts when the power ist first applied to the thin client
AutoPower=no

#Save connections persistent in NVRAM (prevent FTP-Single Point of Failure)
enablelocal=yes

#Screensaver
screensaver=0

#Test
IcaBrowsing=UDP

#Do not save license in NVRAM
FixLicense=clean

#Specifies the local audio volume
device=audio volume=0

#Set the time
TimeZone="GMT + 01:00" ManualOverride=yes daylight=yes start=030507 end=100507
TimeServer=10.0.10.2

#Specifies the desktop background color in RGB string format
DeskColor="0 128 128"

#Lock down thin client
privilege=none lockdown=no

#Remote shadow options
VNCPrompt=no
VncPassword="OPDPPHDDKDGAKKHMLMCP" Encrypt=yes
MaxVNCD=1

#Disable Wyse Device Manager Service
Service=WDM disable=yes

#This will upgrade to firmware if a newer version exists in the ftp directory
AutoLoad=1


PC-INI
#set screen resolution and refresh rate
resolution=1680x1050 Refresh=60

#Lock down thin client
#privilege=high
#privilege=full
privilege=none


#Set correct language
language=de

#Set Mouse Speed
MouseSpeed=0

#Setup a connection to an ica server
connect=ica \
description="xyz" \
icon=ica.bmp \
domainname=xyz \
HttpBrowsing=no \
browserip=ica2.xyz.com \
application="xyz" \
username="" \
Fullscreen=yes \
autoconnect=yes \
localcopy=no

Tags (2)
0 Kudos
1 Reply
mr.sarge
1 Copper

RE: D10D + Citrix PS4.0?

Hi,

solution: add following parameter to wnos.ini: "SessionConfig=ICA FlipByTimer=1"

best regards

Tags (2)
0 Kudos