xtec-2015
1 Copper

T10 USB Printer Redirection issues, 7.x to 8.x

Exclamation T10 USB Printer Redirection issues, 7.x to 8.x

Using the DOVE_Boot firmware 7.1_207 with the following wnos.ini file printer USB redirection works correctly.

When updating to DOVE_boot firmware 8.0_206 with the same wnos.ini file printer USB redirection does not work.

I noticed that when using firmware 7.1_207 the event viewer on the thin device was correctly detecting the USB port that the USB printer was using.

The new firmware does not detect USB port for this printer at all.

wnos.ini

;************************************************* ************
;* *
;* This wnos.ini file was generated with the *
;* Configuration File Generator 6.4.09 *
;* Copyright by Thomas Moellerbernd *
;* *
;* http://www.technicalhelp.de *
;* *
;************************************************* ************


;************************************************* ************
;* General 1 *
;************************************************* ************

autoload=1
AdminMode=yes Admin-Username=MEAFMNABMK Admin-Password=OGGCLDGEOADNKMHOKCHELE
Privilege=None
EnableCacheIni=yes
MirrorFileServer=yes

;************************************************* ************
;* General 3 *
;************************************************* ************

;AutoSignoff=yes Shutdown=yes
;Shutdowncounter=0
;ShutDown=turnoff

;************************************************* ************
;* Peripherals *
;************************************************* ************

Device=audio Volume=25

;************************************************* ************
;* Display *
;************************************************* ************

; If you are using a version of WTOS code < 7.0.1_13 please use:
; Resolution=1280x1024 Refresh=
Screen=1 Resolution=1280x1024
Dualhead=yes MonitorAutoDetect=yes
ShutDownInfo=yes

;************************************************* ************
;* Time *
;************************************************* ************

Timeserver=10.139.191.13 Timeformat="24-hour format" Dateformat=mm/dd/yyyy
TimeZone='GMT - 05:00' ManualOverride=yes Daylight=yes Start=030207 End=110107 TimeZoneName="Eastern Standard Time" DayLightName="Eastern Daylight Time"

;************************************************* ************
;* Network *
;************************************************* ************

SignOn=Yes
DisableDomain=yes
DomainList="PPIN"

;************************************************* ************
;* Services *
;************************************************* ************

Service=SNMPD disable=yes
Service=ThinPrint disable=yes
Service=VDA disable=yes

;************************************************* ************
;* General Session *
;************************************************* ************

SessionConfig=ALL MapDisks=yes VUSB_DISKS=yes Fullscreen=yes

;************************************************* ************
;* ICA *
;************************************************* ************

IcaBrowsing=HTTP
Seamless=yes
;PnliteServer=https://10.139.191.15 AutoConnectList="Microsoft Word" CAGAuthMethod=LDAP DefaultSettings=XenApp
PnliteServer=https://ccoe.ppin.state.mi.us CAGAuthMethod=LDAP DefaultSettings=XenApp
;PnliteServer=https://ccoe.ppin.state.mi.us CAGAuthMethod=LDAP
SessionConfig=ICA DesktopMode=Fullscreen SessionReliability=yes AudioQuality=Medium USBRedirection=HDX

;-------------------------------------------------------------
;- ICA Session 1 -
;- Each line but the last must end with a '\' -
;-------------------------------------------------------------

;CONNECT=ICA \
; BrowserIP=10.139.191.11:8080,10.139.191.7:8080 \
; Application="Microsoft Word" \
; Description="Microsoft Word" \
; AutoConnect=yes \
; Encryption=128 \
; Colors=true \
; Fullscreen=yes \
; Resolution=1280x1024 \
; Logon_Mode=local-user \
; Domainname=PPIN \
; HTTPBrowsing=yes \
; SessionReliability=yes \
; LocalCopy=yes

Tags (3)
0 Kudos
11 Replies
lulin
1 Nickel

RE: T10 USB Printer Redirection issues, 7.x to 8.x

could you give the log of WTOS?

Tags (2)
0 Kudos
xtec-2015
1 Copper

RE: T10 USB Printer Redirection issues, 7.x to 8.x

I don't know of any way of getting the event logs off of the WTOS device in any kind of text file to send to you. If you have some suggestions they would be appreciated.

Tags (2)
0 Kudos
xtec-2015
1 Copper

RE: T10 USB Printer Redirection issues, 7.x to 8.x

If you have a test environment set up with a Wyse T10 device and DOVE_BOOT firware version 7.1_207 loaded on the device. Do the following:

1. boot the device with a USB printer plugged into it using the 7.1_207 firmware and check the event logs. This will have the proper VUSB information for a citrix session to use for USB redirection.

2. boot the device with the same USB printer plugged into it using the 8.0_206 firmware and check the event logs. This will have different information in it that does not include the proper VUSB printer information.

Tags (2)
0 Kudos
Gongyi
1 Copper

RE: T10 USB Printer Redirection issues, 7.x to 8.x

Hi, xtec

I have checked it, 8.0_206 can detect the USB printer, and the VUSB logs are correct. Could you take a photo for the event logs?

Tags (2)
0 Kudos
Highlighted
xtec-2015
1 Copper

RE: T10 USB Printer Redirection issues, 7.x to 8.x

screen shots of event viewer for both firmwares

Tags (2)
0 Kudos
xtec-2015
1 Copper

RE: T10 USB Printer Redirection issues, 7.x to 8.x

VUSB redirection

The USB printer shows up in the event logs for both firmwares. The problem is that when in a Citrix Session that has USB redirection enabled from the Citrix Application Host server to the thin device "T10" the Virtual USB channel does not get hooked up properly.

When I use the older firmware 7.1_207 the Virtual USB channel does get hooked up and I can print through my Citrix Session.

Tags (2)
0 Kudos
xtec-2015
1 Copper

RE: T10 USB Printer Redirection issues, 7.x to 8.x

USB Printing through Citrix Session using VUSB Channel

USB Printing through Citrix Session to the Wyse T10 thin device using VUSB Channel still not working using the new firmware update 8.0_208 BETA.

Tags (2)
0 Kudos
lulin
1 Nickel

RE: T10 USB Printer Redirection issues, 7.x to 8.x

please send me the log by mail: llu@wyse.com as the pic in the post is not shown

which type/brand of the printer? e.g. HPxxxx?

Tags (2)
0 Kudos
xtec-2015
1 Copper

RE: T10 USB Printer Redirection issues, 7.x to 8.x

Printer

Ricoh Aficio SP 4310N

Printing from Citrix Application Host Server through the Wyse T10 thin device USB connected to printer.

OLD FIRMWARE 7.1_207
With the old firmware 7.1_207 and using the same wnos.ini and citrix settings "USB redirect" enabled the printer que gets created and set as the default printer which allows us to print spooled jobs from the application host server to the Wyse T10 thin device.

The print jobs are spooled on the Application host server in the created Ricoh Print QUE. Then the job is sent through the Virtual USB channel from the application host server to the Wyse T10 thin device that has USB connected printer. (The print jobs Print Successfully). Check the source code for this firmware to see how they are creating the Virtual USB channel and also newly created Ricoh Print QUE at login. (This newly created print que is also set as default printer)

NEW BETA FIRMWARE 8.0_208
The Application host server does not create the "Ricoh print QUE" so the jobs have no where to go.

Tags (2)
0 Kudos