KeepSAL
1 Nickel

Wyse 3040 Thin OS NLA RDP issue

Hello,

Maybe somebody of you already facing this issue.

Is Network Level Authentication supported by Thin OS? I would like to use Remote Desktop Connection with NLA turned on but without error messages Smiley Happy

I'm currently running on 8.6_013 Thin OS and if NLA is turned on at RDP host I get login window in ThinOS to type my credentials (in my case Smart Card) and in "System information" the first error is: NLA CredSSP Authentication failed, please check credentials and connection settings. and ERROR: Connection Failed!. RDP connection is configured in WMS as Direct RDP.

After entering my PIN to smartcard Thin OS pass me to Windows login, but with another error "This smart card could not be used. Additional details may be available in the system event log.

In event log is:

            Status code:      0xC000006D -------> STATUS_LOGON_FAILURE

            Substatus code:            0xC0000321 --------> STATUS_SMARTCARD_SUBSYSTEM_FAILURE

 

Then I pass this message by OK and reentering PIN to log in my user. 

Without NLA, RDP session starts without any issues just as is expected (directly to Windows login and asking to enter a PIN.

Thanks in advance

Tags (3)
0 Kudos
4 Replies

Re: Wyse 3040 Thin OS NLA RDP issue

Please open a support case on this.

0 Kudos
KeepSAL
1 Nickel

Re: Wyse 3040 Thin OS NLA RDP issue

Hi, Thanks for the answer. I'm already tried to contact DELL support, but they only provide Software support if you have purchased ProSupport. So, unfortunately, that's not my case. It's quite disappointing that without ProSupport you are not able to get appropriate support to their products.
0 Kudos

Re: Wyse 3040 Thin OS NLA RDP issue

Are you able to test NLA, without smart card auth?   It sounds to me like the smart card auth may be the issue and not NLA.  I have used NLA auth with RDS on ThinOS in the past successfully, but I am not sure the RDS client in ThinOS supports smart card Auth.  

 

0 Kudos
KeepSAL
1 Nickel

Re: Wyse 3040 Thin OS NLA RDP issue

Yes, it looks like a combination of NLA with smart card login. NLA with using standard windows credentials (username and password) is working.

I'm using Gemalto ID Prime 830 to authenticate, so maybe is not able to correctly read all the data from the certificate stored on smartcard. Or certificate is not correct?

 

0 Kudos