ben_mnd
1 Copper

Missing stored procedure

Missing stored procedure

We are currently having problems setting up a backup database on an edge server: When shutting down the primary database on the core server, the edge server tries to switch to its (local) backupdatabase unsuccessfully. Looking in the admin log file reveals the following error message:

015-03-10 08:10:00,831 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.dx.dal.DxDataSource::<init>,69> Setting DBCP initialSize to 4, maxActive to 16, maxIdle to 4, maxWait to 10000 milli-seconds
2015-03-10 08:10:15,901 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.DBConnectionChangeWat chDogTask::tryUpdateWSMDBConnection,220> Trying to switch to backup db configuration if it exists.Backup DB is local.
2015-03-10 08:10:15,902 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.DBConnectionChangeWat chDogTask::switchToBackupDB,260> Trying switchToBackupDB
2015-03-10 08:10:15,904 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.DBConnectionChangeWat chDogTask::switchToBackupDB,266> Backup DB is enabled.
2015-03-10 08:10:15,904 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.DBConnectionChangeWat chDogTask::switchToBackupDB,280> Down DB detection Time: 9 Mrz 2015 06:38 PM
2015-03-10 08:10:15,905 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.DBConnectionChangeWat chDogTask::switchToBackupDB,283> Current Time: 10 Mrz 2015 08:10 AM
2015-03-10 08:10:15,905 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.DBConnectionChangeWat chDogTask::recoverBackupDB,324> Trying to recover from Backup DB.
2015-03-10 08:10:15,906 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.repository.jdbc.DbUtilRepositoryJdbc Impl::recoverWSMDatabase,239> Recovering Backup copy of Database, Database Name: StreamingDB , Backup Location: C:\SQLBackups\StreamingDB.bak
2015-03-10 08:10:15,906 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.dx.dal.DataAccessConfig::readFromDBBacku pRegistry,170> readFromDBBackupRegistry() invoked
2015-03-10 08:10:15,926 [ERROR] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.repository.jdbc.DbUtilRepositoryJdbc Impl::recoverWSMDatabase,262> com.microsoft.sqlserver.jdbc.SQLServerException: Could not find stored procedure 'master.dbo.wsm_restore_wsmdb_backup'.
2015-03-10 08:10:15,927 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.dx.dal.DxDataSource::<init>,69> Setting DBCP initialSize to 4, maxActive to 16, maxIdle to 4, maxWait to 10000 milli-seconds
2015-03-10 08:10:30,017 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.dx.dal.DxDataSource::<init>,69> Setting DBCP initialSize to 4, maxActive to 16, maxIdle to 4, maxWait to 10000 milli-seconds
2015-03-10 08:10:59,851 [ERROR] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.SQLServerNameChangeWa tchDogTask::run,72> IPAddressChangeWatchDogTask::Run() Data connection is not vaild.
2015-03-10 08:11:14,653 [ERROR] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.IPAddressChangeWatchD ogTask::run,87> IPAddressChangeWatchDogTask::Run() Data connection is not vaild.
2015-03-10 08:11:29,444 [ERROR] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.MachineNameChangeWatc hDogTask::run,83> MachineNameChangeWatchDogTask::Run() Data connection is not vaild.
2015-03-10 08:11:54,488 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.DBConnectionChangeWat chDogTask::run,78> DB Connection is Invalid
2015-03-10 08:11:54,488 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.DBConnectionChangeWat chDogTask::tryUpdateWSMDBConnection,182> Trying to start SQL Server if it is local.
2015-03-10 08:11:54,489 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.DBConnectionChangeWat chDogTask::tryUpdateWSMDBConnection,189> Trying to update DB Server Registry Entry if SQL Server is local
2015-03-10 08:11:54,489 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.DBConnectionChangeWat chDogTask::updateDBServerRegIfLocalDB,389> Trying to check if WSM DB Server is local.
2015-03-10 08:11:54,490 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.DBConnectionChangeWat chDogTask::tryUpdateWSMDBConnection,195> Trying to Reconnect to SQL Server after Registry refresh.
2015-03-10 08:11:54,493 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.dx.dal.DxDataSource::<init>,69> Setting DBCP initialSize to 4, maxActive to 16, maxIdle to 4, maxWait to 10000 milli-seconds
2015-03-10 08:12:09,288 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.tasks.DBConnectionChangeWat chDogTask::tryUpdateWSMDBConnection,208> Trying to discover valid db configuration from other servers within site.
2015-03-10 08:12:24,060 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.net.ServerCommunicationConf ig::readFromRegistry,103> readFromRegistry() invoked
2015-03-10 08:12:24,221 [INFO] com.wyse.wsm.dx.admin.tasks.SequentialWatchDogTask Runner <com.wyse.wsm.dx.admin.net.ServerContact::getServe rProxy,106> Base URL: 192.168.1.10/.../contact


Obviously, the stored procedure master.dbo.wsm_restore_wsmdb_backup
is missing. Can you post the script or tell us where to get our hands on this stored procedure?

Regards

Tags (3)
0 Kudos
2 Replies
mhaase-2015
3 Argentium

RE: Missing stored procedure

Have you followed the procedure setting up the DB Backup Server as described in WSM HowTo Series #7 - Setting up DB failover in a Linked Site.pdf ?
The initial configuration Needs to be done by running the BackupServer.properties script on the Backup Server and not the WSM Admin Console.

If the issue continues to exist, please create a Support Case and attach the WSM Troubleshooting Form, log files and screenshots from both Servers.

 

 


#Iwork4Dell

Tags (2)
0 Kudos
ben_mnd
1 Copper

RE: Missing stored procedure

Issue solved

We did not follow the instructions given in the "How To Series", to be honest. Doing that solved the issue!

Thank you very much!

Tags (2)
0 Kudos