Nate Sousek
1 Copper

Unable to rename clients

Unable to rename clients

We have two client machines that we are unable to rename. They are Windows7 Embedded machines. Using both the WyseDeviceManager and the normal Windows way of renaming a PC, the names never stick.

The clients are not connected to a domain. When adding the clients to the domain, it shows up as the new name in AD but the computer continually shows the old name.

Anyone else run into this issue?

Tags (2)
0 Kudos
8 Replies
Genessy
1 Copper

RE: Unable to rename clients

We are having the same issue with clients that started off as WES7 machines that were reimaged to WES. Have you found a solution yet?

 

 

Tags (2)
0 Kudos
Genessy
1 Copper

RE: Unable to rename clients

I found the solution. If you open the command prompt and type "xwfile /d hostname.arc" (no quotes of course) and press Enter, you can then proceed to rename it as normal. You don't even have to remove it from the domain.

Tags (2)
0 Kudos
Genessy
1 Copper

RE: Unable to rename clients

Apparently I gave bad advice before. We are now working on customizing the WES7 image for our uses and are running into the same problem. The xwfile command does not appear to work with the new image after it is applied. We also can't rename the devices through the WDM server or conventional means after they've been imaged. Has anyone run across a solution for this yet? We are currently using build 827 (at the request of Wyse support) lightly customized for our purposes.

Tags (2)
0 Kudos
kmickeletto
1 Copper

RE: Unable to rename clients

Has anyone found a solution to this? I am trying to customize a freshly downloaded copy of XP Embedded and it is doing the exact same thing. I am using all of my self control to not hurt this port TC.

Thanks!

Tags (2)
0 Kudos
Genessy
1 Copper

RE: Unable to rename clients

Another thing we found was that if you completely remove/disable the NetXClean service it can do a few weird things along that line too. According to Wyse support, the best bet is to leave the service, but edit the .ini so that it doesn't actually clean any profiles. Give that a shot! It worked for us on the WES7 workstations we were having trouble with.

Tags (2)
0 Kudos
kmickeletto
1 Copper

RE: Unable to rename clients

That worked! I would buy you a beer if you were here! 

Thanks so much!

Tags (2)
0 Kudos
Highlighted
Michal.M
1 Copper

RE: Unable to rename clients

I found my problem was caused by 2 services that were set to 'Manual' and 'Stopped'. Turn off FBWF and check that 'HAgent' & 'Client Cleanup' services are set to 'Automatic' and 'Started'. Turn FBWF back on

Also take a look at: https://support.wyse.com/OA_HTML/csk...VUpIPkjavftqfQ..

Tags (2)
0 Kudos
Genessy
1 Copper

RE: Unable to rename clients

Yeah, once we "upgraded" to WES7 we had the same issue again. We found out it was tied to the fact we'd disabled the client cleanup service. After it was re-enabled and configured to not remove anything from the profiles, we were able to rename them again.

Tags (2)
0 Kudos