tballin
1 Copper

INI files and XenDesktop WYSE Xenith Manager

INI files and XenDesktop WYSE Xenith Manager

I'm trying to push out an ini config file through WXM to Xenith Zero clients , but it doesn't appear to be working. Is there some special magic to this? Is there a way to confirm whether or not these configs are being received by the clients?

0 Kudos
8 Replies
Highlighted
lobo519
1 Copper

RE: INI files and XenDesktop WYSE Xenith Manager

Quote Originally Posted by tballin View Post

I'm trying to push out an ini config file through WXM to Xenith Zero clients , but it doesn't appear to be working. Is there some special magic to this? Is there a way to confirm whether or not these configs are being received by the clients?

 

on the client

click on admin mode - system tools - global ini

here you should see the config you are applying.

also - for the xenith manager - under local settings I believe you need to populate the fileservers/path and username and password not the WDM servers.

0 Kudos
tballin
1 Copper

RE: INI files and XenDesktop WYSE Xenith Manager

There's definitely nothing in the global ini section - any ideas as to how I might troubleshoot this?

Also, I looked under local settings but I don't see anything about file servers / paths, usernames etc. All I see (under local settings) are system preferences, peripherals, display and printer.

0 Kudos
DaFishe
2 Bronze

RE: INI files and XenDesktop WYSE Xenith Manager

You will need to put the location of the INI file in the File Server / path.
example. http://192.168.1.100/Xenith

0 Kudos
tballin
1 Copper

RE: INI files and XenDesktop WYSE Xenith Manager

Where exactly can I find this File Server / path setting?

0 Kudos
DaFishe
2 Bronze

RE: INI files and XenDesktop WYSE Xenith Manager

go into admin mode.. you might have to enable the "admin button" (to enable the admin button press ctrl alt delete and select the check box to enable the button)
then from the Zero launch bar under system settings choose central configuration. there you will find the file server/path field.

0 Kudos
tballin
1 Copper

RE: INI files and XenDesktop WYSE Xenith Manager

Thanks - I'll try that. (BTW - part of my problem here is that WYSE screwed up on their SKUs and ended up shipping me the Latin America version of this client. And since I don't speak or read Spanish...)

0 Kudos
tballin
1 Copper

RE: INI files and XenDesktop WYSE Xenith Manager

I've tried just about everything, and I can't get this to work... 

According to WYSE KB article 15508, there are two ways to configure the server settings - the way you mentioned and DHCP:

"There are two types of methods which can be used to assign the WTOS thin
computing device to the correct HTTPS server initially. First, you can manually
enter the File Server and Path on the WTOS device by click on Desktop -
System Setup - Network - File Servers/Path and entering the following
information.

EX: https://IPADDRESS/wyse

The Second method uses DHCP option tags 161 and 162 to hand the WTOS thin
computing device the File Server and Path information. Specific information on how
to setup 161 and 162 tags are located in the Wyse Thin OS administrators guide
located at the Wyse Customer Support Knowledgebase and click on Reference
Guides.

I've tried both and nothing works. I notice though that when I try to access the ini file directly from the server, I get an error message: "The page cannot be displayed because an internal server error has occurred.", so I don't think the ini file is accessible. According to the WYSE Administrator's guide, there are two configuration changes that need to be made in IIS in order to successfully deliver ini files:

1. On your IIS server, use the File Types menu to add a New Type.
2. In the File Type dialog box, enter the Associated extension .ini and Content type
(MIME) text/plain.
3. Click OK to apply the settings.

To create/activate .ini:

1. On your IIS server, use the File Types menu to add a New Type.
2. In the File Type dialog box, enter the Associated extension . and Content type (MIME)
text/plain.
3. Click OK to apply the settings

I've also take both of these steps, and yet nothing has changed. (I've also reset IIS)

??

0 Kudos
mmartin-2015
1 Copper

RE: INI files and XenDesktop WYSE Xenith Manager

On your XenDesktop server there is web server running with the standard path C:\inetpub\wwwroot\. There WXM is creating standard path there for Xenith devices wyse\wnos\. Therefore firmware and configuration you create using WXM are going to end up in C:\inetpub\wwwroot\wyse\wnos\ folder.

You have to configure thin client so it would be able to acces your config or FW. This can be done using two different methods:
1. Manual entry in TC GUI: Central Configuration - File Servers/Path
example: http://ipaddress/wyse or: http://FQDN/wyse
2. Using DHCP options 161 and 162
example: 161 string "http://ipaddress" or: "http://FQDN"
162 string "" or just omit parameter 162


You can notice that you need to specify "wyse" subfolder only when using method 1. When using method 2 it is appended by default by Xenith or WTOS. You can omit DHCP parameter 162 or leave it blank, you may use it only if you want to add custom prefix to the default path.

You can also notice that wnos subfolder is appended by Xenith or WTOS by default in both cases.

Now your Xenith will be able to read your config.

0 Kudos