XPS Desktops

Last reply by 07-26-2020 Unsolved
Start a Discussion
2 Bronze
2 Bronze
809

New XPS dead on arrival

New desktop will not power on. Tried everything and no lights on box. Called tech support and they say TAG does not exist .... this is not good customer experience and advice? 

Replies (17)
Anonymous
Not applicable
562

Interestingly, on the Dell web site, I could not configure an XPS 8930 with a i3-9100 processor, let alone a GT 1030 graphics card.

They are really pushing the XPS 8940 hard. Note that I have "9th Gen Intel Core" selected, and the result is two 10th Gen 8940's  

image.png

548

Odd that Dell paired a pascal card with a 9th gen CPU.  I'm guessing this was purchased at the end of 2018, or beginning of 2019 (when they still has pascal stock) or that this was from the Dell outlet.  


357

Was this purchased from Dell, or a third party?  


Anonymous
Not applicable
340

@r72019 

It reflects "Dell.com Order" in the posted spec list. But you are right . . . could be the Outlet. I don't see any notation of "Refurbished" . . . not that they would admit it 

333

Ah, I see it now.  It's the latter - delloutlet.com.  i3-9100 or 8th gen cpu + 1030 or onboard only. Starting at $478. 

 


310

Hi all - resolved the issue the power supply cable had disconnected! 

not what you expect for a new system

302

@pc paul Hi all - resolved the issue the power supply cable had disconnected! 
not what you expect for a new system

I consider it standard and necessary procedure when receiving a new machine to check it over thoroughly as best you can for proper mechanical and electrical assembly before applying power.  It's not uncommon to find something loose or out of place.

Glad you got it working.

GK

301

@pc paul   That's about what I suspected...

As I said, these things do happen, especially during rough shipping. My new XPS 8930 arrived with the NVidia GPU partially out of the PCI-e x16 slot and wouldn't boot. Saw it as soon as I opened the case. Reseated the card and presto...!

Enjoy your new toy!

Ron

   Forum Member since 2004
   I'm not a Dell employee

Latest Solutions
Top Contributor