old_Bean
2 Bronze

XPS 8700, What causes the C drive (Drive0) to become (Drive 1) when adding HDD?

Hi,

I recently reinstalled W10 on the mSATA C_Drive. It correctly shows as Drive 0.
But when I add a second drive (HDD) the mSATA C_Drive now displays as Drive 1, and the secondary HDD drive has become Drive 0.

What causes this to happen please, and where do I look to correct (probably) my mistake?

Seagate 6tb appears as Drive 0b.png

Tags (2)
0 Kudos
4 Replies
Tesla1856
6 Thallium

Re: XPS8700 - What causes the C drive (Drive0) to become (Drive 1) when adding HDD?

we can't see your pics.

Drive-0 and Drive-1 usually correlate to SATA-channels and are normally irrelevant.


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
Vic384
3 Cadmium

Re: XPS8700 - What causes the C drive (Drive0) to become (Drive 1) when adding HDD?

old_Bean
2 Bronze

Re: XPS8700 - What causes the C drive (Drive0) to become (Drive 1) when adding HDD?

Thank you Tesla1856,

I repost the picture here, but it shows on my PC, let me know if it still does not show.  I know it does not show if not logged in.  Maybe some limitations of size or similar?


Seagate 6tb appears as Drive 0b.png

 

0 Kudos
Highlighted
old_Bean
2 Bronze

Re: XPS8700 - What causes the C drive (Drive0) to become (Drive 1) when adding HDD?

Thank you Vic384,

That's very helpful in getting my head around what is going on and the way Windows assigns the Drive number.
I take it from the fact this has already come up that there is no real way to force a Drive & letter combo.

I guess I am still surprised that my (as yet unformatted) secondary drive gets allocated first, because the main drive is an mSATA - but it is shown listed last in the Dell BIOS... maybe that's why, but I can't see a way to change that order.

mSATA in BIOS menu.png

 Just so I don't make a silly mistake would you recommend which port numbers I plug the secondary drive in, and also the DVD ? [ 'cos the mSata is 0 anyway I guess] .  I got the impression that there may be certain combinations that  may cause issues.

Finally, should I format the secondary only when the drives are correct, or can I format straight away ?



0 Kudos