Highlighted
ColeTrainWVU
1 Nickel

XPS 8900 won't boot with external hard drive connected

Jump to solution

I have an XPS 8900 running windows 10. I've had two different >4gb external hdd's and every time one of them is plugged in during the POST, windows boot manager tries to run dell diagnostics (which takes a long time) and then finally says that it can't find any problems or a  boot device. 

If I unplug or turn off the externals, it boots into windows with no problems.

I've tried to do a legacy boot, but that doesn't work with windows 10.

I've tried doing UEFI by selecting my drive and not going through Windows Boot Manager, but it says that it can't find my boot device. 

I've checked and updated all of my drivers to the latest versions, multiple times. I've been dealing with this problem for nearly 3 years now. 



0 Kudos
1 Solution

Accepted Solutions
ColeTrainWVU
1 Nickel

Re: XPS 8900 won't boot with external hard drive connected

Jump to solution

It had System Config -> USB Config -> Enable Boot Support unchecked and still wouldn't boot to the correct hard drive. 

That said, it seems as if I may have found the solution:

The reason why it wouldn't load was because of something to do with windows boot manager not recognizing my primary hard drive and/or placing it in lower precedence whenever an external hdd was detected. Since there isn't a clear way to change boot precedence in windows boot manager, I had to get around that. In order to do that I had to create a new boot option and set it to run before windows boot manager. I tried this before, but I don't think i had the right file selected to boot to.



I did the following and my computer now seems to be booting like it's supposed to. 

  1. On startup tap F2 a bunch of times before or at the very beginning of the dell logo screen in order to enter the BIOS.
  2. In BIOS, go to: General -> Boot Sequence 
  3. Make sure UEFI is selected.
  4. Click the "Add boot option" button
  5. A prompt for creating a new boot option will come up with three fields. 
  6. On the name field you can type whatever you like (i used bootx64.efi, you'll see why shortly)
  7. On the file system field, make sure that the paths referencing your boot drives are selected. -- If you have the USB boot option mentioned in the above comment enabled, you may see other fields here referencing the USB drives. Make sure they aren't highlighted.
  8. On the file name field, click the button with three dots and navigate to \EFI\Boot\ and select bootx64.efi
  9. Save your new settings
  10. You should see a new checkbox up top with the name of the boot option, make sure it is checked.
  11. Click on the white box for the new boot option on the right and use the arrows to move it above "Windows Boot Manager"
  12. Click the Apply button on the bottom of the screen. 
  13. Click Exit
  14. It should now boot to your C drive with windows like it's supposed to. 

 

0 Kudos
2 Replies
RoHe
6 Indium

Re: XPS 8900 won't boot with external hard drive connected

Jump to solution

Reboot and immediately press F2 to open BIOS setup.

Look for an option that allows USB booting. The online service manual doesn't show the BIOS screens, so I can't tell you exactly where to look for it, assuming it's there.

Disable USB booting, but don't change anything else in BIOS setup. Save the change and exit setup.

Does that solve the problem?

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
ColeTrainWVU
1 Nickel

Re: XPS 8900 won't boot with external hard drive connected

Jump to solution

It had System Config -> USB Config -> Enable Boot Support unchecked and still wouldn't boot to the correct hard drive. 

That said, it seems as if I may have found the solution:

The reason why it wouldn't load was because of something to do with windows boot manager not recognizing my primary hard drive and/or placing it in lower precedence whenever an external hdd was detected. Since there isn't a clear way to change boot precedence in windows boot manager, I had to get around that. In order to do that I had to create a new boot option and set it to run before windows boot manager. I tried this before, but I don't think i had the right file selected to boot to.



I did the following and my computer now seems to be booting like it's supposed to. 

  1. On startup tap F2 a bunch of times before or at the very beginning of the dell logo screen in order to enter the BIOS.
  2. In BIOS, go to: General -> Boot Sequence 
  3. Make sure UEFI is selected.
  4. Click the "Add boot option" button
  5. A prompt for creating a new boot option will come up with three fields. 
  6. On the name field you can type whatever you like (i used bootx64.efi, you'll see why shortly)
  7. On the file system field, make sure that the paths referencing your boot drives are selected. -- If you have the USB boot option mentioned in the above comment enabled, you may see other fields here referencing the USB drives. Make sure they aren't highlighted.
  8. On the file name field, click the button with three dots and navigate to \EFI\Boot\ and select bootx64.efi
  9. Save your new settings
  10. You should see a new checkbox up top with the name of the boot option, make sure it is checked.
  11. Click on the white box for the new boot option on the right and use the arrows to move it above "Windows Boot Manager"
  12. Click the Apply button on the bottom of the screen. 
  13. Click Exit
  14. It should now boot to your C drive with windows like it's supposed to. 

 

0 Kudos