Highlighted
promizeone
1 Nickel

XPS 8930, BIOS 1.1.3 does not install?

Morning, 

I cannot get this BIOS update to work. Whenever I click the .exe program, it does nothing. Never starts. Nothing happens. I even tried running it as Administrator and nothing happens. I thought maybe it was a bad download, but I've downloaded it several times now and nothing happens. Just seems it won't start the BIOS update utility like it is supposed to and install itself. I double checked my current BIOS version, it says I'm at 1.0.13 July 20th, 2018.

Any ideas?  Suggestions?

Labels (1)
Tags (1)
12 Replies
Moderator
Moderator

Re: XPS 8930, BIOS 1.1.3 does not install?

For my notes and to check the warranty status, click my username and via private message, send me the service tag number.

 

First, does your XPS 8930 currently have one of the CPU (Intel i9-9900K, i7-9700K, i5-9600K) that this BIOS specifically addresses? If not, you do not need this BIOS.

1.1.3.JPG

 

Second, per the instructions, did you check to see if BitLocker encryption was suspended?

BitLocker.JPG

 

Third,
* Download/Save XPS8930_1.1.3.exe to the Windows desktop
* Disconnect all external USB drives from the desktop. Leaving only the following devices connected to the rear of the XPS 8930 =
power cable
monitor video cable
wired USB mouse
wired USB keyboard
ethernet cable
* Closed all unnecessary software applications (Steam, Anti-virus, etc. )
* Find the saved BIOS file on the Windows desktop
* Right click the file and choose, "Run as administrator". Note, you do not need to "extract" the file. Just run it
* Follow the prompted instructions. The desktop should reboot on its own. Do NOT force it to reboot or power off

0 Kudos
promizeone
1 Nickel

Re: XPS 8930, BIOS 1.1.3 does not install?

Thank you.  

Just figured this was an update I needed since I ran the support thing from Dell... but did notice since you pointed it out it was not for my processor.    

0 Kudos
forepaughs
1 Copper

Re: XPS 8930, BIOS 1.1.3 does not install?

Exactly the same thing happened to me. Seems that Dell Assist is ridiculously dumb since it should know with great precision which processors you have installed. I did read the details and noted that the update did not include my 8700 processors, but I wondered if the details were just wrong instead of the entire Urgent Notice being false. Dell failed miserably on this.
Flickerbrain
1 Copper

Re: XPS 8930, BIOS 1.1.3 does not install?

Same here, I don't have one of the processors the update addresses. Support Assist doesn't realize that and thinks I need it anyway. Dell needs to correct this error.

0 Kudos

Re: XPS 8930, BIOS 1.1.3 does not install?

Hello. I would be very careful about updating this. Yes, Dell has really dropped the ball on this one very badly.

I have the XPS 8910, tried to do the BIOS update, and as of right now my computer won't even turn on.

Lesson learned and awaiting the results. "If it ain't broke, don't fix it."

 

0 Kudos
forepaughs
1 Copper

Re: XPS 8930, BIOS 1.1.3 does not install?

I had great respect for Dell's technical competence and that is why I have purchased only Dell PC's and laptops for the past 20 yrs.   

They have lost their edge and their competence in many things.  This is just one more example.

I get a notice about every 3 days from Support Assist that I urgently need to do this BIOS update, yet I have been unable to install it either via Support Assist or even manually.

Just another nail....

 

 

 

0 Kudos
Vic384
3 Zinc

Re: XPS 8930, BIOS 1.1.3 does not install?

Folks would be better off to disable Support Assist and just manually check for updates with the Service Tag. Be sure to view the driver details and evaluate for yourself the need to download and install.

0 Kudos
spotteddog
2 Iron

Re: XPS 8930, BIOS 1.1.3 does not install?

I have an XPS 8930 with i7 8700k.

I, too, got the Support Assistant message to install the new BIOS when it was first released months ago. Assuming I was supposed to install it, I did. It went fine. No Problems with the install. No problems since installing.

As a learning experience, I am just wondering why I was able to install it and others weren't?.

 

Thanks  

XPS 8930
SSD, 2 HDD, GTX 1070, Windows 10 64-bit, i7-8700K, 16GB DDR4 at 2666MHz
0 Kudos
RoHe
6 Thallium

Re: XPS 8930, BIOS 1.1.3 does not install?


@spotteddog wrote:

I have an XPS 8930 with i7 8700k.

I, too, got the Support Assistant message to install the new BIOS when it was first released months ago. Assuming I was supposed to install it, I did. It went fine. No Problems with the install. No problems since installing.

As a learning experience, I am just wondering why I was able to install it and others weren't?.

 

Thanks  


Sure you're talking about the same BIOS update? There have been a number of BIOS updates for the XPS 8930 over the past few months to fix Intel security issues. This last one seems to be only to enable support for the newest 9th Gen CPUs...

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos