Highlighted
Wavepilot
1 Copper

XPS 8930, Power/Diagnostic LED not lit, computer works normally

Jump to solution

When booting, the power light flashes yellow once as it always has, but instead of turning steady white and remaining on, it turns off. The boot continues normally and the system works fine, but no light. This occurred after the machine went to sleep and normally has a slow flashing white light to indicate sleep, but I returned to no light. The machine woke normally, but no light at all. Rebooted several times and ran Dell Support Assist but all systems check out fine. Did happen to update the BIOS several days ago. Appreciate any thoughts or comments.

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
7- Thorium

Re: XPS 8930, Power/Diagnostic LED not lit, computer works normally

Jump to solution

Sounds like it might be a bum white LED in the power button module...

If you're under warranty, contact Dell Tech Support. Have Service Tag available when you contact them.

Ron

   Forum Member since 2004
   I am not a Dell employee

View solution in original post

0 Kudos
3 Replies
7- Thorium

Re: XPS 8930, Power/Diagnostic LED not lit, computer works normally

Jump to solution

Sounds like it might be a bum white LED in the power button module...

If you're under warranty, contact Dell Tech Support. Have Service Tag available when you contact them.

Ron

   Forum Member since 2004
   I am not a Dell employee

View solution in original post

0 Kudos
Wavepilot
1 Copper

Re: XPS 8930, Power/Diagnostic LED not lit, computer works normally

Jump to solution

Thank you, RoHe. That's what I suspected too if there are in fact 2 separate LEDs. Fortunately, the problem somehow resolved itself.

0 Kudos
7- Thorium

Re: XPS 8930, Power/Diagnostic LED not lit, computer works normally

Jump to solution

Possibly a loose connection or an ailing power button module. If it happens again and you're under warranty, contact Tech Support.

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos