apollo1800
1 Copper

XPS 8930, installed sound card, getting SA error for unplugged cable

I installed a sound card and moved the front panel cable to the new sound card. How do I make the Dell SupportAssist error go away that states there is an IO cable failure?

This post has an image of the error, but I do not see a solution. I do not see an option to disable the integrated sound card in the bios menu.

https://www.dell.com/community/Alienware-Desktops/using-the-front-jacks-with-a-sound-card-causes-a-s...

Labels (2)
0 Kudos
10 Replies
7- Thorium

Re: XPS 8930, installed sound card, getting SA error for unplugged cable

What is your Alienware model number?  Always include that on any initial problem post. 

 



I am not a Dell Employee

Dell forum member since 2002

Dell Inspiron 15 - 5577 Laptop

Home Built Desktop PC with ASUS ROG Z170, i7 6700K CPU

Windows 10 64 bit Pro and Windows 10 Insider Program Beta Versions. SSD drives. Cakewalk by BandLab and Studio One 4.1 Recordng Studio Software.

Dell S2719dgf Monitor

Member of Nashville based R.O.P.E.

0 Kudos
apollo1800
1 Copper

XPS 8930, installed sound card, getting SA error for unplugged cable

The model is XPS 8930.

0 Kudos
apollo1800
1 Copper

Re: XPS 8930, installed sound card, getting SA error for unplugged cable

Disabling Realtek audio in Device manager did not help. Uninstalling the Dell SA (SupportAssist) app did not help.

0 Kudos
7- Thorium

Re: XPS 8930, installed sound card, getting SA error for unplugged cable

The error is very specific

Alert! Front I/O cable failure" message (code 2000-0716)

bios version 1.0.14 on the XPS 8920 had this issue.

bios version 1.0.15 seems to resolve this on XPS 8920

Did you disable the integrated sound card in the Bios menu?


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

0 Kudos
apollo1800
1 Copper

Re: XPS 8930, installed sound card, getting SA error for unplugged cable

My BIOS version is 1.1.8, so it is much later than 1.0.15.

As I said in my original post, there does not seem to be a way to disable the integrated sound card in the BIOS menu. If that is the solution, please explain where I may do that.

Thank you.

0 Kudos
7- Thorium

Re: XPS 8930, installed sound card, getting SA error for unplugged cable

The slim page only goes to 1.1.16

 

https://www.dell.com/support/home/us/en/04/drivers/driversdetails?driverid=82kt9

 

https://downloads.dell.com/FOLDER05736145M/1/XPS8930_1.1.8.exe

Fixes & Enhancements

- Updated the thermal table to enhance the performance of the fan.
 
Description Version Download
Dell XPS 8930 System BIOS
This package contains the Dell System BIOS update and is supported on Dell XPS 8930 system that runs Windows Operating System. BIOS is a firmware that is embedded on a small memory chip on the system board. Supports 9th Generation Intel processor. More details
1.1.6
 
Dell XPS 8930 System BIOS
This package contains the Dell system BIOS update for Dell XPS 8930 system that runs Windows operating system. BIOS is a firmware that is embedded on a small memory chip on the computer's system board. It controls the keyboard, monitor, disk drives and other devices. This update addresses security advisory INTEL-SA-00185 (CVE-2018-12188 CVE-2018-12190 CVE-2018-12191 CVE-2018-12192 CVE-2018-12199 CVE-2018-12198 CVE-2018-12200 CVE-2018-12187 CVE-2018-12196 CVE-2018-12185).More details
1.1.4
 
Dell XPS 8930 System BIOS
This package contains the Dell system BIOS update for Dell XPS 8930 that runs the Windows operating system. BIOS is a firmware that is embedded on a small memory chip on the computer's system board. It controls the keyboard, monitor, disk drives and other devices. This update enhances the system to support the Intel i9-9900K, i7-9700K and i5-9600K processors.More details
1.1.3
 
Dell XPS 8930 System BIOS
This package provides the Dell System BIOS update and is supported on Dell XPS 8930 for Windows Operating System.More details
1.0.13
 
Dell XPS 8930 System BIOS
This package provides the Dell System BIOS update and is supported on Dell XPS 8930 for Windows Operating System.More details
1.0.12
 
Dell XPS 8930 System BIOS
This package provides the Dell System BIOS update and is supported on Dell XPS 8930 for Windows Operating System.More details
1.0.11
 
Dell XPS 8930 System BIOS
This package provides the Dell System BIOS update and is supported on Dell XPS 8930 for Windows Operating System.More details
1.0.10
 
Dell XPS 8930 System BIOS
This package provides the Dell System BIOS update and is supported on Dell XPS 8930 for Windows Operating System.More details
1.0.9
 
Dell XPS 8930 System BIOS
This package provides the Dell System BIOS update and is supported on Dell XPS 8930 for Windows Operating System.More details
1.0.8
 
Dell XPS 8930 System BIOS
This package provides the Dell System BIOS update and is supported on Dell XPS 8930 for Windows Operating System.More details
1.0.7
 
Dell XPS 8930 System BIOS
This package provides the Dell System BIOS update and is supported on Dell XPS 8930 for Windows Operating System.More details
1.0.2
 
Dell XPS 8930 System BIOS
This package provides the Dell System BIOS update and is supported on Dell XPS 8930 for Windows Operating System.More details
1.0.1  

Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

0 Kudos
CodeBlueZ
1 Copper

Re: XPS 8930, installed sound card, getting SA error for unplugged cable

I too have this problem and have the latest bios version 1.1.8. Is there a resolution to this problem? My PC also is the XPS 8930. Should I not use the front I/o jack on the sound card and return it to the mother board? I don't really care if the front io support the sound card as I use rear usb for wireless speakers and may change to a corded headset.

0 Kudos
Moderator
Moderator

Re: XPS 8930, installed sound card, getting SA error for unplugged cable

@CodeBlueZ I'm wondering if this issue is down to the system not being designed with audio card upgrades in mind. 

Looking at the audio connectors on the integrated audio card it's has 7.1 channel capabilities as standard. Furthermore, looking at the BIOS options available, I can see no option for enabling /disabling the integrated audio controller. 

Withe regards to the front i/o panel, there are multiple connectors that run from the front i/o board to the motherboard. Tracing the cables back the front audio connector jack (yellow five pin) connects to the motherboard just below the expansion card slots. I would suggest disconnecting the front audio cable and checking to see if the error message still appears.

This allows you to retain the functionality of the front i/o panel without disabling it in the BIOS.

I can't guarantee that this will work so I look forward to hearing how you get on.

Alan

DELL-AlanD
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

0 Kudos
CodeBlueZ
1 Copper

Re: XPS 8930, installed sound card, getting SA error for unplugged cable

I found that if I left the front IO jack in place on the motherboard, I can then use the sound card when my speakers are directly plugged into the new sound card. I just cannot remove the front IO jack from the motherboard and plug it into the sound card so I would expect that anything plugged into the front jack will still use the onboard sound card. Windows 10 basically added a sound output choice. I believe my USB headphones are still using the onboard sound card which stinks, This means in order to use the new sound card fully, I would need to purchase a hard wired home sound system style head set. Yes, it does look like the XPS 8930 does not really support add in sound cards.

0 Kudos