Highlighted
2 Bronze

XPS 8930, no display, LED lights on

Jump to solution

The computer was working fine for about 6 months, no extra software installed.

Now did windows updates - desktop rebooted fine

Turned on bit locker - Restarted to test and it will not turn on.

The power light comes on, green light is there - No HDMI display - Tried display port also but no avail.

The monitors are fine as tested those with another computer.

After about a minute, the desktop turns off

To mention here, Dell XPS support hasn't been helpful. One person just unnecessarily transferred me to not sure which support line. Didn't clear it - said i am transferring you and pressed transfer.

Second person disconnected the call and never called back even though he had noted down my number and had confirmed that he has correct number.

So if someone has some steps to help, I would appreciate that more than calling the useless Dell XPS Support

1 Solution

Accepted Solutions
Highlighted
2 Bronze

Re: XPS 8930, no display, LED lights on

Jump to solution

Got the issue resolved.

Changed the port in which my HDMI cable was plugged in. It was in the in-built port and was all working all this time, so never thought of moving it. May be turning on bit locker triggered it.

Moved the cable to the video card outlet and the display came on fine. 

All of this, that the Dell's "techies" could not work out. Yes agreed that I didn't also, but hey this is their job to figure out these kind of things.

Apologies. If DELL-Cares had received from you the XPS 8930 service tag number, we would have seen that your XPS 8930 had the added discrete video card. We would have troubleshot accordingly. But we never got the service tag number from you.

XPS 8930, no display on external monitor?

Check the rear of the XPS 8930. Never use the #1 upper onboard video out ports if you have a #2 added discrete video card.

Capture.JPG

View solution in original post

0 Kudos
6 Replies
Highlighted
4 Tellurium

Re: XPS 8930, no display, LED lights on

Jump to solution

@SKtime wrote:

The computer was working fine for about 6 months, no extra software installed.

Now did windows updates - desktop rebooted fine

Turned on bit locker - Restarted to test and it will not turn on.

The power light comes on, green light is there - No HDMI display - Tried display port also but no avail.

The monitors are fine as tested those with another computer.

After about a minute, the desktop turns off

 

To mention here, Dell XPS support hasn't been helpful. One person just unnecessarily transferred me to not sure which support line. Didn't clear it - said i am transferring you and pressed transfer.

Second person disconnected the call and never called back even though he had noted down my number and had confirmed that he has correct number.

So if someone has some steps to help, I would appreciate that more than calling the useless Dell XPS Support


I had the same problem with mine and after 1/2 hour of them asking the same diagnostic questions over and over, they sent someone 55 miles to replace the motherboard and all was good until he left the driveway so they sent a new silver edition one but they put a cheap cpu in it before they shipped it.

Dell XPS 8920 silver edition
7th gen i7 Intel CPU
Samsung 850 evo SSD for boot
Added front fan
16gb of memory
AMD video/graphic card
I buy a new Dell every 4 years for the last 25 years

Highlighted
2 Bronze

Re: XPS 8930, no display, LED lights on

Jump to solution

546insp, at least for you they did some diagnostics, if it is same. For me, they didn't even talk to me for more than 5 minutes!

0 Kudos
Highlighted
4 Tellurium

Re: XPS 8930, no display, LED lights on

Jump to solution


Yea it was actually about a half hour of try this, try that, but I had to keep reminding them that it only worked for a short while. If you can't get any help next time try asking for someone else or just call back a few times. They mostly go by a reference they have in front of them but it's better than nothing. Mine remained a mystery but they did send a new one.

Dell XPS 8920 silver edition
7th gen i7 Intel CPU
Samsung 850 evo SSD for boot
Added front fan
16gb of memory
AMD video/graphic card
I buy a new Dell every 4 years for the last 25 years

0 Kudos
Highlighted
2 Bronze

Re: XPS 8930, no display, LED lights on

Jump to solution

Got the issue resolved.

Changed the port in which my HDMI cable was plugged in. It was in the in-built port and was all working all this time, so never thought of moving it. May be turning on bit locker triggered it.

Moved the cable to the video card outlet and the display came on fine. 

All of this, that the Dell's "techies" could not work out. Yes agreed that I didn't also, but hey this is their job to figure out these kind of things.

Apologies. If DELL-Cares had received from you the XPS 8930 service tag number, we would have seen that your XPS 8930 had the added discrete video card. We would have troubleshot accordingly. But we never got the service tag number from you.

XPS 8930, no display on external monitor?

Check the rear of the XPS 8930. Never use the #1 upper onboard video out ports if you have a #2 added discrete video card.

Capture.JPG

View solution in original post

0 Kudos
Highlighted
1 Copper

Re: XPS 8930, no display, LED lights on

Jump to solution

Thanks SKtime, your issue is exactly what mine was. Thanks so much for sharing. The other HDMI port took care of it for me as well.

 

0 Kudos
Highlighted
1 Copper

Re: XPS 8930, no display, LED lights on

Jump to solution

Hard Reset, Drain the power by remove all cables including AC cord, then press and hold power button for 30 sec.

Put all the cables back and turn it on: it works and back on as usual. 

I was lucky, hope this help