Highlighted
PixelPhile
1 Copper

XPS 8930, temporary breaks in all network connectivity

Jump to solution

I have a Dell XPS8930 running Windows 10 Pro 1803. It has always suffered from short, temporary breaks in network connectivity - although it has taken me some time to understand this. For example, when having a conversation over Skype, the app will suddenly show 'problems with network connection' and the audio will stop for a few seconds, then restart. When using an ssh session to talk to another machine on my local network, the connection will drop out and I'll have to restart the session. When browsing, pages will suddenly stop loading, then resume. I experience identical symptoms whether using a wired Ethernet from the motherboard adapter, when using wired Ethernet through a USB adaptor, and when using a WiFi connection. Dell has replaced the motherboard but that has not fixed the problem. Another machine on the same Ethernet connection, or the same WiFi network, never shows the same problem, so I do not believe it's anything to do with my network. In all other respects, the machine and its software seems completely reliable. All drivers and the BIOS are up to date. I am at a loss to know who to turn to with this issue. It doesn't feel like a hardware problem, so I think it must be Windows and/or the drivers (which are up to date). I've posted this issue on Microsoft's support forum and received a number of 'switch it all off and then on again' replies, but none of their reset procedures has made any difference. Help!

0 Kudos
1 Solution

Accepted Solutions
7 Thorium

Re: XPS 8930, temporary breaks in all network connectivity

Jump to solution

SmartByte can be a real nuisance if it's installed, but this could be a power settings issue. So if JOcean's suggestions don't help, try this, but you might want to make these changes too.

Open Device Manager and double-click the entry for your Ethernet adapter. Click its Power Management tab and uncheck the box "Allow PC to turn off...". Now find the entry for your WiFi card and uncheck that same box on its Power Management tab.

Then expand the list under USB in Device Manager and open each USB root hub. Uncheck that box on each Power Management tab.

Exit Device Manager and open the Windows Power options page. Identify the active power plan and click the link to change its settings. On that screen, click the Additional options link. And on this page, disable USB Selective Suspend, disable Hybrid Sleep, disable PCI Express Link State Power Management. And make sure the Wireless Adapter Settings on that screen are set to max performance. Save the changes to the power plan and reboot.

Does that help?

Ron

   Forum Member since 2004
   I am not a Dell employee

View solution in original post

0 Kudos
7 Replies
JOcean
5 Rhenium

Re: XPS 8930, temporary breaks in all network connectivity

Jump to solution

Do you have Smartbyte installed? If so uninstall it and in Task Manager if there is a box for Smartbyte in Services, make sure it is unchecked.

https://www.dell.com/community/Networking-Internet-Bluetooth/Beware-of-SmartByte/td-p/6130892




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built ASUS B450-F Gaming with Ryzen 5 2600X
Real work on an Inspiron 15 5575 and Latitude E5430
0 Kudos
7 Thorium

Re: XPS 8930, temporary breaks in all network connectivity

Jump to solution

SmartByte can be a real nuisance if it's installed, but this could be a power settings issue. So if JOcean's suggestions don't help, try this, but you might want to make these changes too.

Open Device Manager and double-click the entry for your Ethernet adapter. Click its Power Management tab and uncheck the box "Allow PC to turn off...". Now find the entry for your WiFi card and uncheck that same box on its Power Management tab.

Then expand the list under USB in Device Manager and open each USB root hub. Uncheck that box on each Power Management tab.

Exit Device Manager and open the Windows Power options page. Identify the active power plan and click the link to change its settings. On that screen, click the Additional options link. And on this page, disable USB Selective Suspend, disable Hybrid Sleep, disable PCI Express Link State Power Management. And make sure the Wireless Adapter Settings on that screen are set to max performance. Save the changes to the power plan and reboot.

Does that help?

Ron

   Forum Member since 2004
   I am not a Dell employee

View solution in original post

0 Kudos
mwb1110
1 Copper

Re: XPS 8930, temporary breaks in all network connectivity

Jump to solution

> disable Hybrid Sleep

This seemed to do the trick for me.  Thanks!

0 Kudos
savvy2
4 Beryllium

Re: XPS 8930, temporary breaks in all network connectivity

Jump to solution

SO is  pure PC problem and not both the wifi and Ethernet chips or driver faults.

ever think to boot the PC to Linux demo off usb stick .like Unbuntu v17 up.  "click try me"

see if networking fails now.

or plug in a $3 cheap ethernet DONGLE USB device, and test ethernet this way. (uses new hw/sw )

and for sure, (watch CPU% using task manager) or event longs. if 1 app or software spikes, that be it.

look in same page for startup?

or  my joy app

System internals (mS)

autoruns64. try it, and be amazed at the (scope of coverage) also have license me for Security task manager.Prog.

 

 

I am not Dell, I am retired from this industry since 2009,
0 Kudos
savvy2
4 Beryllium

Re: XPS 8930, temporary breaks in all network connectivity

Jump to solution

very good post power plan and  yes first. but why ethernet goes sleep at high usage that be bad drivers.

 

I am not Dell, I am retired from this industry since 2009,
0 Kudos
7 Thorium

Re: XPS 8930, temporary breaks in all network connectivity

Jump to solution

@mwb1110 wrote:

> disable Hybrid Sleep

This seemed to do the trick for me.  Thanks!


Glad that solved the problem. :Yes:

Please mark this thread "Answered" - thanks...

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
JeffGJeffG
1 Copper

[post deleted]

Jump to solution

[post deleted]

0 Kudos