XPS Desktops

Last reply by 12-18-2019 Solved
Start a Discussion
3 Silver

XPS 8930, urgent Qualcomm QCA61x4A/QCA9377 4747J, won't install

Hi,

Following the URGENT indicator on the Dell Support Downloads page for my XPS 8930, I downloaded the Qualcomm driver (ver. 4747J_WIN_12.0.0.916_A33) and attempted to install it several times. Each time, it failed to install.

The log file text is shown at bottom.

Would greatly appreciate your advice, including Dell Support.

Thank you,

JF

=======

INSTALL LOG FILE TEXT:

਍਍[Sat Dec 14 17:46:53 2019] Update Package Execution Started
[Sat Dec 14 17:46:53 2019] Original command line: "M:\DELL\XPS 8930\Qualcomm-QCA61x4A-QCA9377-WiFi-Bluetooth-Driver_4747J_WIN_12.0.0.916_A33_20191125.EXE"
[Sat Dec 14 17:46:53 2019] DUP Framework EXE Version: 3.8.3.67
[Sat Dec 14 17:46:53 2019] DUP Release: 4747JA33
[Sat Dec 14 17:46:53 2019] Initializing framework...
[Sat Dec 14 17:46:53 2019] Data in smbios table is (hex)value = 3 , Chasis type (hex)value = 3 , System type is : Client
[Sat Dec 14 17:46:53 2019] logo.png
[Sat Dec 14 17:46:56 2019] User Command: attended
[Sat Dec 14 17:46:56 2019] DUP Capabilities Value: 35651583 (0x21FFFFF)
[Sat Dec 14 17:46:56 2019] DUP Vendor Software Version: 12.0.0.916
[Sat Dec 14 17:46:56 2019] Local System/Model Compatible with this Package? Yes
[Sat Dec 14 17:46:56 2019] Local System OS Version: 10.0.0.0
[Sat Dec 14 17:46:56 2019] OS Compatible with this Package? Yes
[Sat Dec 14 17:46:56 2019] Local System OS Language: EN
[Sat Dec 14 17:46:56 2019] Language Compatible with this Package? Yes
[Sat Dec 14 17:46:56 2019] Identified Behavior : attended
[Sat Dec 14 17:46:56 2019] Extraction-miniunz path: c:\PROGRA~3\dell\drivers\da6f6c50-5959-4ce9-85fa-1a073da90c4a\miniunz.exe
[Sat Dec 14 17:46:56 2019] Extraction-arguments: -x M:\DELL\XPS893~1\Qualcomm-QCA61x4A-QCA9377-WiFi-Bluetooth-Driver_4747J_WIN_12.0.0.916_A33_20191125.EXE -o -d c:\PROGRA~3\dell\drivers\da6f6c50-5959-4ce9-85fa-1a073da90c4a
[Sat Dec 14 17:46:57 2019] Extraction-GetExitCode: 0
[Sat Dec 14 17:46:57 2019] Identified Behavior : attended
[Sat Dec 14 17:46:57 2019] Temporary payload log file name: C:\ProgramData\dell\drivers\da6f6c50-5959-4ce9-85fa-1a073da90c4a\DUPEC05.tmp
[Sat Dec 14 17:46:57 2019] Translated Command Line : Setup_MUP.exe /LOG"C:\ProgramData\dell\drivers\da6f6c50-5959-4ce9-85fa-1a073da90c4a\DUPEC05.tmp"
[Sat Dec 14 17:46:57 2019] Path : C:\ProgramData\dell\drivers\da6f6c50-5959-4ce9-85fa-1a073da90c4a
[Sat Dec 14 17:46:57 2019] Identified Behavior : attended
[Sat Dec 14 17:47:46 2019] Appending Vendor Software Log.
[Sat Dec 14 17:47:46 2019]
--- Start of Vendor Software Log ---

[Sat Dec 14 17:47:46 2019] ASCII payload log file detected:
[Sat Dec 14 17:47:46 2019] Log File Name: DUPEC05.tmp
[Sat Dec 14 17:47:46 2019] [2019-12-14 17:46:57] Setup start up.
[2019-12-14 17:46:57] CommandLine is:[/LOG"C:\ProgramData\dell\drivers\da6f6c50-5959-4ce9-85fa-1a073da90c4a\DUPEC05.tmp"]
[2019-12-14 17:46:57] ParseXMLandWriteRegistry.

[Sat Dec 14 17:47:46 2019]
--- End of Vendor Software Log ---

[Sat Dec 14 17:47:46 2019] Vendor Software Return Code: 1602
[Sat Dec 14 17:47:46 2019] logo.png
[Sat Dec 14 17:47:46 2019] Name of Exit Code: ERROR
[Sat Dec 14 17:47:46 2019] Exit Code set to: 1 (0x1)
[Sat Dec 14 17:47:46 2019] Result: FAILURE
[Sat Dec 14 17:47:54 2019] Open file: C:\ProgramData\Dell\UpdatePackage\Log\Qualcomm-QCA61x4A-QCA9377-WiFi-Bluetooth-Driver_4747J_WIN_12.0.0.916_A33_20191125.txt

 

 

 

 

 

Solution (1)

Accepted Solutions

The driver for WiFi on my PC is 12.0.0.916, installed 11-28-19.

The driver for BT on my PC is 10.0.0.916, installed 11-28-19.

So both drivers were updated on the same date, using the 12.0.0.916, A33 update package.  I don't know what version of BT driver was previously installed, but I suspect the WiFi and BT driver version numbers are just out of sync, and maybe only the last 3 digits matter.

If your current drivers match my version numbers, then I suspect you already have the latest drivers installed for both and that's why your manual update "fails".

Ron

   Forum Member since 2004
   I'm not a Dell employee

View solution in original post

Community Accepted Solution
Replies (29)
5 Rhenium

The XPS 8930 can be configured with either Qualcomm or Killer WiFi/Bluetooth hardware. Are you sure you have Qualcomm WIFi/Bluetooth. One way to make sure you see only drivers for your system is to show downloads by Service Tag. 

@Vic384Thank you for replying. Yes, indeed: I was viewing downloads for my Service Tag and Qualcomm is listed in Device Manager for Bluetooth and WiFi.

The question is why would an official Dell download not open on a 1-year old Dell desktop, something that only Dell can answer to.

JF

5 Rhenium

When I reviewed your install.log file I noticed that your .exe file was Qualcomm-QCA61x4A-QCA9377-WiFi-Bluetooth-Driver_4747J_WIN_12.0.0.916_A33_20191125.EXE, but the .exe file in Drivers and Downloads is Qualcomm-QCA61x4A-QCA9377-WiFi-and-Bluetooth-Driver_4747J_WIN_12.0.0.916_A33.EXE. The part I highlighted in red is missing. The difference may mean nothing but I would try downloading the file again.  I downloaded the file and the name of the file I downloaded did not change from what it is on the Dell site.

@Vic384  Thank you again for your close review. You are correct: the additional text you highlighted is my own, indicating what date I downloaded the file; it was a simple renaming which should not affect the content of the file in any way.

Although not mentioned in the installation instructions you could try right-clicking on the .exe file and selecting 'Run as administrator'.

You can also try a clean installation but as a precaution I would create a Restore Point first in case something goes wrong: https://www.intel.com/content/www/us/en/support/articles/000022173/network-and-io/wireless-networkin...

There is a risk with a clean installation, you will lose WiFi and Bluetooth connectivity until the drivers are successfully re-installed. You may wish to also download the existing older driver in case the new driver still will not install with the clean installation. You will have to decide whether or not the risk of the Bluetooth security issue that the new driver is supposed to fix is worth trying this.

I have a XPS  8930 and I installed the Qualcomm QCA61x4A/QCA9377 WiFi/Bluetooth Driver on 11/18/19 with no issues at all.

Try downloading it again manually, not using SupportAssist or Dell Update, and "run as administrator" as @Vic384 said, but I wouldn't rename the file because you never know if there's some security feature hidden in there...

Ron

   Forum Member since 2004
   I'm not a Dell employee

7 Thorium

My guess is that you don't actually have that exact card. Have you looked in Device Manager?

Other possibility is that the card is bad or needs to be re-seated.

Finally, it's all rather irrelevant ... because you can just use the Microsoft-supplied Windows-10 driver instead.


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.

Thank you all for sharing your expertise -- much appreciated!

@Vic384-- I did install as Admin. And I wouldn't want to do a full clean install, for the reasons (risks) you mentioned.

@RoHe-- I just downloaded manually (as before) and tried reinstalling (without renaming), as an Admin. Same failure (but I didn't compare the log files).

@Tesla1856-- I have the Qualcomm QCA9377 card, with the Qualcomm driver ver. 10.0.0.916, dated 8/8/2019. The "Urgent" update is to ver. 12.0.0.916. These numbers suggest that the update is related to the current driver. There are no flags on any of the devices to suggest they are not working, are dislodged or otherwise requiring attention.

As I'm sure you all know from your experience helping others, experienced users (like me), who are not tech support experts but have done plenty of computer maintenance over the years, rely on Dell when figuring out which update is important. When marked Urgent, I always try to install.

Of course, I know there might be local reasons why drivers fail to install.

This desktop (Windows 10 64 ver. 1909, fully up-to-date) has had an upgrade-in-place a couple of days ago, related to a separate problem (mini-freezes of 2-5 seconds that started after one of the Windows updates maybe around April-May-June); and earlier today has undergone sfc /scannow with no errors found.  

For a 1-year old XPS 8930, this nice and powerful machine has had too many little buggy problems that are very annoying. This one is just the latest, with a couple of others yet unsolved.

I'd be happy to try any other suggestions you might have.

Thank you all again!

JF

 

All bets are off since you're running Win 10 v1909.  I'm still running Win 10 Pro v1903 and driver 12.0.0.916 got installed by that urgent update on Dell's site...

So I might hold off for a while trying to update the Qualcomm driver... Let's see if they come out with another update...

EDIT: And if you're still having those freezes, update the chipset driver and DISABLE SupportAssist Remediation Service in services.msc.

 

 

Ron

   Forum Member since 2004
   I'm not a Dell employee

Top Contributor
Latest Solutions