Robishere2
2 Bronze

XPS 8940, only records in mono?

Jump to solution

I have a new XPS 8940.  I can play a wave file with a program like Adobe Audition, Audacity or Winamp, it plays in stereo.

When I try to record from an external source, it records in mono.  To be more accurate, what it is doing is putting one channel into both and left and right channels.  Meaning, that when I record in stereo, both channels are the left input.  For example, if I have a recording with a voice saying "Hello" on the left and another voice saying "Goodbye" on the right, when I record, both channels of the recording will have "Hello" and the "Goodbye" is not recorded.

I have tried recording with a Sound Blaster AE7 along with a USB audio device.  I get the same result with both of these.  Both the left and right are only one channel.  I am sure the left and right channels are correctly connected to the devices.

These devices work fine on my old Dell XPS that I have had for years, and I still have.

Some background, I am very experienced digital recording.  I have made 1000s of recordings on my old XPS.  I have done this for many years.  I am very experienced with electronics and audio connections and do this work professionally.  I am 100% sure that my cables are all connected correctly.

My belief is that something pre-installed on the dell XPS is causing this problem.  Likely some "helpful" piece of audio enhancement software that is pre-installed.  My guess is that something assumes the input is supposed to be mono, so it puts one channel into both channels.

I have searched and found other people with similar issues, but I have not found a solution.

One person pointed to the MaxxAudioPro software that comes pre-installed on the Dell.  I have turned off the "Playback" enhancements, but that has not helped.  (Turning off the playback enhancement did fix the distortion I was getting in the audio but not the recording problem)  I have tried turning off the "Voice" setting, but that keeps turning itself back on.  I don't know why, but when I turn off the "Voice" setting, when I reboot and check it again, it is turned back on.

I have looked for other system mixer settings that would control mono vs. stereo output, but I have not found anything.

Other information that may be useful: 

If I record using the "MME" (Microsoft Multimedia Environment) mapped device, then the input audio is always mono.  If I use the ASIO driver, then the input is correctly stereo.  Potentially that could be a solution, but as I mentioned, I also use a USB audio device that I must use.  When I record with that, it always uses MME so it is always recording one channel only. Again, this device works fine on my old XPS.

I am using a 5.1 sound system for playback and it is working correctly.  I am also sure it is connected correctly.  This system works fine on my old XPS.  Again, it can play stereo fine, it is just when recording, the left and right channels are converted to mono.

Another interesting thing is that the "Sound Blaster Command" has a test button that will play "Left Channel", "Center Channel", "Right Channel", "Back Left", "Back Right" into the appropriate speaker. However, when I run the test, the sound comes out of all speakers.  This is strange because when I use Adobe Audition, it correctly plays in stereo.  My guess is that this test button uses the MME device for playback.

Looking in Device Manager, there are these devices "NVIDA High Definition Audio" and "NVIDIA Virtual Audio Device (WDM)".  I have tried disabling these devices, but that has not helped.  I have also gone into the BIOS and disabled the Realtek audio but that has not helped either.

The bottom line is the Sound Blaster card and the USB Audio adapter both work fine in my old XPS but not in the new XPS 8940.  I suspect if I were to wipe the disk and install plain windows 10 without the add-on Dell applications, everything would work fine.

Any help would be appreciated. Thank you, Robert

0 Kudos
1 Solution

Accepted Solutions
Robishere2
2 Bronze

Re: XPS 8940, only records in mono?

Jump to solution

Thanks for the suggestion.  I figured that out just before your post came in.  I can tell you exactly that it is the MaxxAudioPro MICROPHONE setting that is the problem. 

If the microphone enhancement is enabled in MaxxAudioPro, then it maps the left channel to BOTH the left and right channels.  This setting is on automatically and if you do not know about the MaxxAudioPro application, it is very hard to find because there isn't a shortcut to it in the start menu.

Other information that is hopefully useful....

Originally, as reported by other posts to this forum, I found that the speaker settings cause distortion in audio playback.  I was originally getting this playback distortion too and I googled to find the solution.  So one of the first things I did after finding the solution was turn everything off in MaxxAudioPro.  Also, at the advice of Dell Support, I uninstalled MaxxAudioPro.  However, this did not fix the "mono" problem I was facing.  I believe the reason why it did not fix the "mono" problem is that before I realized the microphone setting in MaxxAudioPro was causing the mono recording problem, I saw that the microphone setting in MaxxAudioPro would magically re-enable itself.  Meaning that before I eventually uninstalled the application, if I would check he application again, I would find that the microphone setting had re-enabled itself.

I think uninstalling MaxxAudioPro did not help because my guess is that before I uninstalled it, it must have re-enabled the microphone "feature".  So I think that once I deleted the application, I was stuck because the microphone is mapped.

Also, I am not using the motherboard provided realtek audio.  However, disabling the realtek audio in the BIOS does *not* fix the problem.  Disabling the realtek driver also does not fix the problem.

What I tried doing is putting an empty hard drive into my computer and installed a clean standard version of windows pro.  I did the base install.  My goal was to test the recording problem before installing anything else.  However, just as I was setting up my test, I saw a message saying that MaxxAudioPro was *automatically* installed without any prompt requiring me to allow the install.  I then ran my test and the "mono" problem was there.

It was at that point, I started MaxxAudioPro by typing the name into the windows search bar.  That allowed me to directly find the program to run.  I was testing the recording while I turned off the microphone and then suddenly I was getting stereo!

I reverted back to the windows provided from Dell.  I did the following things in an attempt to prevent the microphone feature from being automatically re-enabled.

I re-installed the maxaudiopro.  I did not delete the realtek driver, but I saw another post from someone who said to go into device manager and update the driver with the generic "HD audio" driver.  I did that, although I do not know if it was required.  I started MaxxAudioPro and turn off all effects and made a new profile with the effects off.  I then turned off the speaker effect switch and I turned off the microphone.  Then I went into the windows startup in the task manager and disabled MaxxAudioPro so it was not launched at startup.

It has been a few days and so far the microphone has not been turned back on automatically.  So when I record now, it records in stereo... it seems OK so far that is why I waited a few days before responding.

Also I will mention that the night I originally posted this issue in the forum, I also paid for dell software support to fix this problem.  After 3.5 hours of trying, they could not fix it.  I will say the tech did understand the issue, but was not able to solve it.  It was only the next day I was able to figure it out myself by the clean install of windows.  I am just glad I happened to be looking at the screen when MaxxAudioPro installed all by itself.

I hope this post helps people in the future. Hopefully my issue stays fixed.  It looks like I must leave the application installed to prevent the problem from reoccurring. 

With all of the complaints and real problems with the MaxAudioPro application, I would hope that Dell would make a change to prevent this software on their system.  It only causes problems.  People doing professional recording do not want all of these "helpful" sound enhancements.  They want a flat playback so they can control exactly what things sound like on their own.  I am also surprised that the distorted sound problem the application causes hasn't caused Dell to stop using this application.  The application doesn't help, it just makes things worse.  I believe because there are less people doing recording vs just audio playback, this issue has not been seen as much.  I also expect there is someone out there who is less technical and isn't realizing they are recording in mono.

View solution in original post

0 Kudos
12 Replies
RoHe
8 Krypton

Re: XPS 8940, only records in mono?

Jump to solution

You probably have Waves MaxxAudio Pro software on this system which has various mic and recording settings of its own, so have a look at those.

And/or you might want to stop MaxxAudio from loading at boot by disabling it on the Startup tab in Task Manager and see if that makes any difference...

 

Ron

   Forum Member since 2004
   I'm not a Dell employee

0 Kudos
Robishere2
2 Bronze

Re: XPS 8940, only records in mono?

Jump to solution

Thanks for the suggestion.  I figured that out just before your post came in.  I can tell you exactly that it is the MaxxAudioPro MICROPHONE setting that is the problem. 

If the microphone enhancement is enabled in MaxxAudioPro, then it maps the left channel to BOTH the left and right channels.  This setting is on automatically and if you do not know about the MaxxAudioPro application, it is very hard to find because there isn't a shortcut to it in the start menu.

Other information that is hopefully useful....

Originally, as reported by other posts to this forum, I found that the speaker settings cause distortion in audio playback.  I was originally getting this playback distortion too and I googled to find the solution.  So one of the first things I did after finding the solution was turn everything off in MaxxAudioPro.  Also, at the advice of Dell Support, I uninstalled MaxxAudioPro.  However, this did not fix the "mono" problem I was facing.  I believe the reason why it did not fix the "mono" problem is that before I realized the microphone setting in MaxxAudioPro was causing the mono recording problem, I saw that the microphone setting in MaxxAudioPro would magically re-enable itself.  Meaning that before I eventually uninstalled the application, if I would check he application again, I would find that the microphone setting had re-enabled itself.

I think uninstalling MaxxAudioPro did not help because my guess is that before I uninstalled it, it must have re-enabled the microphone "feature".  So I think that once I deleted the application, I was stuck because the microphone is mapped.

Also, I am not using the motherboard provided realtek audio.  However, disabling the realtek audio in the BIOS does *not* fix the problem.  Disabling the realtek driver also does not fix the problem.

What I tried doing is putting an empty hard drive into my computer and installed a clean standard version of windows pro.  I did the base install.  My goal was to test the recording problem before installing anything else.  However, just as I was setting up my test, I saw a message saying that MaxxAudioPro was *automatically* installed without any prompt requiring me to allow the install.  I then ran my test and the "mono" problem was there.

It was at that point, I started MaxxAudioPro by typing the name into the windows search bar.  That allowed me to directly find the program to run.  I was testing the recording while I turned off the microphone and then suddenly I was getting stereo!

I reverted back to the windows provided from Dell.  I did the following things in an attempt to prevent the microphone feature from being automatically re-enabled.

I re-installed the maxaudiopro.  I did not delete the realtek driver, but I saw another post from someone who said to go into device manager and update the driver with the generic "HD audio" driver.  I did that, although I do not know if it was required.  I started MaxxAudioPro and turn off all effects and made a new profile with the effects off.  I then turned off the speaker effect switch and I turned off the microphone.  Then I went into the windows startup in the task manager and disabled MaxxAudioPro so it was not launched at startup.

It has been a few days and so far the microphone has not been turned back on automatically.  So when I record now, it records in stereo... it seems OK so far that is why I waited a few days before responding.

Also I will mention that the night I originally posted this issue in the forum, I also paid for dell software support to fix this problem.  After 3.5 hours of trying, they could not fix it.  I will say the tech did understand the issue, but was not able to solve it.  It was only the next day I was able to figure it out myself by the clean install of windows.  I am just glad I happened to be looking at the screen when MaxxAudioPro installed all by itself.

I hope this post helps people in the future. Hopefully my issue stays fixed.  It looks like I must leave the application installed to prevent the problem from reoccurring. 

With all of the complaints and real problems with the MaxAudioPro application, I would hope that Dell would make a change to prevent this software on their system.  It only causes problems.  People doing professional recording do not want all of these "helpful" sound enhancements.  They want a flat playback so they can control exactly what things sound like on their own.  I am also surprised that the distorted sound problem the application causes hasn't caused Dell to stop using this application.  The application doesn't help, it just makes things worse.  I believe because there are less people doing recording vs just audio playback, this issue has not been seen as much.  I also expect there is someone out there who is less technical and isn't realizing they are recording in mono.

View solution in original post

0 Kudos
RoHe
8 Krypton

Re: XPS 8940, only records in mono?

Jump to solution

Wonder if that's a bug in Maxx...?

If you have Dell's SupportAssist and/or Dell Update running in the background, one of them may be force-feeding Maxx to you. So you may need to stop SupportAssist and Dell Update from loading automatically at boot too.

Ron

   Forum Member since 2004
   I'm not a Dell employee

0 Kudos
Robishere2
2 Bronze

Re: XPS 8940, only records in mono?

Jump to solution

I have found today that MaxxAudioPro has magically re-enabled it's microphone setting.  I had to go back into the application and turn it off again.  I have not figured out why it keeps turning the microphone setting back on or how to stop it from doing that.

Also, to comment to the previous post, I found that MaxxAudioPro installs all by itself, without having the Dell update software installed.  Something about the hardware on the dell motherboard causes windows to install this application.

If someone has a way to permanently turn off this application, please let me know. Thank you.

0 Kudos
Vic384
5 Tungsten

Re: XPS 8940, only records in mono?

Jump to solution

@Robishere2 The MaxxAudioPro application is part of the Realtek High Definition Audio Driver and therefore installs because you have the Realtek hardware which prompts automatic installation of the driver. If you download the driver from Dell and look in the archive with a program like 7-Zip you will see the MaxxAudioPro application installation files. Probably your best approach is to figure out how to work with the application to do what you want it to do or you can try to disable the application from starting. Go to Task Manager, click on the Startup tab, and right-click on the MaxxAudioPro application, and select Disable. I don't have an XPS 8940 so I don't know if this will work.

0 Kudos
Robishere2
2 Bronze

Re: XPS 8940, only records in mono?

Jump to solution

@Vic384 Thanks for the advice.  I had already disabled the application from starting as you suggested, however, the microphone enhancement still turned on by itself.

0 Kudos
Vic384
5 Tungsten

Re: XPS 8940, only records in mono?

Jump to solution

@Robishere2 Did you reboot your PC after you disabled the application and after the reboot is the application still disabled? If the application is still disabled after the reboot then I think your only remaining option is to work with the application and find some way to do what you want it to do, perhaps by saving settings, startup options, command-line options, etc.

0 Kudos
RoHe
8 Krypton

Re: XPS 8940, only records in mono?

Jump to solution

@Robishere2 

Click Start>Run and type in: services.msc and click OK. Scroll down the list to Waves Audio Services. Double-click it and set its Startup Type to DISABLED. Don't change anything else in services.msc, just exit and reboot. Does that keep Maxx from taking over control?

Is it possible Microsoft is installing it when you're not looking? Check the Win 10 Reliability Monitor to see if it's listed there as having been installed recently.

For example, the Reliability Monitor on my XPS 8930 (Win 10 Pro, v20H2) shows updates for NVidia Control Panel, etc. etc. etc. were all secretly installed in the last few days, and I would have had no idea without checking the monitor's records...

Ron

   Forum Member since 2004
   I'm not a Dell employee

0 Kudos
speedstep
8 Krypton

Re: XPS 8940, only records in mono?

Jump to solution

Max Audio is bundled with the Realtek driver which is why there is not a separate download

maxx audio is bundled into the Realtek packages.

Realtek ALC234CG High Definition Audio Codec
Realtek ALC3234 High Definition Audio Codec
Realtek ALC3234CG High Definition Audio Codec
Realtek ALC3246 High Definition Audio Codec
Realtek ALC3600 High Definition Audio Codec
Realtek ALC3660 High Definition Audio Codec
Realtek ALC3661 High Definition Audio Codec
Realtek ALC3861 High Definition Audio Codec
Realtek High Definition Audio Codec

Maxx is bundledMaxx is bundled


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

0 Kudos