XPS Desktops

Last reply by 11-30-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
3082

XPS 8940, randomly freezing

XPS 8940

So here's a fun one. I too (as many on this forum have), have been having random system freezing issues with my Dell XPS 8940 with Nvidia RTX 3060 Ti video card. After a lengthy phone call with Dell support, the support engineer in their infinite wisdom has decided that the system doesn't have a hardware problem and if I'd like any further help resolving this situation, I can fork out another $100 for "software" support. System is less than 1 year old and still under warranty. I spent close to $2500 for what was supposed to be Dells "top of the line" Desktop. So, I'm left with 2 choices - either live with a problematic dell desktop or shell out another $100 for their software support and HOPE that their software support personal can help me fix this issue. Needless to say, I will be seriously considering whether or not to purchase ANYTHING else from Dell, ever.

Replies (77)
228

Well, I only had 1 16GB DIMM as delivered by Dell in the 2nd Slot, first White one from the CPU. The 'standard' configuration was 2 8GB's of RAM, but 1 16GB was a free option and I knew I wanted to get more RAM later.

I never locked-up (the term 'freeze' to me mean a temporary 'stall' and then it continues, like a 'stutter') until last Jan. when BIOS V2.4.0. was released.

Recently, I bought a 16GB DIMM from Crucial and added it as the 2nd DIMM on Channel 1/Bank 0,

I am on BIOS V2.8.0, and continue to Lock-up, about every 2 weeks ore less.

Since the first chip is the Samsung Single Rank, both DIMMs run as Single.


===================================

I am a Dell TechExpert. I am not a Dell employee. I enjoy using my free time to help the community. If you find my posts useful, you can thank me by clicking on Kudos!

Thanks,

Irv S.

214

That's odd then that you had the temporary freezing issue with no H/W changes, which would seem to point to the BIOS update.  However, after that you adding the Crucial stick in slot# 4, but the updated BIOS did not completely fix the problem.  On that "freezes completely" discussion Rohe states,  "There has been an indication these XPS 8940 freezes might be related to RAM rank. Dell installs either single or dual rank 16 GB OEM modules in the XPS 8940. A user removed the single rank OEM RAM and replaced it with dual rank Crucial RAM and the problems disappeared."    In your case, CPU-Z shows the Crucial as single whereas mine shows dual.  I am using Crucial model# CT16G4DFD832A in slot# 3.  If there is no difference in the model#, you might try seating the Crucial in slot# 3.  Also, does the freezing occur whether you're on the network or not?

211

@ishmael 

No, I had a LOCK-UP, never a temporary freeze. Only way out, use the Power button to turn off the XPS and then on again to be able to use the PC.

Slots 2 and 4 are Channel 1 so I wanted to add that to have 32GB's in one channel rather than 16GB's in 2 channels. Less work for the Memory Controller.

No, there is no indication of RAM rank that can be proved.. only one user here has 2 XPS, one all Dual Rank, the other all Single Rank DIMM's. That I think is what has RoHe thinking that Rank is the problem.

We've also had users with only Single Rank that do not have the problem.

So right now, the only 'proof' that seems to exist is if one goes back to BIOS V2.3.0 the problem goes away, but again, not for everyone.

My DIMM is an CT16G4DFDA32A and I think I've got something that might be a Single Rank one. On Amazon it is spec'ed as "Rank and Configuration = 1Rx8 or 2Rx8 ", but isn't showing as Dual. It could be because it IS operating correctly as a 1Rx8 when it is in the SAME channel as a Single Rank DIMM.

Some people have had problems mixing Ranks and/or DIMM GB's. I have had no problem.

I'm waiting for Crucial to answer me on what happens when I mix it with a Single Rank DIMM. I suspect it is capable of working with either function of the Memory Controller.

 


===================================

I am a Dell TechExpert. I am not a Dell employee. I enjoy using my free time to help the community. If you find my posts useful, you can thank me by clicking on Kudos!

Thanks,

Irv S.

2 Bronze
2 Bronze
198

Hey all,

just spamming the various similar threads with a solution which seems to be working for me(so far), sorry if unrelated:

https://www.dell.com/community/XPS-Desktops/XPS-8940-Intermittent-Freeze-Possible-Solution/m-p/82463...

2 Bronze
2 Bronze
195

Voi siete corretti, mentre le mie note non lo sono. Dalla CPU: Gli slot 1 e 3 sono neri, gli slot 2 e 4 sono bianchi. La memoria è l'unica cosa che avete aggiunto o sostituito sul vostro xps 8940? Il pc si è bloccato prima di aggiungere la memoria?

182

@meharg 

================

You are correct, while my notes are not. From the CPU: Slots 1 and 3 are black, slots 2 and 4 are white. Is memory the only thing you have added or replaced on your xps 8940? Did your pc crash before adding memory?

===============

I assume you were replying to me.

Only added an External USB drive, and yes, locked up once BIOS V2.4.0 came out in Jan.2022 and all BIOS versions after that, both with the Dell shipped RAM and added RAM later.


===================================

I am a Dell TechExpert. I am not a Dell employee. I enjoy using my free time to help the community. If you find my posts useful, you can thank me by clicking on Kudos!

Thanks,

Irv S.

137

Hi Irv,

Did you get your lockup issue resolved? 

 

132


@ishmael wrote:

Hi Irv,

Did you get your lockup issue resolved? 

 


Sad to say, I did NOT!!!!

First, since I could not get a clear answer from Crucial (actually Micron it seems) on the 1Rx8/2Rx8 issue on the CT16G4DFDA32A, as it was running a Single Rank, I returned it and bought 2 16GB CT16G4DFD832A's that another user here had and was running Dual Rank. The reason for thinking maybe Dual Rank was the reason NOT to have the lock-up was a post by @DataKill here who had 2 'identical' XPS's. One had  4x8GB Single Rank Dimm's and the other 4x16GB Dual Rank Dimm's. Only the Single Rank XPS locked up.

With the 32GB's Dual tank in my XPS's White Clips, I was running Dual Rank, Dual Channel.

I had the Mixed Samsung and single Crucial I returned on V2.8.0 for about a week and made the switch. For 4 more days I recall (didn't keep notes but knew when I got the new sticks and put then in) and no lock up. Well, that might mean it was fixed in the V2.8.0 BIOS even, so I went and installed V2.4.0 again.

Sad to say, on Day 5 running V2.4.0 I left the house around 8AM, came back around 10AM, and the Desktop was still showing on the monitor, lower right hand Systray clock read 8:12AM...

Took longer to fail, but it still fails. It appears RANK of the Dimm is not the answer, or at least not the full answer.

The only other question though would be the Intel Management Engine. See, when you roll back the BIOS versions, they do include the Management Engine version for that date the BIOS was built. However, Intel doesn't allow the s/w to be back-leveled. So I was running BIOS V 2.8.0's ME V14.1.65.1990 with BIOS V2.4.0's included ME V 14.1.60.1892. Before on V2.4.0 I could not even stay running 2or 3 days, but this time 5? BIOS V2.3.0 had an ME V14.1.53.1649 by the way, which never would back-level either, but going from V2.4.0 to V2.3.0 did solve the lock up problem?

So I am wondering if there is any involvement with the Intel Management Engine and the lock ups? Hard to say? Both the BIOS and ME have CVE's included. Those may not be made public until they are fixed, and some are Fixed 'quietly' before announce (as in the description in fixes include as 'and other fixes' that are unnamed). One never knows? Possible the V2.8.0 (V2.9.0 appears to include the same ME) works better and that explains the longer time between locking up on V2.4.0?

I am on V2.9.0 right now. 2 days only... I don't have any expectation that I will not lock-up again. I feel until Dell opens up and posts here what it knows, and when it expects to have the BIOS/Nvidia problem fixed we'll never know? Either that or 'we' users start collecting information and send it to a Dell Moderator to present to Level 3 Support.

There are people with Nvidia cards on 8940's that DO NOT have the problem. Even on the XPS8950 users with the same Nvidia cards are not seeing the problem? Why is the real question?

Need to see what people have, both those that do and do not have the problem. Data like:

  • BIOS Version
  • Nvidia Card
  • Nvidia Card RAM
  • Monitor Resolution
  • Monitor Port used
  • Intel CPU
  • XPS Standard or S.E model
  • XPS RAM total
  • XPS DIMM size in GB's
  • XPS DIMM slots used
  • DIMM Rank
  • Windows Version
  • Any BIOS changes other than turning off Capsule Update
  • Is SSD running RAID or AHCI
  • Any ADDED internal h/w (disks, PCIe cards, etc)
  • Any ADDED external devices (USB Hard drives, non-Dell wireless Keyboard/mouse, etc.)

Just maybe with enough of the above data one could find the common element that one could have that causes the fail?

So confusing, and so frustrating. Any time one has a lock up, data could be lost. I've had 2 programs get mangled Settings already. I feel the only sure fire fix right now IS an AMD video card!!!

By the way, it isn't only Windows users, at least ONE Linux user has the same problem, and is not even Stable (does not lock up) under BIOS V2.3.0! What does that tell you?

It has been almost 7 months now with no relief... Dell really needs to get this fixed fast!

@DELL-Chris M , what is the status of this problem!!!


===================================

I am a Dell TechExpert. I am not a Dell employee. I enjoy using my free time to help the community. If you find my posts useful, you can thank me by clicking on Kudos!

Thanks,

Irv S.

123

Hey Irv,

 

I too have had recurring lock-ups even with the dual rank DIMMS....   Just installed the v2.9.0 BIOS today, however I don't expect that to solve the issue based your recent comments.   At the moment, I'm limping along best I can, making sure I regularly save "important things" (just in case)....  Anyway, I guess here's to hoping Dell can eventually get their act together on this and resolve the underlying conflict that is plaguing a number of us with Nvidia cards....     

At the moment, I'm just gonna limp along as I am....  When it's not locking up, the system is great.

 

-Steve-

186

You wrote, "Well, that might mean it was fixed in the V2.8.0 BIOS even, so I went and installed V2.4.0 again."  Why go back to v2.4.0?    Why not wait to see if it failed on 2.8? 

 

Here's my configuration again, along with some additional info you requested, but don't know about AHCI vs RAID.  I have not changed anything related to the drives except to disable SATA-1 and SATA-2.

Desktop PC:
XPS 8940, Special Edition
Purchase date: 07/22/2021
CPU: i7-11700 @ 2.50GHz, 8 Cores
GPU: Nvidia RTX 2060 Super, 8GB
Memory: 16GB single rank stick (SK Hynix) in slot# 2, added a second 16GB dual rank stick (Crucial) in slot# 3.
Crucial part# CT16G4DFD832A
CPU-Z shows: memory is dual channel: 2 x 64-bit, Hynix rank single, Crucial rank dual
Drives: C: 512GB SSD, task mgr shows NVME BC711 NVME SK hynix 512GB
1TB HDD, task mgr shows WDC WD10EZEX-75WN4A1
E: CD-ROM, ATA PLDS DVD+/-RW DU-8A5LH
Motherboard: 0K2CM7
O/S: Win10 Home--> 21H2 (OS build 19044,1889)
BIOS: v2.8.0
Intel Mgmt Engine Interface: v2145.1.42.0, 10/31/2021
Cooling: Replaced rear stock fan with Noctua NF-A9 92mm fan, replaced stock CPU fan with a Vetroo 5,
added Dell VRM heatsink, using HWinfo64 to monitor CPU/GPU

Monitor: Dell_U2715H, 2560 x 1440 QHD at 60Hz, using Nvidia port
Devices: Logitech USB wireless mouse M510 and keyboard K330

 

Latest Solutions
Top Contributor