XPS Desktops

Last reply by 06-14-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
907

XPS 8940, wake on lan (WOL) not working

Upon contacting Dell support to get help with setting up WOL on my XPS8940 Dell support initiated a replacement of my XPS8940 motherboard. Now the motherboard has been replaced but WOL is still not working. I have followed the setup instructions provided by Dell article # 0001755283.  The problem is that after shutdown of the XPS8940 the Network LEDs are not on ( this is required per the above Dell article) . If the network LEDs are not on, the computer can't receive the magic packet which will wake up the computer. Why are the Network LEDs not on after shutdown of the computer?  

Replies (14)
10 Diamond
647

Version of Windows?

Which Killer Ethernet do you have?

Version of Killer driver?

Is PC connected to a surge protector or power strip? Are you leaving them turned on? Have you tried without connecting through them?

Open Device Manager and double-click the entry for Killer Ethernet. If there's an Advanced tab, go down that list looking for things like Shutdown Wake Up, Wake on Magic Packet, and Wake On Pattern Match, and make sure they're Enabled, if not already set that way.

Exit Device Manager and reboot. Then shut down normally and check Ethernet LED status again...

EDIT: Version of BIOS?

Ron

   Forum Member since 2004
   I'm not a Dell employee

644

1. Windows 11Pro

2. Killer E2600 Gigabit Ethernet Controller

3. Driver Version: 10.47.121.2021

4. PC is connected through surge protector which is always on

5. I have done all required adjustments to the Killer E2600 NIC including  Power Management and Advanced setup.

For your info: I have two other  computers (HP and Lenovo) on the LAN.  Both are setup for WOL and both are responding to magic packet wake up without a problem. Unfortunately the Dell XPS8940 does not keep the Ethernet NIC powered on after shutdown. This prevents the computer from responding to WOL.

There seems to be a problem with the  

10 Diamond
622

You didn't mention the version of BIOS...

Sure about that Killer Ethernet driver number? The support page says 3.1121.1158, A34 is the latest, though that might just be the package number and not the actual driver number.

Sounds like you'll have to work with Dell Tech Support to get another motherboard installed...

Ron

   Forum Member since 2004
   I'm not a Dell employee

10 Diamond
622

I just pinged my Dell contacts about this....

Ron

   Forum Member since 2004
   I'm not a Dell employee

10 Diamond
618

@bhs-berkeley   - Just spotted this thread which may have the solution for you too...

Let us know if that solves the problem.

Ron

   Forum Member since 2004
   I'm not a Dell employee

2 Bronze
2 Bronze
617

I updated the BIOS. Current version: 2.4.0

10 Diamond
615

@bhs-berkeley  Keep in mind that BIOS 2.4.0 is causing random freezes/crashes on XPS 8940. Lots of threads about this problem.

So you may want to downgrade BIOS back to 2..3.0 which is the only known work-around, until Dell replaces 2.4.0.

Ron

   Forum Member since 2004
   I'm not a Dell employee

596

RoHe thank you for the thread. It seems another person had similar WOL issues with the XPS8940 and was able to figure out which settings would work for him. He did not spell out in the thread what those settings were. Also his BIOS snippets seems to show other configuration settings than what I see in my current BIOS. For example his BIOS has a "Deep Sleep" setting whereas my BIOS shows a "Block Sleep" setting instead. I think Dell needs to come up with specific instructions how to achieve working WOL settings on the XPS8940.

10 Diamond
580

@bhs-berkeley  That other thread doesn't mention any BIOS version number so it's possible the options were are different than what you see in v2.4.0.

So just disable Fast Startup in Windows, which was said to be the WOL fix in that thread:

  1. Boot to desktop
  2. Open Power & Sleep screen
  3. Click Additional power settings
  4. Click Change what power buttons do
  5. Click Change settings that are currently unavailable
  6. UNcheck Turn on fast startup
  7. Click Save changes
  8. Do a full power-off shutdown, not just a Restart.
  9. Then power on and boot to desktop
  10. Power off normally and check Ethernet LED status now

NOTE: With fast startup disabled, your boot times will be noticeably longer than they are with FS enabled. So you make a trade-off of getting WOL to work vs fast boot times.

Ron

   Forum Member since 2004
   I'm not a Dell employee

Latest Solutions
Top Contributor