XPS Desktops

Last reply by 06-13-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

XPS 8940, will not boot with DELL purchased RAM

I just purchased a XPS 8940 (11th gen i7 processor) that came with 16GB RAM (2 8GB sticks). Since I do photo editing that can sometimes be intense, I wanted to add more ram, so I ordered 2 of these, that were the recommended memory sticks from Dell: 16GB - 1RX8 DDR4 UDIMM 3200MHz. This would give me 48GB ram, which is plenty for what I need to do.

I added the additional memory to the open slots on the MB (in this case, the black slots), leaving the original 16GB on board. When I add the additional memory, the computer will not boot.

If I remove the original memory and put just the new sticks in their place (the white slots), it will not boot.

If I leave the original memory in, and just add one of the new sticks, it will not boot. I switched out the new sticks, and swapped which slot they were in. Nothing.

If I take out the original memory and move them to the black slots, it will not boot. My guess is that something has to be in the white memory slots.

The only thing I can think of is that the memory selector is wrong, or (as unlikely as it must seem), both new memory sticks are bad.

When the new memory is installed, I don't even get the Dell logo so I can access the BIOS.

I'll try to give Dell a call on Monday, but in the meantime, I'll accept any suggestions.


Replies (10)

Thank you! We have received the required details. We will work towards a resolution. In the meantime, you may also receive assistance or suggestions from the community members.

Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. To send us a private message, click our DELL-Cares username. Our Forum profile page will then appear. On the right, click "Send this user a private message".

2 Bronze
2 Bronze

In the course of doing some follow up research, it appears that 48gb of ram may not be an acceptable configuration for the 8940. However, that still doesn't explain why it doesn't work with just 32gb (2 16gb sticks), which appears to be an acceptable configuration.

3 Argentum

Will share some experience (have i7-11700) ...
My PC came with two of 8GB 3200 1Rx8 (single rank) total 16GB in while clip slots.
I've added two of 16GB 3200 1Rx8 and PC has booted showing 48GB with one exception - frequency has triggered into 2933 mode instead of 3200.
I have tried different configurations swapping black and white slots with new/old sticks or leaving just one new module in - RAM was still operating at 2933 frequency.
In a result just got another pair of the same new modules (this one worked for me: cheap Transcend JM3200HLE-16G from MemoryC, it has SpecTek chips on sticks) and it synced all four (new) modules without a problem at 3200 Mhz (Command rate: CR=1T, Gear2 mode - the only a bit slower part unfortunately, but that's by Intel specification for i7, should have gone for i9 instead for better RAM config), Therefore I assume it was just some incompatibility between two batches from different manufacturers.

There's one note - first boot after changing memory was taking around 2 minutes, not instant as it was before, but after all automatic internal checks BIOS part of boot time (Dell Logo) returned to instant (3-5 seconds?).
Since you're not saying what RAM model you have put in - it's better to be careful and not buy by accident ECC / buffered memory or the one having XMP profile (also brand new from reputable seller works much better / has lower risk, not used one).

1) Those configurations you see on specification means what Dell has tested and can assure those work, it doesn't necessarily means other configs won't work, they just can't warranty it will work.
2) Memory controller is located on CPU, although there's some logic on MB (partially BIOS controlled) for powering RAM (voltage regulator for memory, different for CPU).
3) Memory error code normally has distinct Morse sound beeps, therefore not just silent fail (although I think this is probably possible too)


@Bob F. It is possible that one or both of the new RAM modules are bad, although not likely. You should try to install the new modules, one at a time, in DIMM1 slot, the white slot closest to the CPU.

2 Bronze
2 Bronze

So...after a lot of great communications with DellCares (thank you), and a lot of swapping modules into various slots, it appears that the problem is that the system simply doesn't like a 48gb configuration.

8, 16, 24, 32 and 40gb works (in a variety of configurations), but 48 does not. If I add all 4 modules (48gb), it won't boot, and there are no error beeps or lights, it just doesn't boot.  If I remove any one module from any slot, it will boot.

I will probably buy 2 more 16gb modules, which will fill all 4 slots and get me to 64gb, which is an acceptable configuration, and that will likely be the proof of my conclusion that simply is that 48gb doesn't work.

10 Diamond

Have you tried mixing the pairs? Put two matched modules (eg, 2x 8 GB) in 1st and 2nd slots from CPU (mismatched retention clip colors). Then put the other matched pair in 3rd and 4th slots from CPU (again, mismatched) clip colors).

Now remove motherboard battery and press/hold power button on PC for ~30 sec. Reinstall the battery and see if PC boots properly now.


   Forum Member since 2004
   I'm not a Dell employee


I did mix and match the pairs. Didn't work. I did not pull the CMOS battery, since DellCares did not suggest it.

At this point, I am waiting for a couple more 16gb modules to arrive (tomorrow), and will see if 16gb X 4 remedies the issue.

Since 48gb is not a recommended configuration, it's probably best that I go with something that is recommended.


@Bob F. I must be missing something because I thought you wrote more than once that 2 x 16 GB (32 GB) did not boot. In fact, didn't you write that you can't understand why 32 GB, an acceptable configuration, did not work? Is 2 x 16 GB working now?



Sorry for the confusion. Yes, when I first tried to get this all to work, the 2 X 16gb configuration did not work. Or at least I thought it didn't it seems that after you change something (add memory...) the computer makes noises and lights up as if it is booting up and then shuts down. Apparently you have to hit the power button again, the first time after changing the configuration. I've never seen a PC do that before. 2 X 16gb may have worked from the beginning after all. (note to Dell...your documentation could use some improvement).

All that aside, I do know that 48gb absolutely does not work.

Sorry for the confusion, and thanks for your suggestions.

Latest Solutions
Top Contributor