XPS Desktops

Last reply by 07-22-2021 Solved
Start a Discussion
2 Bronze
2 Bronze
1157

XPS One 2710, Slow to boot up and shut down with new Seagate SATA HDD

As per the subject line, my PC is slow to boot and shut down since installing the new HDD. I think the boot screen is telling me that the SSD Cache (disk 0-0-1) is disabled but I don't have a screen shot of how it used to be to compare. Is this the reason for slowness, and how do I enable it please? (if indeed I should!)

20210702_154700.jpg

Another wee thing if anyone can help too, the optical drive eject button works when in ePSA Pre-boot, but not when Win10 is running. Is there a fix to make it work in Win10 please?

Many thanks

Solutions (2)

Accepted Solutions
739

Have you re-enabled the cache on the SSD?

Ron

   Forum Member since 2004
   I'm not a Dell employee

View solution in original post

708

Inaccessible Boot Device means you need to set windows to AHCI instead of the default RAID.  This needs to be fixed Before you change so that windows will see all drives.  No need to enable the SSD Cache device.

stop 7B WIN10.jpg

Go to Start > Settings > Update & Security > Windows Update > Check for updates to make sure your PC is up to date. You’ll get device driver updates too, which help improve PC performance.

 

Switch Windows 10 from RAID/IDE to AHCI.

 

Click the Start Button and type cmd.

Right-click and select Run as administrator.

 

Type this command and press ENTER

bcdedit /set safeboot minimal

 

Restart the computer and F2 bios setup

Change SATAOPERATION  to  AHCI from  RAID.

 

Save changes and exit Setup

Windows will restart  Safe Mode.

Background will be black don’t panic.

 

Click the Start Button and type cmd.

Right-click and select Run as administrator.

 

Type this command and press ENTER

bcdedit /deletevalue safeboot

 

Dell Support Resources

 

 

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support


Get Support on Twitter @DellCaresPro


Diagnostics & Tools

View solution in original post

Replies (19)
10 Diamond
811

Did you do a clean install on the new HDD or clone the old one?

Your image shows that the mSATA SSD cache isn't enabled. Read how to enable the cache. Note: Those instructions only go up to Win 8, so things may be different with Win 10...

Old PC so it's possible the eject button function isn't supported in Win 10.  Does it eject the disk if you do it manually via the software in Win 10?

 

Ron

   Forum Member since 2004
   I'm not a Dell employee

794

Hi Ron, Thanks for your reply. There's so much info in the knowledge base that unless a query is phrased right there's a high chance of missing an answer like this! I'll now see if I can confirm the procedure for Win10.

To answer your questions...

Yes, a clean install of Win10 onto the new HDD.

Yes, I can eject the media from the drive with Right click / Eject so must just not be supported on the PC.

Thanks again,

David

 

783

Hmmmm! Dell Pre Boot Diagnostics and Setup  both see the Samsung SSD but Windows does not. I set ACHP, exited setup and the computer went on to load Windows, but brought up all the exact same errors it was bringing up before I changed the main HDD. Went back into setup and reverted to RAID, computer works okay again. Now I wonder if all my troubles are actually due to the SSD cache packing up? Downloaded OpenHardwareMonitor - it cannot see the SSD either. Thoughts? Cheers.

768

In order to use the SSD as a cache for the HDD, BIOS has to be set to RAID. If BIOS is changed to AHCI, PC won't boot because Windows files that are needed are on the SSD and won't be accessible.

The cache SSD is invisible when BIOS is set to RAID. Only Windows can see and read/write to that drive. Any other activity that affects the content on the SSD would destroy the cache and stop Windows from working.

The default BIOS setting is AHCI, so if the motherboard battery died, BIOS could have reverted from RAID back to the default AHCI, meaning PC wouldn't be able to boot. So if you never replaced that battery, this may be the time to do that, before going any further.

Ron

   Forum Member since 2004
   I'm not a Dell employee

754

Hi Ron

The BIOS battery has not died, the BIOS setting has only ever been RAID, and the only reason AHCI came into the conversation is because the instructions you linked to specified that setting. Windows cannot see the SSD via Device Manager but Dell pre-boot diagnostics both see the device and return a ok result for test. I'll change the BIOS battery because it is 8yrs old after all, but just put up with the slowness. Cheers, David

740

Have you re-enabled the cache on the SSD?

Ron

   Forum Member since 2004
   I'm not a Dell employee

725

Hi Ron, no I have not re-enabled the cache on the SSD. The files don't exist at the link for the  Intel Rapid Storage Technology Application  at step 6 of the Windows 8 instruction, and you did not seem overly confident that the Win7 or Win 8 instructions would work for Win10 on this PC so I've decided to quit while I'm ahead!

This PC has been  running Win10 just fine for six years, which has been a win on its own considering Dell say it is not capable. Now with new BIOS battery, new HDD, and new AX200 WiFi6 card it is actually going to do the duty it needs to pretty well, and the person who is going to be gifted it won't even realize that it is slow to boot.   

Cheers

David

710

Too bad you didn't put an SSD in there instead of a new HDD. That would have made it boot up at lightening speed...

The giftee should be happy/thankful to get this PC!

Ron

   Forum Member since 2004
   I'm not a Dell employee

709

Inaccessible Boot Device means you need to set windows to AHCI instead of the default RAID.  This needs to be fixed Before you change so that windows will see all drives.  No need to enable the SSD Cache device.

stop 7B WIN10.jpg

Go to Start > Settings > Update & Security > Windows Update > Check for updates to make sure your PC is up to date. You’ll get device driver updates too, which help improve PC performance.

 

Switch Windows 10 from RAID/IDE to AHCI.

 

Click the Start Button and type cmd.

Right-click and select Run as administrator.

 

Type this command and press ENTER

bcdedit /set safeboot minimal

 

Restart the computer and F2 bios setup

Change SATAOPERATION  to  AHCI from  RAID.

 

Save changes and exit Setup

Windows will restart  Safe Mode.

Background will be black don’t panic.

 

Click the Start Button and type cmd.

Right-click and select Run as administrator.

 

Type this command and press ENTER

bcdedit /deletevalue safeboot

 

Dell Support Resources

 

 

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support


Get Support on Twitter @DellCaresPro


Diagnostics & Tools

Latest Solutions
Top Contributor