J50A
1 Copper

9370 Power button not working out of the box

Hello,

1. Power button doesn't work and not responsive regardless of the state - sleep/shutdown/plugged in/on battery...
Long/short/multiple press. The fingerprint sensor on it works well.
2. When on battery, it starts up on its own after shutdown/hibernate even when the lid closed!!! It says shutting down, takes the time to do so then goes off, but within 20-30 seconds starts back by itself.
When plugged in, it does not start at all. I cannot do anything to start it up because the power button is dead. However, as I remove the charger and wait the same 20 seconds, the keyboard lights up for a moment, the screen remains off but system is booting up. Touch it and hello to me.

- Windows and all the drivers are up to date
- Troubleshooting did not detect any problems
- I tried all sorts of power settings and plans including unselecting fast start up and things like "what the power buttons do"
- I tried different versions of BIOS, 1.4.0 is installed now

Am I missing something?

0 Kudos
2 Replies
ejn63
5 Rhenium

Re: 9370 Power button not working out of the box

Best bet with a DOA system -- get it replaced.

 

0 Kudos
Highlighted
K_j_b
1 Copper

Re: 9370 Power button not working out of the box

I have the problem that my XPS 9370 does only turn on if the charger is plugged in. The battery then shows fully loaded. When the system goes into sleep (or so) it does not wake up, when pressing power unless the charger is plugged in. The keyboard lighting flashes up for a few seconds, then fades out again.

0 Kudos