Last reply by 06-08-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

9380 Type C/Thunderbolt port stopped working

My 9380 xps 13 last night stopped working on the left top USBC port. When you plug in the power adapter it doesn't recognize the power adapter thus not charging the laptop through that port. I can plug it into the second port on the left and the laptop charges. I have also used the J5Create USBC dock on the port and it worked 100% yesterday - today not at all. same as using the charger.


Device manager: UCM-UCSI ACPI Device under USB Connector Managers not happy

Windows has stopped this device because it has reported problems. (Code 43)

Dell Support Assistant: All drivers are up to date


I have followed the steps outlined in this thread to try and get the port alive again but no luck.



USB Connector Managers.JPGAsMedia.JPGDead USB port.JPG

Replies (5)
3 Argentum

The Code 43 error you get is mostly because of corrupt or outdated drivers. Download DELL SupportAssist and let the application detect the hardware connected and download the drivers required for the devices to connect and work efficiently.

Tell me if this helps.


Hi Thanks for the reply. I have already run the Support Assistant and it said all is up to date.

So I have implemented the suggestions as per the previous post I made....

However - about an hour later the laptop with dock connected to the second usbc port on the left side gave me all screens black freeze. So no key could "un-freeze" the laptop. I then did a hard restart by holding the power button for 10 odd seconds. Laptop switched off and I restarted it afterwards. When the laptop boot completed I tested to see what happens when I plug power adapter into the top left usbc port....it worked. the charger was picked up correctly and you can see the battery charging icon in system tray.

The J5Create dock plugged into the left top usbc port worked and the two external screens are displaying.


Did you have any success getting your problem resolved? I have the identical problem with my XPS13 9380. I too tried the same suggested fixes as you did; something worked for a day, and then Dell SupportAssist suggested an update, and now I am back to square one with the same USB again not being recognised and showing the UCM-UCSI ACPI issue.

2 Bronze
2 Bronze

I was successful solve the problem by unplug battery connection and hold power button for 30 second.

2 Bronze
2 Bronze

Hi guys, I had this issue today and tried to fix it with support but they couldn't get it working right, after several tries I got it myself. Here are the steps which help in my case: 
- go to Device Manager
- hover your mouse over the files with an exclamation (!) mark
- right-click
- update driver 
- Browse my computer for drivers (after several tries "search automatically...") 
- Let me pick from a list...
- and then select the first option (if not working then try the second)
- next
- close

These step by step, helps me fix this problem. 
I hope it was helpful to you guys also.

Latest Solutions
Top Contributor