Ronald S.
1 Copper

Re: Alert! TPM device is not detected

This is very annoying. I have a Precision that I spent almost $3k on and having the same problem. Does Dell put these BIOS update through adequate testing? Does not appear to be the case.


OS Name Microsoft Windows 10 Pro
Version 10.0.18363 Build 18363
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name PRECISION-001
System Manufacturer Dell Inc.
System Model Precision 5530
System Type x64-based PC
System SKU 087D
Processor Intel(R) Core(TM) i7-8850H CPU @ 2.60GHz, 2592 Mhz, 6 Core(s), 12 Logical Processor(s)
BIOS Version/Date Dell Inc. 1.15.0, 12/25/2019
SMBIOS Version 3.1
Embedded Controller Version 255.255
BaseBoard Manufacturer Dell Inc.
BaseBoard Product 0NFGCT
BaseBoard Version A00
Platform Role Mobile
Secure Boot State On
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "10.0.18362.387"
User Name AzureAD\RonaldSircar
Time Zone US Mountain Standard Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.7 GB
Available Physical Memory 6.94 GB
Total Virtual Memory 19.2 GB
Available Virtual Memory 7.92 GB
Page File Space 3.50 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Un-allowed DMA capable bus/device(s) detected, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

1 Copper

Re: Alert! TPM device is not detected

I have the same issue and can't fix it myself

1 Copper

Re: Alert! TPM device is not detected

Mainboard has to be replaced.

1 Copper

Re: Alert! TPM device is not detected

Is this a fact?

1 Copper

Re: Alert! TPM device is not detected

For me it has always been the case. I have had multiple (+10) Latitudes with TPM gone missing after a BIOS update. So far, Dell has always replaced the motherboard.

1 Copper

Re: Alert! TPM device is not detected

I too had this problem for a long time on several computers at work but managed to solve it.

During my quest to find a solution I tried everything but it never occurred to me that I never shut down my computer and unplugged to power cord. I have always shut it down with the power cord still in, just restarted the computer or have it gone in sleep mode. I bet most corporate do this using sleep mode or have the AC plugged in when shut down.

Well how stupid did I feel when I shut down my computer completely, unplugged it from the AC and let it be for 30 second. When I plugged in the AC again and turned on the computer the magic happened. LOL The TPM alert was gone. For some reason shutting down the computer and unplugging the AC for 30 seconds seems to do something allowing the bios to find the tpm again.

So I tried the same on a second computer and the same stupid fix worked on that one. Well in the end we did this on all the computers encountering this and the same fix applied for all of them. So after this we are now upgrading the bios on all computers and any computer getting this error is easily fixed by shutting it down, removing the AC for 30 second and then firing up again. lol

So if you havent tried this then please try it and see if it works for you. Im not saying it is the fix but worth trying 🙂