ukognas34
1 Copper

Re: Annoying fan noises on 2018 XPS 15 9570


@TheKala  a écrit :

My dell XPS 15 9570 (8th gen i7, 16gb ram) has a problem where the fans turn on and off every 2-3 seconds. The fan is not loud but it is very annoying. I don't mind have the fan run continuously but the on off cycle really annoys me when I'm working. Is there anyway to turn off the on off fan cycle?



Did you try to go into the device manager, and disable then enable the nvidia GPU ? I think it should solve the problem. If it does, I can give you a script to do this automatically at each system boot.

0 Kudos
Highlighted
ukognas34
1 Copper

Re: Annoying fan noises on 2018 XPS 15 9570


@pcvl  a écrit :

Thats exactly the same problem I have! Could you tell us how you solved it step-by-step so I can do it too?

 

Thank you,

 


So first, be sure that you have the same problem as me : with CoreTemp or HWMonitor for example, monitor your CPU comsuption at idle, with any other program closed. If it's around 0.5W, I don't know how to help you.

If it's around 3.0W, go into the device manager, under display adapters, and disable then enable your NVidia GPU (or enable then disable, if it was already disabled). Your CPU consumption at idle should be back to normal, around 0.5W.
Then, you will need to download this zip file : Devcon.zip . It contains devcon.exe, a batch to enable then disable the GPU and an XML file for the task scheduler. Unzip it and place the Devcon folder in C:\. Devcon is a software to enable or disable a device in a terminal. You can find help about devcon here . First, you need to open a terminal in the devcon folder, and type : 

devcon hwids *

It will show you informations about all you devices. Search for the NVidia GPU (you can search nvidia with ctrl+F).  Below, you have a list of hardware and compatible IDs. Note the last ID of the compatible IDs list. For me, it's PCI\CC_0302. Now, you can enable or disable your GPU with the terminal. For example, to enable it, open a terminal as administrator and type : 

C:\Devcon\devcon enable 'PCI\CC_0302

It's an example working for me, but you might need to modify the path, the ID, according to where you placed the Devcon folder, and what yor GPU ID is. You can also choose to disable it.

Then, you can modify the disable_gpu batch file with your path, your GPU ID. You can switch the first two lines if you want your GPU to stay enabled.

Finally, open the task scheduler and import the XML file Disable_GPU, or create a new task, which executes your batch file when you want. Be sure to tick the box "run with highest privileges".

 

I hope it will work for you too!

 

 

0 Kudos