XPS

Last reply by 12-14-2021 Solved
Start a Discussion
2 Bronze
2 Bronze

Battery not recognized

I have an xps 13<Private Service tag removed. TOS72>I recently changed the battery because orginal one was no longer holding charge. I bought the new battery from parts-people.com initially it worked like a charm bringing back the old full charge backup of over 14 hours then recently dell pushed through the latest BIOS and all of a sudden the new battery is not recognized the orange status led continuously flashes, preboot support assist detects a non compatible battery and in BIOS under battery information the status switches between 'Idle' and    'charging' and  'disconnected' frequently computer rarely turn on with only battery but often will not even show any light. I was thinking how a BIOS update suddenly found that I am operating on a non OEM battery after all I purchased the battery from parts-people.com. I did all the trouble shooting including the powerdrain after disconnecting the battery and charger, turning on without battery and putting the battery battery back on etc I also restored BIOS to 'last known good configuration'. I am afraid to do a BIOS downgrade as they computer may just shuts down during the process. Any inputs highly welcome 

Replies (5)

Hi I powered on the laptop without the battery connected and reconnected later after it is completely switched off, this fixed my issue you can try this but if it still not working then disconnect the main battery along with the coin cell CMOS battery diconnect every outside connections and press and hold the power button for 30 seconds put everything back and see, either of these should fix the issue 

2 Bronze
2 Bronze


I must also mention that when I saw that the new battery is not recognized I tried to put back the original battery and it is no longer recognized.

        Hi Neil, 

Can you please describe to me exactly the steps I should follow? I have the same problem as yours, and I couldn't get it to work. Thanks in advance.

Thanks man that seems to have taken care of my issue. Earlier I did the power drain within the cmos battery disconnected but this time I did just as you advised and it worked thanks

4 Ruthenium

Yes do not play with BIOS downgrade/upgrade, without battery it can kill the Motherboard. 

This is very rare that BIOS is giving error of non complaint battery. 

Remove both main battery and coin cell,  Release charge by holding power button for 30 seconds. 

 


Community Accepted Solution
Top Contributor
Latest Solutions