Last reply by 08-16-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

Can't upgrade one RAM Slot

XPS 15 7590


I have a Dell XPS 15 7590.

The Laptop has two RAM Slots. 2x 4 GB RAM were installed. I wanted to upgrade it with 2x 16GB RAM.

However when I replaced both Slots with the new RAM. When I started my Laptop I didn't get an image. Only the status bar began blinking white and amber lights. Always 3x White and then 2x Amber and then repeating the cycle.

I reinstalled both old RAM sticks (2x 4GB) and the Laptop booted just fine. I only got one message from some Diagnostic tools before booting into Windows which said that the previous boot attempt didn't have memory or something like that. 

After that I tried to install only one new RAM Stick. I installed it in the right slot (see the picture).  This worked fine and I could boot as always. I also tried to install the other RAM Stick in the right slot. This worked fine too. Meaning that the  new RAM Sticks probably aren't problem.

However when I tried to install one of the new RAM Sticks in the left slot and install one of the old RAM Sticks in the right slot. It didn't work.

This leads me to believe that there's some problem with the left slot, which prevents me from upgrading it. It would be great if somebody could help me to solve this problem. If more information or pictures are needed, please ask. I will send them to you.IMG_20220810_185130.jpg

Solution (1)

Accepted Solutions

How I solved the problem:

I ordered new 32GB Ram from Crucial and it worked.

View solution in original post

Replies (6)
8 Krypton

It sounds like your troubleshooting has definitively pointed to a marginal RAM socket. 

Two options:

1.  Run the system with a single 16G module, or

2.  If you must have 32G, replace the system board.

You can try a single 32 G module, but the system is not certified for that -- it may or may not work.

You can also keep one of the original modules plus the second 16G, but that's not recommended from a performance standpoint.


8 Platinum

Sounds like incompatible ram to be.

And that pic you posted ... best to never run mis-matched DIMMs (just a single would be better than that).

Try this:
- Reinstalled both original ram-memory DIMMs (2x 4GB).
- Boot up. Check memory detection in BIOS. Check Windows operation real quick. Shut-Down.
- Press F12 and run ePSA Diags. Look for 100% pass of "long test".

- Create and boot USB-drive from www.MemTest86.com . If you can complete two long test-passes with 0-errors ... your motherboard (and ram slots) are perfectly fine.


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
6 Indium

Welcome to the Dell Community   @thomas.marzell 

Did you try the new memory in the left slot with no other memory in the right slot???

Best regards,



Yes this doesn't work either.

2 Bronze
2 Bronze


I've just found something weird. If I remove the left slot (where the OLD Ram Stick is) and only boot with the right slot (where the new Ram Stick is) it suddenly doesn't work anymore. Even though it worked perfectly when the Old ram Stick was in the left slot and the new one in the right slot.


How I solved the problem:

I ordered new 32GB Ram from Crucial and it worked.

Latest Solutions
Top Contributor