Highlighted
Edgoro
1 Copper

Cannot reinstall wifi network adaptor "Intel(R) WiFi Link 5100" dell studio

Dear community,

First of all, I warn you that English is not my first language (but I handle it quite well and understand) so I apologize for some mistakes.

So, since yesterday, I have an issue with the wifi network adaptor of my Dell studio 15 (Windows Vista) laptop. The wifi connection got lost (not a problem within my house as my other laptop and devices detect the wifi). As it already happened to me in the past, I tried to fix it using the following strategy:


- Open "device manager", uninstall the network wifi adaptor
- Search for modifications and so let windows automatically reinstall the adaptor and the driver/device Intel(R) WiFi Link 5100


It always worked perfectly in the past but yesterday it didn't. Indeed, when I asked to search for modification, it took a long time (almost 5 minutes) and displayed a message telling me that it cannot install the driver (even though it finds it) and stopped while displaying a message telling me that the time expired.

Even stranger, after it fails, if I open the "device manager" menu, my wifi adaptor name is different from before. Indeed, now it is named "Intel(R) WiFi Link 5100 #2". And to make it again more stranger, everytime I reboot, of course windows tells me that it detected a new device and wants to intall the driver. And when I say "OK", now it tells me that it manged to install the driver. BUT the wifi still doesn't work and there is always that name that is different from the "original one".

To summarize:

- When I try to reinstall my wifi network adaptor, windows fails (at least to install the driver) and a network adaptor with a different name from the original is displayed in the "device manager" menu.

- When I reboot, windows automatically tries to reinstall the driver and claims that it managed to do it.

- But the wifi is still not working (by the way, the "wifi" LED on the board never turns on anymore since I got that trouble).

Did someone has an idea aout how to fix it? Even it is cumbersome, I can reinstall everything as last resort (Vista, drivers, etc.) but do you think that it could really fix that issue? In other words, do you think that this is my wifi card which is dead?

I know that this is an old laptop but it was still working fine and actually I use it only like a "2nd TV/surfing/desktop" while using my other laptop for job purposes only.

Thank you in advance for your help!

0 Kudos