1 Copper

Cannot upgrade SSD to 1tb - incompatible 970-960 EVO ?

Hello to the community. I've had the following problem for the last 10 days, and it drives me crazy.

I've tried every possible solution i can think, still no luck.

My XPS 9570 works ok with the pre-installed 512gb nvme SSD. SK Hynix 512.

When i try to install either the samsung 960 evo or the 970 evo 1tb Samsung i crash after some minutes with a BSOD "DRIVER POWER STATE FAILURE"

 More specifically, i am doing a clean install by the DELL OS recovery software, that i download from dell's site with my Service TAG.

 Windows installs normally, and then after the first 1-2 restarts that windows downloads the extra updates with me updating my drivers from DELLS SupportAssistant, or when i try to download my first basic programs i crash with the same exact BSOD. "DRIVER POWER STATE FAILURE"

 I've done the exact same steps with a clean install in the SK HYNIX drive, it works fine. Rock solid after 1-2 days of heavy use.

The same exact steps with 2 1tb ssds (960 evo - 970 evo) i crash after 1-2 minutes. I've upgraded the SSDs firmware, i have latest drivers, bios, downloaded samsung drivers from the internet.

Is there any sort of incompatibility?
Anything else i am doing wrong?
Any help appreciated.

Labels (2)
Tags (3)
0 Kudos