2 Bronze

Dell Drivers & downloads Fails to install on XPS 15 9530

Dell Drivers & downloads webpage insists my video driver has an update, but Fails to install on XPS 15 9530 video driver [Intel HD 4600 Graphics Driver 20.19.15.4835]. I've tried numerous times. Manually Extracted driver and tried to point [Update Driver] to extracted folder. Just tried running .EXE file in Safe Mode but error said not compatible.

 

Driver failure.png

 

Labels (1)
0 Kudos
3 Replies
1 Copper

Re: Dell Drivers & downloads Fails to install on XPS 15 9530

Try again with the new update, I had that same problem, failed to install, manual try always said not correct hardware, official Intel HD drived said custom dreiver installed so that wouldn't work either, was online today after playing with the update assistant and there is a new revision to the driver, version A04, that installs fine and updated me straight away.

0 Kudos
2 Bronze

Re: Dell Drivers & downloads Fails to install on XPS 15 9530

Thank you BR15K, the new A04 version worked for me too.
Your post got my attention to check again. I had lost faith that Dell still cared about our "old" laptops.
I remain fully delighted with my XPS 15 9530 and hope to keep it in service for at least a few more years.

0 Kudos
1 Copper

Re: Dell Drivers & downloads Fails to install on XPS 15 9530

Not a problem, I found it very strange that the Dell software updater constantly told me there was an update but never let the system update with it, by chance I tried again one day and noticed it was offering a different version of the update and hey presto, all updated again, wish they'd do a Bluetooth update, virtually useless on a 9530, only way I can Bluetooth anything across is to open the actual laptop Bluetooth app and tell it to "Receive file", then it will let me send a file across, all my other laptops (D630's) put this to shame, I walk in with the phone, select photos and click send, laptop instantly responds and accepts files, when I try this on the 9530, everything looks like it's working but seconds later , always the same message , "file failed to send" .

But this is modern technology at its best, get something that works fine, then break it, it worked best of all In XP, still worked but not so well on Windows 7 and virtually useless in Win 10, why does technology go forwards so badly 😠😠
0 Kudos