Highlighted
Vitaliy S
1 Copper

Dell Premier is not working.

Jump to solution
https://www.dell.com/community/XPS/XPS-15-9570-UHD-Dell-Premier-color-not-working/m-p/7369616#M34159 Continuing this thread. When I buying this laptop at first step I update all drivers to latest version using dell support assistant. Next I trying to change display profile in Premier Color, and its not working. Then I decided to write message there. Currently I have latest version of all drivers, that offer me support assistance. And yes, only brightness slicers is working now on Premier Color.
0 Kudos
1 Solution

Accepted Solutions
Renx-78
2 Iron

Re: Dell Premier is not working.

Jump to solution

It happened to me several times, in the various times I was formatting; I reinstalled Windows to the latest version; I updated everything and then installed Premier Color, only the brightness adjustment worked. I could not figure out what it depended on but as soon as an Intell video driver update (from the Dell site) arrived, Premier Color started working properly again.
Assuming that the configurations of the various versions of the 9570 may differ for some components, it does not necessarily solve your problem. You can try downloading the latest version of the Intel graphics drivers from the Dell support site, after which you disconnect from the network, uninstall the Intel graphics driver (from Control Panel -> Applications), reinstall the downloaded drivers and after rebooting you reconnect to the network. If you want try to do this and see if it starts working again!

0 Kudos
1 Reply
Renx-78
2 Iron

Re: Dell Premier is not working.

Jump to solution

It happened to me several times, in the various times I was formatting; I reinstalled Windows to the latest version; I updated everything and then installed Premier Color, only the brightness adjustment worked. I could not figure out what it depended on but as soon as an Intell video driver update (from the Dell site) arrived, Premier Color started working properly again.
Assuming that the configurations of the various versions of the 9570 may differ for some components, it does not necessarily solve your problem. You can try downloading the latest version of the Intel graphics drivers from the Dell support site, after which you disconnect from the network, uninstall the Intel graphics driver (from Control Panel -> Applications), reinstall the downloaded drivers and after rebooting you reconnect to the network. If you want try to do this and see if it starts working again!

0 Kudos