XPS

Last reply by 11-23-2020 Solved
Start a Discussion
2 Bronze
2 Bronze

Dell Premier is not working.

https://www.dell.com/community/XPS/XPS-15-9570-UHD-Dell-Premier-color-not-working/m-p/7369616#M34159 Continuing this thread. When I buying this laptop at first step I update all drivers to latest version using dell support assistant. Next I trying to change display profile in Premier Color, and its not working. Then I decided to write message there. Currently I have latest version of all drivers, that offer me support assistance. And yes, only brightness slicers is working now on Premier Color.
Solution (1)

Accepted Solutions
3 Silver

It happened to me several times, in the various times I was formatting; I reinstalled Windows to the latest version; I updated everything and then installed Premier Color, only the brightness adjustment worked. I could not figure out what it depended on but as soon as an Intell video driver update (from the Dell site) arrived, Premier Color started working properly again.
Assuming that the configurations of the various versions of the 9570 may differ for some components, it does not necessarily solve your problem. You can try downloading the latest version of the Intel graphics drivers from the Dell support site, after which you disconnect from the network, uninstall the Intel graphics driver (from Control Panel -> Applications), reinstall the downloaded drivers and after rebooting you reconnect to the network. If you want try to do this and see if it starts working again!

View solution in original post

Community Accepted Solution
Replies (3)
3 Silver

It happened to me several times, in the various times I was formatting; I reinstalled Windows to the latest version; I updated everything and then installed Premier Color, only the brightness adjustment worked. I could not figure out what it depended on but as soon as an Intell video driver update (from the Dell site) arrived, Premier Color started working properly again.
Assuming that the configurations of the various versions of the 9570 may differ for some components, it does not necessarily solve your problem. You can try downloading the latest version of the Intel graphics drivers from the Dell support site, after which you disconnect from the network, uninstall the Intel graphics driver (from Control Panel -> Applications), reinstall the downloaded drivers and after rebooting you reconnect to the network. If you want try to do this and see if it starts working again!

Community Accepted Solution

Thanks it worked with my dell xps 9500 ;-).

My intel UHD driver was already up to date before the operation, but by uninstall it and reinstall it without the netwok it worked ;-).

2 Bronze
2 Bronze

Try this
1. Uninstalled Dell premier colour
2. Go to this link
https://www.dell.com/support/home/en-uk/drivers/driversdetails?driverid=vvw6m
3. Download the file and install.
4. Restart the computer.
5. On the desktop, right click, “Dell premier colour” should be in the drop down. From here another menu will drop down where you can choose the required colour space.
HOPE THIS HELPS

Top Contributor
Latest Solutions