Calixte
1 Copper

Dell XPS 13 9350 Touchpad Issues after upgrading to Ubuntu 17.10

Jump to solution

After upgrading to 17.10, the touchpad configuration is messed up. Side scrolling doesn't work anymore and something about either the palm detection is completely off so that the text cursor randomly jumps when I type.

This same problem happenned again after a complete reset.

Is there a way I can load the original touchpad driver/configuration?

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
Calixte
1 Copper

Solution

Jump to solution

For some reason this post was marked as **bleep**, so here it is again:

Ubuntu was indeed installed from the factory, but the problem arose after upgrading the OS according to normal procedure, having installed no third party software. Why is it that the first response from Dell we get is always get is "not our fault" instead of something helpful?

I have, however, managed to solve the problem myself. I posted the solution below for anyone who may have the same problem as me.

Notes for beginners: 

Spoiler
  • Copying and pasting on the terminal is done with "Ctrl+Alt+C" and "Ctrl+Alt+V"
  • The command "sudo" enables you to edit system files as "root"(administrator) which you wouldn't be able to otherwise. The terminal will ask you for your password the first time you use it.

Easy step-by-step solution:

There should be a file named "70-synaptics.conf" in "/usr/share/X11/xorg.conf.d/". To check, type the following in the terminal: 

ls /usr/share/X11/xorg.conf.d

If "70-synaptics.conf" is present, it should appear within the list. If it doesn't, check for "50-synaptics.conf" or something similar and proceed replacing all mentions with that file. However, you should not edit that file as the changes you made to it will be overwritten next time you upgrade. 

Instead, copy and paste the file to "/etc/X11/xorg.conf.d/" 

sudo cp -i /usr/share/X11/xorg.conf.d/70-synaptics.conf /etc/X11/xorg.conf.d/70-synaptics.conf 

Open the file with your text editor: 

sudo gedit /etc/X11/xorg.conf.d/70-synaptics.conf

Add the following lines to the file:  

#This section was added by the user
Section "InputClass" Identifier "touchpad catchall" Driver "synaptics" MatchIsTouchpad "on" # Add all options below MatchDevicePath "/dev/input/event*" Option "PalmDetect" "1" Option "HorizTwoFingerScroll" "1" EndSection

You can also add other options. The full list can be viewed by typing "synclient" in the terminal. 

The ones added here are:  

Option "PalmDetect" "1" #reenables palm detection
Option "HorizTwoFingerScroll" "1" #reenables horizontal scrolling 

I also added a couple of other options, decribed below: 

Option "ClickFinger3" "2" #enables "middle mouse button" with a 3-finger tap
Option "TapButton3" "2" #enables "middle mouse button" with a 3-finger click
Option "VertEdgeScroll" "0" #disables scrolling using the edge of the touchpad

Additionally, you should also try adding and changing the values of the two options below if palm detection remains wonky (shown below with their default values): 

Option "PalmMinWidth" "10"
Option "PalmMinZ" "200" 

 

3 Replies
Community Manager
Community Manager

Re: Dell XPS 13 9350 Touchpad Issues after upgrading to Ubuntu 17.10

Jump to solution

Hi Calixte,

Thanks for posting.  Apologies that your system is not performing as expected.

Unfortunately if the Ubuntu OS wasn't installed from the factory, it would not be supported by Dell.  However you may be able to get some assistance with your question from here:  

canonical.com


Dell-Robert P
Social Media Support
#IWork4Dell
To help us troubleshoot, please send us the Dell service tag number via a private message
Would you like to be a Dell Community Rockstar?


0 Kudos
Calixte
1 Copper

Solution

Jump to solution

For some reason this post was marked as **bleep**, so here it is again:

Ubuntu was indeed installed from the factory, but the problem arose after upgrading the OS according to normal procedure, having installed no third party software. Why is it that the first response from Dell we get is always get is "not our fault" instead of something helpful?

I have, however, managed to solve the problem myself. I posted the solution below for anyone who may have the same problem as me.

Notes for beginners: 

Spoiler
  • Copying and pasting on the terminal is done with "Ctrl+Alt+C" and "Ctrl+Alt+V"
  • The command "sudo" enables you to edit system files as "root"(administrator) which you wouldn't be able to otherwise. The terminal will ask you for your password the first time you use it.

Easy step-by-step solution:

There should be a file named "70-synaptics.conf" in "/usr/share/X11/xorg.conf.d/". To check, type the following in the terminal: 

ls /usr/share/X11/xorg.conf.d

If "70-synaptics.conf" is present, it should appear within the list. If it doesn't, check for "50-synaptics.conf" or something similar and proceed replacing all mentions with that file. However, you should not edit that file as the changes you made to it will be overwritten next time you upgrade. 

Instead, copy and paste the file to "/etc/X11/xorg.conf.d/" 

sudo cp -i /usr/share/X11/xorg.conf.d/70-synaptics.conf /etc/X11/xorg.conf.d/70-synaptics.conf 

Open the file with your text editor: 

sudo gedit /etc/X11/xorg.conf.d/70-synaptics.conf

Add the following lines to the file:  

#This section was added by the user
Section "InputClass" Identifier "touchpad catchall" Driver "synaptics" MatchIsTouchpad "on" # Add all options below MatchDevicePath "/dev/input/event*" Option "PalmDetect" "1" Option "HorizTwoFingerScroll" "1" EndSection

You can also add other options. The full list can be viewed by typing "synclient" in the terminal. 

The ones added here are:  

Option "PalmDetect" "1" #reenables palm detection
Option "HorizTwoFingerScroll" "1" #reenables horizontal scrolling 

I also added a couple of other options, decribed below: 

Option "ClickFinger3" "2" #enables "middle mouse button" with a 3-finger tap
Option "TapButton3" "2" #enables "middle mouse button" with a 3-finger click
Option "VertEdgeScroll" "0" #disables scrolling using the edge of the touchpad

Additionally, you should also try adding and changing the values of the two options below if palm detection remains wonky (shown below with their default values): 

Option "PalmMinWidth" "10"
Option "PalmMinZ" "200" 

 

rept
1 Copper

Re: Solution

Jump to solution

Hi,

@Dell totally unhelpful response!

@Calixte I'm getting this error:

cp: cannot create regular file '/etc/X11/xorg.conf.d/70-synaptics.conf': No such file or directory

The directory /etc/X11/xorg.conf.d/ doesn't exist.  (using Ubuntu 18 though).

0 Kudos