Highlighted
derfaba
1 Nickel

Dell XPS 13" 7390 /w i8650U # GPU Hangs: freezes, bei geringster last auf der GPU (Intel UHD 620 SoC) (Win + Linux)

Hi,

hier mal meine Leidensgeschichte mit DELL Hardware (ich will das alte XPS 13" design zurück! - oder zumindest ein redesign der Lüftung):

--> Dell XPS 13" UHD 4K Touch /w i8650U und Toshiba 500GB NVMe

Ich habe, fast, durchgehend massive freezes von mehreren Sekunden (~3-30sec), in denen keinerlei Interaktion mit dem Betriebssystem möglich sind. Im Anschluss, funktioniert die GPU dann wieder - aber leider nur bis zum nächsten freeze und der kommt ganz bestimmt!

Also, dann nochmal gegliedert:

#problem#
- freezes von mehreren sec der GUI jedes, getesteteten, Betriebssystems (unter Linux weit schlimmer als unter Windows)
- innerhalb der freezes keine Interaktion mit dem Betriebssystem möglich
- innerhalb der freezes keine Eingaben innerhalb der GUI des Betriebssystems möglich
- Was während der freezes funktioniert:
-- textconsole/TTy unter Linux mit 640x480 VGA rendering vom generischen analogen nativen Ausgabetreiber
-- innerhalb von Windows, funktionierte wirklich garnichts im freeze (Logisch: weil alles GUI)
- zum Zeitpunkt des freezes, konnte ich folgende Beobachtungen machen:
-- GPU load kurz auf 100% - direkt, mit Abfallen des loads auf 99% -> freeze
-- GPU läuft trotz 100% load nur auf max 8W (**bleep** ?! bei einem 15W TDP -.-)
-- GPU taktet auf die maximal erlaubten 1220MHz (auch komisch, im datasheet von Intel steht max 1150MHZ)
-- Temp GPU steigt auf ca 80-90°C - und bleibt dort für X sec
-- Lüfter drehen, erst nach freeze und +X sec Hoch
-- CPU0-7 - load steigt an, aber nicht im kritischen Bereich
-- CPU Temps steigen auch auf 60-80°C (und somit dann auch im throtteling der einzelnen CPU Taktungen)
-- kurz vor dem freeze:
--- steigt immer!, eine bestimmte (00:04:* PCIe HW mapping - IRQ könnte ich auch liefern) PCIe HostBridge aus (state dead kein recover möglich, selbst Manuell mit HW befehlen)
--- der Fail passiert, wenn "extended registers" für das ACPI Powermanagement enabled und allokiert wird, da wohl nicht genügend Speicheradressen vom Bios selbst reserviert wurden, muss ACPI selbst nachhelfen -> die extended registers sind aber nicht adressierbar für ACPI, da in einem ganz anderen Betriebssystem State gebunden (hier wird, auf Deutsch, also die Berechtigung verweigert diese Adressen zu beschreiben)
----> ### Mir ist nicht ganz klar, ob das irgendwie irgendwo zusammen spielt und in Summe die freezes ergeben ... allerdings sitzt die GPU auf PCIe 00:00:00* HW mapping, was nichts mit der obigen HostBridge zu tun haben sollte - da, meines Wissens, zwei unterschiedlich adressierte Bus Interfaces mit unterschiedlich allokierten Speicheradressen sind.


Ich bin mitlerweile echt dermaßen verzweifelt ... ich habe schon folgendes unternommen um dem Ganzen irgendwie bei zu kommen:

#allgemein#
- Bios auf latest updated
- Firmware aller Komponenten auf latest updated

- Dell Powermanagement installiert ... hmpf
-- danach war alles gefühlt NOCH schlechter (in jeglichen Energieklassen/optionen) (die GPU lief bei 100% load zum Teil auf 3-6W und das bei einem 15W TDP ?! **bleep**, was tut ihr der Hardware hier nur an - undervolting schön und gut, aber das ist echt zu viel)
-- habe sogar Testweise das Active PowerLink State Mon für den PCIe kram deaktiviert - resultierte in maximal drehenden Lüftern und einer GPU die noch immer in Sleep versetzt werden kann ? Das soll mir mal einer erklären, wie der Modus noch funktionieren soll, ohne Power LinkState Monitoring!

#windows testing#
- Windows Versionen getestet (mit "clean" install - auch wenn ich das für pseudo erachte ...):
-- Windows 1703 + Windows 1709 + Windows 1803 + Windows 1809 + Windows 1903

-- PSR in den intel Treibereinstellungen deaktiviert (und die wesentlich schlechtere Akkuperformance in Kauf genommen)

-- Neuste Treiber von Dell (inkl. manuell und SystemAssistant + Update) und auch direkt von intel geladen und installiert (warum ist bei intel eigentlich eine wesentlich aktuellere Version des UHD GPU/Iris Treibers verfügbar, als auf der DELL Support Page ?)
-- INFO: hier allerdings nur die 1803 + 1809 + 1903 je mit allen Treiberkonstellationen (MS forciert feature updates also macht älter wirklich keinen Sinn)

 

#linux testing (hier kenn ich mich auch besser aus als auf Windows)

- Linux Kernel/Versionen getestet(und auch, aus purer Verzweiflung, mit exakt passenden options komplett selbst kompiliert):
-- RedHat Kernel 4.1 bis  einschl. 5.2RC3+4 getestet
-- Ubuntu LTS 16.04 + 18.03 stable + 20.04 + 22.04 unstable/upstream getestet (weil die developer edition ja mit Ubuntu 16.04 und jetzt mit 18.03 geshippt wird, muss da ja eig alles nativ unterstützt werden und sollte funktionieren)
-- archlinux mit mainline kernel getestet (kernel + treiber selbst kompiliert)
-- alle intel LTS (btw. LTS==LongTermSupport) von 4.1.17 - 4.9
-- die neuste DRM-TIP und DRM-INTEL von freedesktop (mit den aktuellsten commits für die intel Treiber und firmwares - von intel selbst)
-- unter allen Kernel Versionen, den "alten" intel  2D Treiber xf86-video-intel kompiliert(inkl. deps.: Mesa VAAPI xf86-video-intel LibDRM # wird von intel selbst gecoded und verwaltet -> quasi closed source treiber vom Hersteller)
-- unter allen Kernel Versionen, den "neuen" intel  2D Treiber xorg-drv-intel und mesa kompiliert (wird von den mainline kernel leuten, witzigerweise auch Jungs von intel, gecoded und verwaltet -> quasi open source treiber)
-- den modesetting Treiber vom Linux Kernel getestet, auch mit DRI3 ...
--- hier muss man ehrlich sagen, das Setup, ergab noch die stabilste und beste Lösung - mit den unpassensten Treibern die man für einen modernen XPS13" nur laden kann.

---> ## ich habe wohl ziemlich sicher, eigentlich alle existierenden Versionen vom standard Kernel über Windows FeatureUpdates in Verbindung mit jeglichen Treiberkonstellationen getestet, die man auf Linux und Windows zur Verfügung hat. Nicht ein Setup war so, dass ich sagen würde:"damit kann man Arbeiten!" ...  uff ...


#DELL DE Support Hotline#
- VIER Versuche, eine Klärung, auf eine Lösung Hoffe ich schon lange nicht mehr, zu erarbeiten
-- bei 2/4 Versuchen, wurde ich, nach beschreiben meines Problems und Nennung des ServiceTags, wurde ich mit der Aussage "Ich muss eben schnell was klären hierzu, ich bin gleich wieder für sie da" on Hold gesetzt und nach 30 sec - 1 min on Hold glatt komplett aus der Leitung gekicked! aber hey, bei so viel eigener Fehlersuche und dem Auschluss jedes, eigentlich, denkbaren Softwareproblems oder Abhängigkeiten ... nene, verarscht kommt man sich da echt nicht vor ... -.-'
-- bei einem Versuch, gabs wohl etwas komisches an meinem Datensatz vom ServiceTag ... schlappe 24min on Hold, ich habe dann nach aufgelegt, da ich nebenher iwie arbeiten musste ^^
-- der noch fehlende zu 4/4, war leider akkustisch sowie auch sprachlich (wobei ich aus sprachlichen Hindernissen niemandem einen Vorwurf mache!) - in Kombination, war das leider alles andere als Zielführend

@DELLSUPPORTSwer kann denn bitte zu euren Servicezeiten in DE, mal eben so mitten am Tage, für ne Stunde oder mehr, dauerhaft nur warten bis mal eben "was abgeklärt" wurde ?! Es gibt durchaus Menschen in Deutschland, die Arbeiten exakt zu euren ServiceZeiten - und Urlaub will ich mir für einen Dell SupportCall nun echt nicht nehmen müssen!

Aus Verwzeiflung, habe ich dann den DELL US Support angechatted ... die haben wesentlich besetzere ServiceZeiten - und tausend mal besser gelegen, für unseren arbeitenden und normalen privaten DE-Kunden. DELL US meinte eigentlich, nach recht wenig Fehlerbeschreibung und Testcases, dass man hier das Motherboard tauschen müsste - allerdings über den DE Support.

Es gibt scheinbar auch keine Support MailAdresse, bei der man seinen incident einfach, kanalisiert und zu bestimmt gewählten Tageszeiten, weiter bearbeiten kann - warum gibt es bei Dell nur interaktive Ansätze des Supports ?
Zumindest ist mir was anderes nicht bekannt, was DE angeht ... falls jemand eine Adresse oder Endpunkt hat - gerne her damit!

Als letzten, zugegeben etwas merkwürdigen, Versuch, habe ich einfach mal versucht, auf meine ServiceTag ID eine Erweiterung des Supports zu kaufen/bestellen, so dass ich NextDaySupport bekommen könnte ... dies wurde mit quasi einem "nicht möglich" "wenden sie sich gefälligst an den Händler" nach dem Motto "wenn sie schon nicht bei uns direkt kaufen"  ... da hier anscheinend initial mal keinerlei support, auf dem Gerät gebunden war, kann ich auch keinen neu Buchen bzw. hinzu buchen.
(Notebook habe ich in UK gekauft (btw: in UK gibts die Gewährleistung, wie wir sie kennen, für ganze komplette 6 jahre lang!): und mein Fall, wäre meines Erachtens nach, auf jeden Fall ein Fall für eine Gewährleistung - da der Fehler sich schon stark Richtung "zu heisser" Hardware bzw. Platine kristallisiert. Das wäre ein wirklicher Mängel, da sowas ja nur vorkommen kann, wenn etwas falsch dimensioniert wurde oder nicht richtig funktionierte und das ab Werk - da auch keine der Seals gebrochen sind, lässt sich gut beweisen, dass das Gehäse nie offen war und der Schaden gleich im Betrieb entstanden sein muss.

Falls irgendjemand, schon mal ähnliches durchgemacht hat und oder den Fehler oder Teile davon kennt, bitte gebt kurz Bescheid ! Danke schonmal, für alle die bis Hierhin durchgehalten und gelesen haben 😄 aber die Story nimmt langsam auch echt verdammt komische Züge an ...

und mitlerweile @dell - besorgt mir einfach die Möglichkeit, für eine , von mir bezahlte und Dell zertifizierte, Reperatur bzw. einem Motherboard Tausch - und ich erhebe niemals wieder, auch nur ein Wort gegen Dell ... (war vermutlich auch die letzte HW die ich von Dell gekauft habe)

fab.

PS: Zu letzterem, da gibts wirklich was komisches, da ich meinen ServiceTag auch nicht meinem Customer Account hinzufügen konnte (also das asset)
Den Asset selbst, kann man aufrufen ... allerdings steht hier dann und das ist nun wirklich absolut strange, als Attribute folgende:

"Versanddatum Januar 01, 0001 Land: Unknown"

1 ANTWORT 1
Community Manager
Community Manager

Re: Dell XPS 13" 7390 /w i8650U # GPU Hangs: freezes

Hallo,

 

deine Erfahrung tut mir wirklich sehr leid.

 

Lass mich bitte die Service Tag Nummer per private Nachricht wissen, damit ich mir die Einträge in der Datenbank ansehen kann.

 

 

DELL- Martin M
EMEA (Europe, Middle East, Africa) Social Media Support