Last reply by 03-08-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

Dell XPS 15 ethernet hardware issues

Hi. I'm currently having some issues with my ethernet network connection on my Dell XPS 15 9570. The XPS doesn't have an ethernet port, but I've got a USB3.0 gigabit ethernet adapter because ethernet is more reliable than WiFi where I live. This setup has worked for about a year. Now, however, the connection keeps dropping for a few seconds once every few minutes.

There are several things I've noticed, and some things I tried to troubleshoot this issue:

* I've tested my ethernet+adapter setup on two other devices and it works fine on those.

* I have tried updating/reinstalling the network adapter driver (Realtek USB GbE Family Controller).

* My device is dual booted with Windows 10 and Ubuntu 18.04. The connection behaves the same way on both operating systems.

* The issue persists when I use either USB port on my laptop.

* I used to have a USB-C ethernet adapter, but when I was using that device my XPS very often failed to connect to the ethernet at all. This was why I bought the USB3.0 ethernet adapter.

This leads me to believe there is a hardware issue in my laptop. Does anyone know how the hardware handles a network connection via the USB ports? I know there's a WLAN adapter in the XPS which can easily be replaced, but I don't suppose that that one has anything to do with my ethernet connection issues.

My theory is that it's an issue with the network card. I believe the network card for the XPS 15 is integrated on the motherboard. Can anyone confirm this? Is this part replaceable? Or would I have to replace the full motherboard if that is the issue?

I hope someone can help me with this. Thanks in advance.

Labels (3)
Replies (9)

Tried all the other fixes but disabling Mac Address Pass-Through in BIOS fixed the constant disconnects for me. 4 days no drops...thanks!

2 Bronze
2 Bronze

This one was driving me nuts for two days. I took an XPS 15 9570 that's been in use for years without issue (ethernet or otherwise), wiped it, and installed Windows 10 from the latest ISO. Once in Windows I did a full install of all the latest Dell drivers, firmwares, and BIOS. After doing the BIOS update my downloads would bomb out after a few seconds. Switching to Wi-Fi and everything worked fine, back to ethernet and I'd get that spotty connection.

Troubleshooting: I uninstalled that Realtek USB gigabit ethernet driver and reinstalled it with every version I could find. Didn't work. I let Windows update do it for me. Didn't work. I hopped between the little Dell USB-C to ethernet dongle, a TB16, WD19, and WD19TB dock. Same issue on all of them. In Windows Device Manager I cleared the save power checkbox on every USB device with a Power Management tab. Didn't work.

My Solution: I made my way into the BIOS to see if maybe there was a Thunderbolt setting or something that might look suspect. I cleared the processor C-States which I remember fixed some issue several years ago, might have been freezing, but that didn't fix this. What ultimately did was under Post Behavior > MAC Passthrough, I set it to Disabled and now my ethernet connections are solid (tested on the type-c dongle and the WD19). This is likely another breadcrumb that leads to the actual issue, but since I don't need machine's MAC address to be passed through for anything, I'm happy leaving it here. Hope this helps someone else out there, maybe years from now!


Hi @macBAR ,

Since my last post, I have bought the Delock USB 3.0 gigabit ethernet adapter. When I first used that new adapter, it showed the same symptoms as my old adapter. However, after about an hour, the problems disappeared and it has performed perfectly ever since. So that fixed my problem.

When I get the chance, I can test if my old adapter still malfunctions. If it doesn't, it might be the case the my new adapter triggered some driver installs/updates to fix the problem. This would mean that the original problem was driver related. However, I still think it's most likely that my old adapter simply wasn't working.

Hope that helps!


@jurrdb Did you manage to fix the problem?  I have similar issue with 9570. I cannot squeeze more than ~270MBs downlink. Exactly same tests on Windows 10 and Ubuntu 18.04. No matter if it is DELL DA200 (USB C), DELL TB16 (USB C) or other USB 3.0 Gigabit Ethernet Adapter.


@jphughanToday the ethernet worked flawlessly, surprisingly. However, I started having issues with my mouse, which was plugged in to the adapter's USB ports (which it also has, like the ones you mentioned). The mouse started dropping signal at a similar rate as the connection was dropping before. This does convince me that my troubles are coming from the adapter itself, which is kind of a shame as it's only about a year old.

Anyway, thanks again for your help, I will see if a new ethernet adapter will fix the problem. Will go for one from Dell this time.


I am having similar issues with ethernet dropping but I'll start a separate thread. 


@jurrdb  happy to help!  Even before you replied back, I actually wondered if the dropouts might be correlated with high traffic periods.  On a somewhat related note, I once had a SATA to USB adapter that would occasionally crash, causing the disk to disappear and reappear a few seconds later, but of course interrupting any activity that had been going on.  I finally realized that it only happened under sustained heavy write activity, even though heavy read activity was fine.  Needless to say, it ended up in the trash once I figured this out.

If you're not having trouble with any other peripherals plugged into the same port, then my guess is indeed that a problem may have developed with your adapter.  I had a USB Ethernet adapter once that suddenly would only ever negotiate at 100 Mbps rather than Gigabit, and after losing a LOT of time dealing with drivers, diagnostics, reboots, etc., I just happened to notice that two of the 8 pins inside the adapter's network jack itself had somehow been pressed farther back into the connector than the others.  I opened up the adapter, moved the pins back into place, and I had Gigabit again.

Anyhow, Gigabit Ethernet to USB adapters are quite inexpensive these days, even nicer ones that have things like aluminum rather than plastic casing and a built-in USB port so that you don't lose a system USB port as a result of using the adapter.  I would suggest buying one from a retailer with an easy return policy.  If you're seeing problems as frequently as you're describing, it should become clear one way or the other fairly quickly whether a different adapter will behave any differently.  I've happily used adapters from StarTech, Anker, and Dell.  The Dell adapter I have is the DA300, although that's more expensive because it does more than just Ethernet.


@jphughanThank you for your quick reply and your thorough explanation.

The ethernet adapter I have is this one, the Orico USB3.0 Hub with Gigabit Ethernet Converter.

About the driver; I tried removing the driver and downloading the ORICO Wired Gigabit Network Card HUB_Driver instead, but that doesn't solve the issue. Moreover, that site doesn't seem fully legit, as the connection isn't secured, and moreover, the setup shows that it's the Realtek driver again. I'm not really sure what to think of this.

I'm glad to hear the you think it's not related to hardware issues IN my laptop. You're right that I'm not experiencing any issues on other usb-c peripherals. However, I'm not yet fully convinced it can be software related either, since the issue started happening on both my OSes around the same time.

Another thing I noticed is that the ethernet disconnects more often when I'm using my network more heavily, for example when I'm downloading. I read somewhere that this might be a heating issue, although none of my devices/peripherals seems exceptionally warm. Some people online also suggest turning off battery-saving settings in the driver settings in Window's device manager, but this did not solve anything for me.

I'm kind of worried that if I buy another ethernet adapter, it will not work either. Especially since I used to own another ethernet adapter (a usb-c one), but got rid of it since it didn't work properly with my XPS.

Please let me know if you have another take on this. Thanks again for your time.

7 Plutonium

@jurrdb  there is no Ethernet controller or "card" embedded into the XPS 15's motherboard, because as you say the system has no built-in Ethernet.  If the system had such a controller, it would also have an Ethernet connector on the system itself. USB Ethernet adapters work by having an Ethernet controller chip built into the adapter itself.  It's just that whereas an internal Ethernet controller/card would be embedded onto the motherboard or installed as an actual expansion card (in desktops/servers) and would therefore communicate with the system over PCIe, a USB Ethernet adapter connects its controller to the system over USB (to a USB controller that then connects over PCIe).

Are you sure that the Realtek driver is the correct one for that particular adapter?  That driver is listed on the XPS 15's support.dell.com Drivers page because that's the correct driver for Dell docks that can be used with the XPS 15 -- because that's the controller that Dell chose to embed into those docks.  It will NOT necessarily be the correct driver for the USB Ethernet adapter that you have, because there are of course multiple vendors making Ethernet controllers, and the manufacturer of your USB adapter may have chosen to use a different chipset.  Simply having the Realtek driver installed shouldn't be causing any problems even if it's unnecessary, but you might want to make sure you're running the latest version of the driver that's actually appropriate for your adapter.  Since you unfortunately didn't specify which specific USB Ethernet adapter you have, I can't tell you what the correct driver would be.

All that said, it admittedly would be strange for a driver issue to be the culprit if you're seeing this behavior on two different OSes running on that system -- unless you just happen to have outdated drivers on both OSes.

If driver updates don't resolve this, I would start by testing another USB Ethernet adapter, even though I realize that you've successfully tested your existing adapter on other systems.  The reason I say that is because if it's a hardware issue with the XPS 15, it would likely be related to the USB controller somehow -- although in that case if you're observing these problems even when connecting it to different USB ports, I would expect you to see issues with other USB peripherals as well.

And no, the WLAN adapter shouldn't make any difference to the operation of a USB Ethernet adapter.

Latest Solutions
Top Contributor