Highlighted
Gotopik
1 Copper

Dell XPS NVIDIA GPU not being used

Hi there

My Story

In January, after the "forced" install of the Windows 10 Fall Creators Update, my Dell XPS 15 was caught in a bootloop. Meaning Windows was rebooting itself and only displaying "installing updates" for hours. So I had to reinstall Windows using a Windows Boot-USB-Stick. I encountered no errors during the installation and everything seemed to be working as usual afterwards.

My Issue

Only some hours later I realized, that some of the Apps I use weren't working anymore. So first I blamed the Apps for it, e.g. Adobe Premiere Pro and L*ague of Legends. With the App's Online Support I tried many solutions on how to make the apps run again but none of them seemed to work. They were - and still are - crashing on start.

By analyzing the crash log files with App's Support Team, we realized, that althought my NVIDIA GPU is installed properly it isn't being used by Windows.

What seems to be working

  • All drivers are installed and up to date.
  • In Device Manager both Display adapters, Intel HD Graphics 530 and NVIDIA GeForce GTX 960M are displayed and "working properly".
  • The "Preferred Graphics Processor" is globally set to NVIDIA.

(Nevertheless, NVIDIA GPU is not being used)

What has already been done

  • Apps have been uninstalled and reinstalled.
  • All drivers have been properly installed, uninstalled, reinstalled, updated.
    Please do not advise me to reinstall or update my GPU drivers.
  • Boot Mode has been switched from BIOS back to UEFI, because in one of Dell's Community threads they figured that on some modern graphic processors only work in UEFI boot mode.
  • I have been in contact with Dell. They sent me a technician home who replaced my motherboard and GPU. That didn't resolve the issue. However, we can be pretty sure now that there is no hardware problem.

Interesting

When manually disabling Intel GPU in device manager, Windows will use "Windows Basic Display Adapter" and still not the NVIDIA GPU. Also the NVIDIA GPU is no more "working properly" but displays "error 44" in device manager.

Next steps

Dell advised me to reinstall Windows. However Windows doesn't recognize my SSD during installation, so I'm always getting stuck in installation process. I copied the newest SATA drivers from Dell's website on an USB-Drive but Windows couldn't load "any certified drivers" during the install.

The "WHY"

Dell offered me to send my laptop to their lab (for free (warranty)). However, I'm afraid that they will just reinstall Windows and everything will seem to be working properly and they will send it back without trying to reproduce the issue (running 3D Apps).

However, if you guys don't know any solutian that is exactly what I will do.

Please help me, you're my last hope.

My System

Spoiler
OS Name    Microsoft Windows 10 Pro
Version    10.0.16299 Build 16299
Other OS Description     Not Available
OS Manufacturer    Microsoft Corporation
System Name    NICK
System Manufacturer    Dell Inc.
System Model    XPS 15 9550
System Type    x64-based PC
System SKU    06E4
Processor    Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz, 2601 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date    Dell Inc. 1.2.12, 14.07.2016
SMBIOS Version    2.8
Embedded Controller Version    255.255
BIOS Mode    UEFI
BaseBoard Manufacturer    Dell Inc.
BaseBoard Model    Not Available
BaseBoard Name    Base Board
Platform Role    Mobile
Secure Boot State    Off
PCR7 Configuration    Elevation Required to View
Windows Directory    C:\WINDOWS
System Directory    C:\WINDOWS\system32
Boot Device    \Device\HarddiskVolume3
Locale    United States
Hardware Abstraction Layer    Version = "10.0.16299.248"
User Name    NICK\Nick
Time Zone    W. Europe Daylight Time
Installed Physical Memory (RAM)    16.0 GB
Total Physical Memory    15.8 GB
Available Physical Memory    7.80 GB
Total Virtual Memory    18.2 GB
Available Virtual Memory    8.12 GB
Page File Space    2.38 GB
Page File    C:\pagefile.sys
Virtualization-based security    Not enabled
Device Encryption Support    Elevation Required to View
Hyper-V - VM Monitor Mode Extensions    Yes
Hyper-V - Second Level Address Translation Extensions    Yes
Hyper-V - Virtualization Enabled in Firmware    Yes
Hyper-V - Data Execution Protection    Yes

 

8 Replies

Re: Dell XPS NVIDIA GPU not being used

Did you ever resolve this? I’m having the same issues with the graphics card doing no work and apps crashing on startup (mainly 3D apps). Hope you can help it’s driving me nuts!

ejn63
5 Rhenium

Re: Dell XPS NVIDIA GPU not being used

First:  be sure you understand how your system functions.  It does not have a true, discrete GPU.  It has a software-controlled hybrid setup in which the Intel GPU is permanently wired as primary and the nVidia GPU is solely a co-processor for the Intel GPU.  As such, ALL video data passes through the Intel GPU on its way to the screen.  ONLY the Intel GPU has a physical connection to the display panel.  

It can be difficult to tell whether the nVidia GPU is active because Windows will see the Intel GPU as primary.

On some newer XPS systems, the nVidia GPU is hardwired to the thunderbolt port and will drive the external screen without the Intel GPU -- but not the internal one.

Many (most) 3D applications are built to run with a true, discrete GPU. They may need to be setup to work with hybrid video - or may only work partially -- or not at all.  Autodesk and Adobe applications in particular often have issues with hybrid video setups.  For those, check with the software publishers for the recommended settings.

There are some third-party applications out there that can tell you whether or not the nVidia GPU is active.  In general, it will be if you set the application to run with it, AND the application supports hybrid video (there are plenty of applications that do not -- some 3D apps and many, particularly older games -- do not).

 

Re: Dell XPS NVIDIA GPU not being used

Exactly the same problem over here... anyone knows a fix for this dumb bug?
BroBot92
3 Argentium

Re: Dell XPS NVIDIA GPU not being used

I'm also having similar problems.

As mentioned on the message board, the Nvidia GPU passes frames to the Intel iGPU to be displayed on the panel or via HDMI out. Unfortunately the drivers responsible for the switching are fragile, probably broken or conflicting with Windows after the update. I have updated, downgraded and tried everything with both the "official" Dell drivers and regular ones. (Nvidia, Intel HD 630, Intel Dynamic Platform Thermal Framework, etc)

Even with a factory re-image from the recovery partition using the stock drivers, I still have problems with both frame-rates and performance. Most of my apps launch fine, but games and applications will slow to a crawl or the fps will dip significantly to 10-15 fps after a minute or so. Videos also lag for the first 3 seconds and have a grid pattern (broken hardware up-scaling?). I also suspect the Nvidia GPU isn't used properly.

It gets weirder. Running a game in Steam with the fps counter set to on - will show 100+ fps, but the game will start to lag soo much it becomes unplayable after 1 minute. I can change the graphics setting from low to ultra, change the resolution from 720p to 1440p and it makes no difference. The frame-rate still appears to be around 15-20fps with massive lag spikes, despite the fps counter showing 90-150fps.

Dell has also has issues with throttling and has recently changed the BIOS to significantly down-clock the GPU at 74 degrees when it was set to 78 degrees before. Users have reported it drops to 400mhz or more than 50% of the performance. While this may a play a part in the reported issues, something is seriously broken with the XPS laptops as even more threads such as this are appearing.

0 Kudos
BroBot92
3 Argentium

Re: Dell XPS NVIDIA GPU not being used

Copied my post from another thread:

Notice the temps and 100% utilisation below? How is it that the card is maxing out at 47 degrees C in a benchmark? Score should be around 5000.

Superposition_Benchmark_v1.0_843_1540293464.png

Plugged in, Power plan set to high performance, Official drivers up to """date""" according to the Dell website. Preferred GPU set to "Nvidia". Clean install from the factory image partition a few days ago...

0 Kudos
BroBot92
3 Argentium

Re: Dell XPS NVIDIA GPU not being used

After running the test over and over and over again, finally this happens:

Superposition_Benchmark_v1.0_4974_1540296183.png

This is a really annoying problem. Performance is now in the normal range - however this is short lived and very temperamental. It pretty much goes back to rubbish, I magically jagged this result. Dell please fix!

BroBot92
3 Argentium

Re: Dell XPS NVIDIA GPU not being used

Hi all,

This is indeed BIOS related. It is a very strange temperature bug - causing performance issues under 48 degrees. Yes, completely ridiculous! See the recent article below - it also confirms my experience running the Unigine benchmark from other posts. Hopefully Dell will finally fix it now the issue is growing...
https://www.notebookcheck.net/Some-Dell-XPS-15-9570-laptops-may-have-a-BIOS-related-GPU-bug.355026.0...

0 Kudos
xr280xr
1 Copper

Re: Dell XPS NVIDIA GPU not being used

Then what use is it? I thought I was getting a laptop with only an nVidia GPU with dedicated memory that would boost my performance all the time and it seems like it's never actually going to be used? I'm not even gaming, just doing software development.

0 Kudos