Last reply by 08-15-2021 Solved
Start a Discussion
2 Bronze
2 Bronze

Dell XPX 15 7590 cannot upgrade windows 10 to 20H2 (and 20H1) Failed at 10% and undid changes


I have Dell XPX 15 7590 that is stuck on Windows 10 version 1909 since 13/09/2019 and has not been able to to install updates ever since.

I do not know if it is related but a few months ago I randomly was prompted for the bit locker key when I turned on the system.  I have no idea how or why this happened. I did not even know I had bitlocker up to that point. I can only assume it was something to do with the dell support assistant or the dell update app that caused it.

I have tried extensively to troubleshoot, tried DSIM, SFC and CHKDSK to check for corruption and errors, searched the internet for a solution and no matter what I have tried the windows 10 update 20H2 fails to install at 10% and undoes changes and stay at version 1909.

I have tried to update the system via windows updates and via the MS media creation tool.

The media creation tool shows this error when back in windows after each failed attempt:


0x8000700A1 - 0x20007

The installation failed in the SAFE_OS phase with an error during INSTALL_DRIVERS operation.




Version 1909 is now end of life and I can't upgrade the system.

I checked the Windows Update client event log (Microsoft-Windows-WindowsUpdateClient/Operational) after the last failed attempt and see these flowing errors:

Windows Update failed to download an update:

  updateTitleIntel Corporation - SCSIAdapter -


Windows Update failed to download an update:

  updateTitleSTMicroelectronics - System -



I am at the end of my tether with this. 

Hoping there is a way to fix this without having to a clean install on Windows 10.

Please advise!



Replies (10)
2 Bronze
2 Bronze

Thank goodness that intel provides the support that dells update assistant was supposed to be able to provide.


Latest Solutions
Top Contributor