XPS

Last reply by 11-29-2022 Solved
Start a Discussion
165

G7 7700 Intel Management Engine Security Vulnerability

Dell G7 17 7700

Hello,

Intel released a new version of the CSME Detection Tool. When I run this on my Dell G7 7700 with BIOS v1.20 it shows that the system is vulnerable. So we did have a similar case in 2021: Dell G7 7700 Management Engine Security Vulnerability - Dell Community after which a ME firmware update was released by Dell for the system. I assume a new firmware update is needed to resolve the open issues? When can we expect Dell to get this done?

<Image removed because it displayed your private Service Tag. DELL-Admin>

 

 

Solution (1)

Accepted Solutions
Community Manager
77

As I stated in your three other threads, all you and we can do is check the Inspiron G7 17 7700 driver page for updates.

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag


View solution in original post

Replies (3)
144

Dell,

Even though my warranty has expired, this is an outstanding issue with the G7 17 7700 system! According to Intel: INTEL-SA-00610 the CSME firmware needs to be updated to v14.1.67 or higher. The latest BIOS 1.20 comes with CSME firmware 14.1.65. A simple "we're working on it" would be enough. Thx.

127

Well this is exactly what I would call bad customer service.  

Community Manager
78

As I stated in your three other threads, all you and we can do is check the Inspiron G7 17 7700 driver page for updates.

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag


Latest Solutions
Top Contributor