Last reply by 07-03-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

How to Disable Modern Standby for XPS 15 9500

Hello folks,

Please advise how to revert S0 modern standby to S3? I have various issues with it, random wake up, battery drain, overheating in a bag while commuting, sleeping problems at the end of the day... cause it just wakes in the middle of the night. This feature is absolutely disaster for laptops. I have smartphone which has this feature and laptop serves for different purpose 

I really need this to be solved, otherwise I'm ready to return my new laptop back.


Replies (39)

Same problem here with my new Precision 5550 and Windows Build 2004. Hope to see a solution soon. 


What are you doing at the moment as a result of this "feature"?  shutting down?

One of the side-effects I have noticed I think is that while it is on this modern standby, the SSD use counter when running any of the drive tools (crystal for instance) states the clock is ticking even while the lid is shut.

My worry is this is causing unnecessary use of the SSD when not actually doing anything and this tied in with the heat build-up...

In my case, I am shutting down now but its a right annoyance having to then reopen all my tabs or software that until now, has just been fine for years on standby


Yes, shutting down is the only safe way to put it in the bag.

While in normal operation. modern standby really <Profanity removed> because it doesn't always keeps network alive. When I get back to computer, I have to reopen some aplications more sensible to network changes (RDP for example). 


All - I have the exact same issue - brand new 5550 precision - fresh install less than 3 days old. Thought I was going crazy. So I guess, for now, I'm going to set it so that when I close the lid, I'm going to have the machine hibernate. While not as elegant as Sleep, the restore time seems pretty quick all things considered. Not as fast as coming out of Sleep - but it's functional and the machine won't kill itself. I do completely agree though - a laptop for 3k shouldn't have problems using a feature that's so <Profanity removed>standard across the board.


Incidentally, for those on Windows 10 May 2020 update (2004), you may have noticed that to add insult to injury Microsoft has removed the UI switch to always turn off network while in sleep. I'm happy to confirm that this can still be done through the registry, though - see option 5 on this page:


powercfg /a confirms that resulting sleep state is "Standby (S0 Lower Power Idle) Network Disconnected". ACSettingIndex for A/C power, DCSettingIndex for battery.


This is how you can disable modern standby in Windows 10 and enable S3 sleep https://superuser.com/a/1539097

However, Dell's BIOS bug prevents it from waking up - this needs to be fixed before S3 is usable on the Precision 5550 and XPS 9500. As a temporary workaround, we'll have to live with battery drain and potentially having the laptop blow up on us  when it gets too hot in the backpack!

I'm sure Dell's already on top of this issue. We'll just have to wait for a new BIOS!


I changed to hibernate when lid is shut, but today right after I closed the lid the machine got very hot again. Fans went crazy and I had to open the lid again and switch off the laptop, because the screen only showed dell logo and didn't react on anything. It was just the same when the action on closing the lid was sleeping. Is there a chance that Modern Standby is not an issue and the problem is somewhere else? 

2 Bronze
2 Bronze

I have never had a problem with sleep mode until I bought Dell XPS 7590... In sleep mode battery drains over night from 100% to 18%. If I have it in backpack it is hot. I dont want to shut down my notebook every time I move somewhere, I have open many apps and I dont want to reopen them every time. I moved from Lenovo in believes that Dell is more reliable, but it was a mistake, now I think I should had choose HP

2 Bronze
2 Bronze

I fixed the random wake up issue (including battery drain, overheating, unnecessary use and degradation of resources) by running in a command line first:


powercfg /setacvalueindex scheme_current sub_none F15576E8-98B7-4186-B944-EAFA664402D9 0


Then in the Registry Editor go to:

HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control -> Power -> PowerSettings -> F15576E8-98B7-4186-B944-EAFA664402D9 -> edit Attributes and set Value data to 0


I stopped having those nasty issues after this.



I just discovered that issue on my new Precision 5550 (Ubuntu Mate 20.10).

After almost burning my bagpack after a failed sleep tentative for 30 minutes, I understood S2idle was the issue. I tried to switch from suspend_to_idle to suspend-to ram as in my previous laptop (XPS15). Now, the laptop goes to sleep ok with fans stopping as should be, but ... it won't wake up.

Have you heard news on that Dell bug you mentioned? (my bios is the latest - updated in january but that did not fix it) Did you finally find a workaround?

Thanks a lot

Latest Solutions
Top Contributor