Last reply by 12-13-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Installing a samsung 980 EVO Pro SSD to XPS 13 Plus 9320 issue

Hi guys

I would appreciate for some help pls.

I am wanting to install the samsung SSD 1Tb to 9320 but I'm not having much success.

3 methods I've tried and issues encountered so far:

1. I imaged the original ssd of 9320 and tried to image it onto the new samsung ssd using macrium but could not select it as a destination after installing the samsung ssd into 9320. The samsung SSD showed up in the bios but macrium could not see it . I downloaded intel drivers and tried installing it while in the macrium bootmenu but no luck.

2. So imaged the original ssd of 9320 onto the new samsung ssd using a ssd enclosure through macrium. Installed the samsung ssd onto 9320  but tries to repair windows but fails to do so.

3. I downloaded win 11 iso onto usb and through onetime boot option, tried to clean install win11 but no boot from usb option available despite enabling boot from usb option in the bios.

I've spent 2 weeks and accidentally deleted my backup external hard disk (i tried dos clean disk option.....) trying to get this to work.....

I would be grateful for help to get the system working!


Replies (12)
3 Zinc

If you are going to do a completely fresh install of Windows 11 from USB, you must use the Windows Media Creation tool from Microsoft. Once it has created the USB you must download the Intel RST driver (specific for your laptop) in the ZIP file format and unzip it to your USB. This should then allow you to detect the SSD when performing the install.

2 Bronze
2 Bronze

Thank you d5123101.




I ve tried that but the issue is that I am unable to boot from usb. Even in the bios, I can't seem to enable it.




Any suggestions as to how to enable bios to boot from usb?







3 Zinc

Can you take a picture of your system when you enter the one time boot menu when you're hitting F12 on boot? You're using a USB C to USB A adapter for the USB flash drive?




Thanks d5123101


Yes, I'm using USB A to C adapter for the flash drive.


This seems to be a multi-part question.  So, perhaps it would be best to get your USB drive situation working.  If you are running Optane Memory on that system, it can make a difference with how you install.

You can allow the Media Creation tool to create the flash drive.  The reason is, there is a file in there that is too large to go on a normal Fat 32 drive.  The MCT splits it for you so it will copy normally.

Note:  Some newer systems, can use a NTFS formatted drive to boot into UEFI.  If your system will do that, all you have to do in format the drive as NTFS then mount the .iso and copy over the files.   Everyone needs a working Install Media drive as a backup for normal operations.

Once you have the flash drive created, you can insert it before you start the boot and use the F12 key to get a boot device menu and then select the UEFI version of the drive to boot.  When you select the F12 key, you have to start tapping the key very early in the boot process and keep tapping until you see a message.

Maybe after you tie down the USB situation, everything else will be easier to deal with.

As normal practice, do not leave an original drive installed while trying to use a cloned or imaged version of it.

XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720, AW3423DW
System fully Win 11 compliant
2 Bronze
2 Bronze

Hi guys 

So I managed to get the system to boot off the usb and clean installed win 11.

When all seemed going well, the progress stops at connecting to wifi page. It is coming up blank, no available network to select or even give me a local install and connect later.

Any suggestions?


Thanks saltgrass. Explanation regarding the media creation tool was helpful as I could not understand why I couldn't copy the iso file on to non ntfs usb. And my system wouldn't boot off ntfs usb.


If you are referring to the part of the install that requests a network, you can say you don't yet have one and the install should proceed.  

XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720, AW3423DW
System fully Win 11 compliant

Hi saltgrass


So I tried again, trying to find a no network option but there is none and I am unable to proceed.

Pls see the screen shot.

Is there a work around?


Latest Solutions
Top Contributor