Highlighted
2 Bronze

Intel Management Engine driver update on XPS 9360

Jump to solution

Some time ago a new Intel Management Engine driver appeared at Dell's downloads page - 1829.12.0.1154, A02. Has anyone managed to install it successfully on their XPS 9360?

For me each install attempt ends up with a fatal error. I am however able to install the previous driver version (11.7.0.1054, A01) without any problems.

Interestingly, I reimaged my Dell a few days ago and wanted to start with the new driver, and the effect was the same - it wouldn't install at all.

If I'm reading the long installation log correctly, I'm getting the 1603 installation error, which per my search can basically mean anything...

0 Kudos
1 Solution

Accepted Solutions
Highlighted
7 Thorium

Re: Intel Management Engine driver update on XPS 9360

Jump to solution

Laptops rarely if ever get updated drivers. If the driver doesn't install it means you either already have it or you don't need it for your specific motherboard. It is probably for newer motherboards than yours or to solve a problem you do not have. Don't force it.

View solution in original post

0 Kudos
3 Replies
Highlighted
7 Thorium

Re: Intel Management Engine driver update on XPS 9360

Jump to solution

Laptops rarely if ever get updated drivers. If the driver doesn't install it means you either already have it or you don't need it for your specific motherboard. It is probably for newer motherboards than yours or to solve a problem you do not have. Don't force it.

View solution in original post

0 Kudos
Highlighted
2 Bronze

Re: Intel Management Engine driver update on XPS 9360

Jump to solution

Well, possibly - when I check the driver properties, it looks the one already installed (12.0.2021) is even never that the one offered by Dell (12.0.1154) - I assume I can disregard the initial part.

Capture.JPG

0 Kudos
Highlighted

Re: Intel Management Engine driver update on XPS 9360

Jump to solution

Hi kikorutko,

 

Thanks for posting and for providing your service tag information.  

 

From reading the Forum, it appears your issue has been resolved.  

 

Regards,
Robert

0 Kudos