Wurlitzer165
2 Bronze

Internet good, but many web sites won't load.

Jump to solution
Same issue on XPX 13 and XPS 15. Have six computers on site, with very strong ethernet and wifi internet. About a week ago, the XPS laptops would no longer load many web pages, going to the usual, "this site can't be reached". Some sites load perfectly, like google, Facebook, Instagram, email, and others. Most others will not load. I've tried both Ethernet and WiFi, moved computers do different access points and locations. No difference. Other computers, connected to same Ethernet and / or WiFi load perfectly at speeds around 400 Mbps. Sometimes, and briefly, they will load and operate normally, but it's a fool's promise, as they soon revert to same behavior. I've tried the command prompt "netsh" and "winsock refreshes" found on various support boards. No change. Rebooted numerous times. Switched cords, WiFi, ports, etc. No change. So strange, as the internet is strong, many sites load, but most will not. I'm a reasonably sophisticated user, but this has me stumped! Any ideas? Thanks!
0 Kudos
1 Solution

Accepted Solutions
JOcean
5 Iridium

Re: Internet good, but many web sites won't load.

Jump to solution

Try this YouTube video. Just wondering if you have an antivirus with internet protection on those systems.

https://www.youtube.com/watch?v=RBwtQEWt6L0




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with MSI B-460 Torpedo MB with an Intel i5 10400
Real work on an Inspiron 15 5575 and Latitude E5430

View solution in original post

0 Kudos
2 Replies
JOcean
5 Iridium

Re: Internet good, but many web sites won't load.

Jump to solution

Try this YouTube video. Just wondering if you have an antivirus with internet protection on those systems.

https://www.youtube.com/watch?v=RBwtQEWt6L0




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with MSI B-460 Torpedo MB with an Intel i5 10400
Real work on an Inspiron 15 5575 and Latitude E5430

View solution in original post

0 Kudos
fanic
1 Copper

Re: Internet good, but many web sites won't load.

Jump to solution

I also faced this issue.

 

I expect some problem with the Dell automatic cleanup and the cache of browsers.

Wiping the whole Browser cache helped for me. 

0 Kudos