XPS

2 Bronze

Is Dell XPS 15 known to be bad for audio work? Recordings always hiccup.

My XPS warranty has expired so I'm wondering what hope there is to identify the problem I've been suffering with ever since I got this fancy computer.

It is fancy for spreadsheets and office stuff, but for my audio recording it has been awful.  I lose a random < 1s of time, randomly, during my recordings.  

I've asked around about optimizing win10 for audio, tips from the Adobe Audition forum, tried going into airplane mode before recording, looked at task manager.. nothing has changed, I have to scrutinize every recording I do because there is going to be random bits of time missing that need "fixing".

I can't reproduce this problem on demand, it is random.  I can't imagine an experiment to reveal it.  

Is there anything Dell can do for me, if I buy a warranty extension?  

Thanks for any advice

 

update: my latest glitch I did the math and it was 0.500 seconds missing

Dell XPS15, 32GB RAM, 1 TB (25% full)
Win10 64bit
Steinberg UR22
Adobe Audition 12.1.5.3
All my software is legit
Labels (2)
Replies (3)
7 Thorium

@hardware408  Google "XPS 15 DPC Latency".  In fairness, there are quite a few other systems, both Dell and non-Dell, that have DPC latency issues that affect real-time audio recording -- but yes, it's a known issue.


@jphughan  thank you for validating my issue.

When I google Dell XPS DPC Latency I do find a lot of familiar issues.  Now I know that "dropouts" is what I've been hating life from for the last two years.  

I hope I will stumble on something to help now other than abandon the Dell. 

Thanks again for taking the time to reply, I was lost.

 

Dell XPS15, 32GB RAM, 1 TB (25% full)
Win10 64bit
Steinberg UR22
Adobe Audition 12.1.5.3
All my software is legit
2 Bronze

I had some success today with my issue.   It seemed to work fine until I typed.    Then the sound would be wonky and artifacty typing or not from then on.     Even in the sound recorder.    I found a setting in the Maxxaudio program under the voice tab.   Basically I turned that off in there.   And the recordings so far are better.   You can hear my typing and room noises but the recording doesn't descend into a mess of digital artifacting.    I prefur to hear the background noise then.  

 

 

Top Contributor
Latest Solutions