2 Bronze

M1330 throttles the CPU

Jump to solution

I have an old XPS M1330. Every time I start it, "HWiFO" shows On-demand clock modulation at 75%. Each time to make it 100% I have to run "ThrottleStop", check and uncheck Clock Modulation, that's set to 100% by default. I found this trick on the internet. I don't really know/understand what's that "ThrottleStop" program for, just doing that exercise as long as it serves the purpose. Just don't want to keep it always checked, cause as I told I don't know what will it affect on. I also learnt from other forums that this may be related to battery. The battery is so old that the system doesn't even see it, even in BIOS. So I'm using it plugged in to power all the time. Any idea if this issue may be resolved without buying a new battery, cause this laptop is not worth the price of a new battery?

0 Kudos
1 Solution

Accepted Solutions
2 Bronze

Re: M1330 throttles the CPU

Jump to solution

Resolved!
Under BIOS/Performance there is a setting called Virtualization meant for Virtual Machine. When On, the system allocates those 25% for Virtual Machine I guess. After turning it off the issue is gone.

View solution in original post

0 Kudos
1 Reply
2 Bronze

Re: M1330 throttles the CPU

Jump to solution

Resolved!
Under BIOS/Performance there is a setting called Virtualization meant for Virtual Machine. When On, the system allocates those 25% for Virtual Machine I guess. After turning it off the issue is gone.

View solution in original post

0 Kudos