Highlighted
Chan888
1 Copper

Owner of XPS 12 9q33 CPU Clock locked to 0.79MHz

Hi

I had installed Windows 10 Pro and my clock speed locked to 0.79MHz and here my solution.

In Computer Management, under Batteries - Disable the Microsoft ACPI-Compliant Control Method Battery in the Driver Tab.  Restart your PC.  

Mind is now 100% normal.

Chan

0 Kudos